From 4df43632bee24052820b3f29e315c46e4cc5fbcc Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Wed, 17 Aug 2011 21:48:18 +0000
Subject: sysvinit: Make changes to ensure halt/reboot work.

---
 abs/core/sysvinit/PKGBUILD    | 10 ++++++++--
 abs/core/sysvinit/__changelog |  6 ++++++
 2 files changed, 14 insertions(+), 2 deletions(-)

diff --git a/abs/core/sysvinit/PKGBUILD b/abs/core/sysvinit/PKGBUILD
index 110d93c..3be24b0 100644
--- a/abs/core/sysvinit/PKGBUILD
+++ b/abs/core/sysvinit/PKGBUILD
@@ -4,14 +4,13 @@
 
 pkgname=sysvinit
 pkgver=2.88
-pkgrel=3
+pkgrel=4
 pkgdesc="Linux System V Init"
 arch=('i686' 'x86_64')
 url="http://savannah.nongnu.org/projects/sysvinit"
 license=('GPL')
 groups=('base')
 depends=('shadow' 'util-linux' 'coreutils' 'glibc' 'awk')
-install=sysvinit.install
 source=(http://download.savannah.gnu.org/releases/sysvinit/${pkgname}-${pkgver}dsf.tar.bz2 halt-init.patch)
 
 build() {
@@ -23,6 +22,13 @@ build() {
 package() {
   cd "${srcdir}/${pkgname}-${pkgver}dsf"
   make ROOT="${pkgdir}" install
+
+  # Rename some stuff so it does not bigfoot changes needed for runit
+  cd "${pkgdir}/sbin"
+  rm -f reboot poweroff
+  mv halt halt-init
+  mv shutdown shutdown-init
+
 }
 md5sums=('6eda8a97b86e0a6f59dabbf25202aa6f'
          'cd4c5767f63ca5881e3e1f1c4f10f896')
diff --git a/abs/core/sysvinit/__changelog b/abs/core/sysvinit/__changelog
index 9dc0b73..2a93469 100644
--- a/abs/core/sysvinit/__changelog
+++ b/abs/core/sysvinit/__changelog
@@ -18,3 +18,9 @@ patch halt to work with runit
          *      Get flags
          */
 
+
+# mjh 08-17-2011
+* mv halt to halt-init
+* mv shutdown shutdown-init
+* rm -f reboot poweroff
+* remove sysvinit.install
-- 
cgit v0.12