From 3a0e257f6d84b473151464699f6ea17d9b350d4c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 26 Sep 2010 01:12:31 +0000
Subject: runit-scripts: update tty2/3 to use tty2 and tty3 instead of vc/2
 added logic around fbsplash-runit to stop it from aborting when fb-slash.conf
 is missing

---
 abs/core-testing/runit-scripts/PKGBUILD            |  5 ++--
 abs/core-testing/runit-scripts/fbsplash-runit.sh   | 35 ++++++++++++----------
 abs/core-testing/runit-scripts/runitscripts/1      |  1 +
 .../runit-scripts/runitscripts/services/tty2/run   |  2 +-
 .../runit-scripts/runitscripts/services/tty3/run   |  2 +-
 5 files changed, 25 insertions(+), 20 deletions(-)

diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index a8087bd..768d311 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=1.8.0
-pkgrel=117
+pkgrel=119
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
@@ -28,4 +28,5 @@ build() {
   install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
   rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
 }
-md5sums=('c6cbd6af3657783bd1ce8f75f574d72f')
+
+md5sums=('46f6261239a06a192a08d10663df0273')
diff --git a/abs/core-testing/runit-scripts/fbsplash-runit.sh b/abs/core-testing/runit-scripts/fbsplash-runit.sh
index aa391b0..fb132b8 100755
--- a/abs/core-testing/runit-scripts/fbsplash-runit.sh
+++ b/abs/core-testing/runit-scripts/fbsplash-runit.sh
@@ -5,23 +5,26 @@
 CALLER=$0
 
 # splash stuff #
-. /etc/conf.d/fbsplash.conf
-. /sbin/splash-functions.sh
+if [ -e /etc/conf.d/fbsplash.conf ]
+then
+	. /etc/conf.d/fbsplash.conf
+	. /sbin/splash-functions.sh
 
 # Redefine the stat functions #
 
-stat_runit() {
-	printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
-	printf "${SAVE_POSITION}"
- 	deltext
-	printf "   ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "
-        # Load variables #
-        var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
-        # Only update the splash progress if we're in sysinit, multi, or shutdown. #
-                ((SPLASH_STEP_NR++))
-                SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
-                SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
-                splash_update_progress ${SPLASH_PROGRESS}
-                var_save STEP_NR CURRENT_PROGRESS
+	stat_runit() {
+		printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
+		printf "${SAVE_POSITION}"
+	 	deltext
+		printf "   ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "
+	        # Load variables #
+        	var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
+	        # Only update the splash progress if we're in sysinit, multi, or shutdown. #
+        	        ((SPLASH_STEP_NR++))
+	                SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
+        	        SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
+                	splash_update_progress ${SPLASH_PROGRESS}
+	                var_save STEP_NR CURRENT_PROGRESS
 
-}
+	}
+fi
diff --git a/abs/core-testing/runit-scripts/runitscripts/1 b/abs/core-testing/runit-scripts/runitscripts/1
index 6e4425d..af6b376 100755
--- a/abs/core-testing/runit-scripts/runitscripts/1
+++ b/abs/core-testing/runit-scripts/runitscripts/1
@@ -9,6 +9,7 @@ hostname `cat /etc/hostname`
 rm /etc/dhcpc/dhcpcd*.pid  2>/dev/null
 rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
 rm -f /etc/runit/reboot 2>/dev/null
+/sbin/agetty -8 38400 tty10 linux &
 stat_busy "Starting network"
 /etc/net/scripts/network.init start 2>/var/log/network.init.error >/var/log/network.init
 stat_done
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/tty2/run b/abs/core-testing/runit-scripts/runitscripts/services/tty2/run
index 8db2924..b2a4fa6 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/tty2/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/tty2/run
@@ -4,4 +4,4 @@ export TERM=linux
 . /etc/rc.d/functions
 stat_runit "Starting Agetty 2"
 
-exec /sbin/agetty 38400 vc/2 linux
+exec /sbin/agetty 38400 tty2 linux
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/tty3/run b/abs/core-testing/runit-scripts/runitscripts/services/tty3/run
index bdbec66..0bafcd4 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/tty3/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/tty3/run
@@ -3,4 +3,4 @@ export TERM=linux
 . /etc/rc.conf
 . /etc/rc.d/functions
 stat_runit "Starting Agetty 3"
-exec /sbin/agetty 38400 vc/3 linux
+exec /sbin/agetty 38400 tty3 linux
-- 
cgit v0.12