From e5d6fb56366922d37f3e820338318414f9cf3faa Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 5 Feb 2019 15:39:14 +0000
Subject: openssl: update to 1.1.1.a

---
 abs/core/openssl/PKGBUILD     | 22 +++++-----------------
 abs/core/openssl/ca-dir.patch | 12 ++++++------
 2 files changed, 11 insertions(+), 23 deletions(-)

diff --git a/abs/core/openssl/PKGBUILD b/abs/core/openssl/PKGBUILD
index caeb0e2..3868826 100644
--- a/abs/core/openssl/PKGBUILD
+++ b/abs/core/openssl/PKGBUILD
@@ -1,11 +1,9 @@
-# $Id$
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=openssl
-_ver=1.1.0g
+_ver=1.1.1a
 # use a pacman compatible version scheme
 pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
-#pkgver=$_ver
 pkgrel=1
 pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security'
 arch=('x86_64')
@@ -14,12 +12,11 @@ license=('custom:BSD')
 depends=('perl')
 optdepends=('ca-certificates')
 backup=('etc/ssl/openssl.cnf')
-source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"
-        "https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz.asc"
+source=("https://www.openssl.org/source/${pkgname}-${_ver}.tar.gz"{,.asc}
         'ca-dir.patch')
-sha256sums=('de4d501267da39310905cb6dc8c6121f7a2cad45a7707f76df828fe1b85073af'
+sha256sums=('fc20130f8b7cbd2fb918b2f14e2f429e109c31ddd0fb38fc5d71d9ffed3f9f41'
             'SKIP'
-            '90c7411fed0157116f2df8f4be755aaf5a26e8484351b4e6a79492805d5f2790')
+            '0938c8d68110768db4f350a7ec641070686904f2fe7ba630ac94399d7dc8cc5e')
 validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
 
 prepare() {
@@ -32,18 +29,9 @@ prepare() {
 build() {
 	cd "$srcdir/$pkgname-$_ver"
 
-	if [ "${CARCH}" == 'x86_64' ]; then
-		openssltarget='linux-x86_64'
-		optflags='enable-ec_nistp_64_gcc_128'
-	elif [ "${CARCH}" == 'i686' ]; then
-		openssltarget='linux-elf'
-		optflags=''
-	fi
-
 	# mark stack as non-executable: http://bugs.archlinux.org/task/12434
 	./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
-		shared no-ssl3-method ${optflags} \
-		"${openssltarget}" \
+		shared no-ssl3-method enable-ec_nistp_64_gcc_128 linux-x86_64 \
 		"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
 
 	make depend
diff --git a/abs/core/openssl/ca-dir.patch b/abs/core/openssl/ca-dir.patch
index 1daba84..a140243 100644
--- a/abs/core/openssl/ca-dir.patch
+++ b/abs/core/openssl/ca-dir.patch
@@ -1,5 +1,5 @@
---- apps/CA.pl.in	2016-09-26 11:46:04.000000000 +0200
-+++ apps/CA.pl.in	2016-11-01 16:02:16.709616823 +0100
+--- apps/CA.pl.in	2018-09-11 14:48:19.000000000 +0200
++++ apps/CA.pl.in	2018-09-11 16:16:32.125629435 +0200
 @@ -33,7 +33,7 @@
  my $PKCS12 = "$openssl pkcs12";
  
@@ -9,9 +9,9 @@
  my $CAKEY = "cakey.pem";
  my $CAREQ = "careq.pem";
  my $CACERT = "cacert.pem";
---- apps/openssl.cnf	2016-09-26 11:46:04.000000000 +0200
-+++ apps/openssl.cnf	2016-11-01 16:02:48.378503427 +0100
-@@ -39,7 +39,7 @@
+--- apps/openssl.cnf	2018-09-11 14:48:20.000000000 +0200
++++ apps/openssl.cnf	2018-09-11 16:16:32.125629435 +0200
+@@ -43,7 +43,7 @@
  ####################################################################
  [ CA_default ]
  
@@ -20,7 +20,7 @@
  certs		= $dir/certs		# Where the issued certs are kept
  crl_dir		= $dir/crl		# Where the issued crl are kept
  database	= $dir/index.txt	# database index file.
-@@ -323,7 +323,7 @@
+@@ -327,7 +327,7 @@
  [ tsa_config1 ]
  
  # These are used by the TSA reply generation only.
-- 
cgit v0.12