From 9d60489a74969c68758de7f2515b6b709993a2d1 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 23 Jan 2016 18:06:28 +0000
Subject: talloc: update to 2.1.5

---
 abs/core/talloc/PKGBUILD            | 18 +++++++++++++++---
 abs/core/talloc/fix_test_path.patch | 13 +++++++++++++
 2 files changed, 28 insertions(+), 3 deletions(-)
 create mode 100644 abs/core/talloc/fix_test_path.patch

diff --git a/abs/core/talloc/PKGBUILD b/abs/core/talloc/PKGBUILD
index c19a0fc..15dfc1b 100644
--- a/abs/core/talloc/PKGBUILD
+++ b/abs/core/talloc/PKGBUILD
@@ -3,7 +3,7 @@
 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
 
 pkgname=talloc
-pkgver=2.1.0
+pkgver=2.1.5
 pkgrel=1
 pkgdesc="Hierarchical pool based memory allocator with destructors"
 arch=('i686' 'x86_64')
@@ -12,10 +12,16 @@ url="http://talloc.samba.org/"
 depends=('glibc')
 makedepends=('python2' 'docbook-xsl')
 optdepends=('python2: for python bindings')
-source=("http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.{gz,asc}
+        fix_test_path.patch)
+sha1sums=('bdf3b3d8449e2c354f1ebc43d3e1058160eb4adb'
+          'SKIP'
+          '34132be289f9ce1c38c8b367def8d91ac7dbb706')
+validpgpkeys=(9147A339719518EE9011BCB54793916113084025) # samba-bugs@samba.org
 
 prepare() {
    cd "${srcdir}/${pkgname}-${pkgver}"
+   patch -p1 < ../fix_test_path.patch
    sed -i -e 's#python#python2#g' buildtools/bin/waf
 }
 
@@ -24,12 +30,18 @@ build() {
    ./configure --prefix=/usr \
      --sysconfdir=/etc/samba \
      --localstatedir=/var \
+     --bundled-libraries=NONE \
+     --builtin-libraries=replace \
      --enable-talloc-compat1
    make
 }
 
+check() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make check
+}
+
 package() {
    cd "${srcdir}/${pkgname}-${pkgver}"
    make DESTDIR="${pkgdir}" install
 }
-md5sums=('85a69bfb5808fcadf378bd9eadb1f9c2')
diff --git a/abs/core/talloc/fix_test_path.patch b/abs/core/talloc/fix_test_path.patch
new file mode 100644
index 0000000..37ed604
--- /dev/null
+++ b/abs/core/talloc/fix_test_path.patch
@@ -0,0 +1,13 @@
+diff --git a/wscript b/wscript
+index 9cedbbf..4432a9a 100644
+--- a/wscript
++++ b/wscript
+@@ -158,7 +158,7 @@ def test(ctx):
+     cmd = os.path.join(Utils.g_module.blddir, 'talloc_testsuite')
+     ret = samba_utils.RUN_COMMAND(cmd)
+     print("testsuite returned %d" % ret)
+-    magic_cmd = os.path.join(srcdir, 'lib', 'talloc',
++    magic_cmd = os.path.join(srcdir,
+                              'test_magic_differs.sh')
+ 
+     magic_ret = samba_utils.RUN_COMMAND(magic_cmd)
-- 
cgit v0.12