From 8948f44addbdd49e1b1f3429cb137d29964a21c0 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 20 Apr 2016 13:35:52 +0000
Subject: LinHES-system: find_orphans.py: add .ts extension and new storage
 groups to exclude

---
 abs/core/LinHES-system/PKGBUILD        | 4 ++--
 abs/core/LinHES-system/find_orphans.py | 7 ++++---
 2 files changed, 6 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 9a630bb..6eafde5 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.4
-pkgrel=7
+pkgrel=8
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -125,7 +125,7 @@ md5sums=('c03d5e54f00e404c561c7dc69fff9168'
          'dedd3fcb1abec6361f4060d8149c7d6d'
          '8b0298f70f97cc1dc2a58b9a73c64bd3'
          'b4bb70650893c811c854d446cfa6ca6a'
-         'cd28dd67a78f3b7da704e31db0298916'
+         'e30bf8ec8b9dcc2ceb7127375a91d8d1'
          'e9f545c3bcf9c85b45496c281fc6a1b8'
          'a94fe6d980f4b810f2e2ae5352084b39'
          '0d1632ea63d8145c173c6aecf0b007f0'
diff --git a/abs/core/LinHES-system/find_orphans.py b/abs/core/LinHES-system/find_orphans.py
index c134e82..b1d78de 100644
--- a/abs/core/LinHES-system/find_orphans.py
+++ b/abs/core/LinHES-system/find_orphans.py
@@ -69,8 +69,9 @@ def populate(host=None):
             hosts = [r[0] for r in c.fetchall()]
     for host in hosts:
         for sg in DB.getStorageGroup():
-            if sg.groupname in ('Videos','Banners','Coverart',\
-                                'Fanart','Screenshots','Trailers'):
+            if sg.groupname in ('Videos','Banners','Coverart','Fanart',\
+                                'Music','MusicArt', 'Photographs',\
+                                'Screenshots','Trailers'):
                 continue
             try:
                 dirs,files,sizes = BE.getSGList(host, sg.groupname, sg.dirname)
@@ -97,7 +98,7 @@ def populate(host=None):
                 if name in f:
                     unfiltered.remove(f)
     for f in list(unfiltered):
-        if not (f.endswith('.mpg') or f.endswith('.nuv')):
+        if not (f.endswith('.mpg') or f.endswith('.nuv') or f.endswith('.ts')):
             continue
         orphvids.append(f)
         unfiltered.remove(f)
-- 
cgit v0.12