From 66ff84165690a39ab01a2a39107c98be0ffde695 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Thu, 6 Aug 2009 02:21:37 +0000
Subject: firefox: include flashplayer plugin and fix fullscreen flash crash

---
 abs/extra-testing/community/firefox/PKGBUILD | 23 ++++++++++++++++++++---
 1 file changed, 20 insertions(+), 3 deletions(-)

diff --git a/abs/extra-testing/community/firefox/PKGBUILD b/abs/extra-testing/community/firefox/PKGBUILD
index babf777..191c913 100644
--- a/abs/extra-testing/community/firefox/PKGBUILD
+++ b/abs/extra-testing/community/firefox/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=firefox
 pkgver=3.5.1
-pkgrel=2
+pkgrel=3
 _xulver=1.9.1.1
 pkgdesc="Standalone web browser from mozilla.org"
 arch=(i686 x86_64)
@@ -20,7 +20,8 @@ source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/s
         mozilla-firefox-1.0-lang.patch
         browser-defaulturls.patch
         firefox-version.patch
-	browser-app-makefile.patch)
+	browser-app-makefile.patch
+	http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz)
 md5sums=('18169e189785d680827d4fce94524449'
          '3c928b11918d22377eba01de34debc19'
          '68cf02788491c6e846729b2f2913bf79'
@@ -28,7 +29,8 @@ md5sums=('18169e189785d680827d4fce94524449'
          'bd5db57c23c72a02a489592644f18995'
          '346d74ec560e7bbf453c02ff21f4b868'
          '1dd9a10df0b9e4cf332eadc326d78e07'
-         '165c43a5b03a0bf7ad2e7210b0d8c82c')
+         '165c43a5b03a0bf7ad2e7210b0d8c82c'
+         '6306980e40a3266b4b6c173bfcfdc946')
 
 build() {
   cd "${srcdir}/mozilla-1.9.1"
@@ -56,4 +58,19 @@ build() {
   install -m644 ${srcdir}/mozilla-1.9.1/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
   install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ || return 1
   install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
+
+  # Install the flash player plugin.
+
+  mkdir -p ${pkgdir}/usr/lib/firefox-3.5/plugins
+  install -m755 ${srcdir}/libflashplayer.so ${pkgdir}/usr/lib/firefox-3.5/plugins || return 1
+
+  # This is to stop firefox from crashing when the flashplayer (youtube) is 
+  # set to full screen. To test if it is still necessary with updates to 
+  # this package, run /usr/bin/firefox.bin without setting the LD_PRELOAD var.
+
+  mv ${pkgdir}/usr/bin/firefox ${pkgdir}/usr/bin/firefox.bin
+  echo "#!/bin/bash
+export LD_PRELOAD=/usr/lib/libGL.so.1
+/usr/bin/firefox.bin" > ${pkgdir}/usr/bin/firefox
+  chmod 755 ${pkgdir}/usr/bin/firefox
 }
-- 
cgit v0.12