From a9e6741db5e5f6364ff731b2f1ef82964a8615d1 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 17 Sep 2009 22:39:22 -0700
Subject: linhes-scripts:Improved linhes_update.sh to more acurately determine
 if an upgrade is available.

---
 abs/core-testing/linhes-scripts/PKGBUILD         | 2 +-
 abs/core-testing/linhes-scripts/linhes_update.sh | 5 +++--
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index 1aaba84..924acfd 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=26
+pkgrel=27
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/core-testing/linhes-scripts/linhes_update.sh b/abs/core-testing/linhes-scripts/linhes_update.sh
index 27ada60..6890d26 100644
--- a/abs/core-testing/linhes-scripts/linhes_update.sh
+++ b/abs/core-testing/linhes-scripts/linhes_update.sh
@@ -10,8 +10,9 @@ dsply ()  {
 	fi
 }
 chck ()  {
-	sudo pacman -Sy > /tmp/check_update
-	if grep -q is\ up\ to\ date /tmp/check_update
+	sudo pacman -Sy
+	sudo pacman -Qu > /tmp/check_update
+	if grep -q no\ upgrades\ found /tmp/check_update
 		then
 		killall osd_cat
 		echo -e "No updates available\n at this time." | osd_cat -p middle -s 5 -f"-adobe-courier-bold-*-*-*-34-*-*-*-*-*" -d 5 -A centre
-- 
cgit v0.12