From 6eae208f1674fa476dd45ab7bbfc24e320e59ada Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Apr 2014 13:47:43 +0000
Subject: python-pytest: initial inclusion.

---
 abs/core/python_modules/python-pytest/PKGBUILD    | 56 +++++++++++++++++++++++
 abs/core/python_modules/python-pytest/__changelog |  1 +
 2 files changed, 57 insertions(+)
 create mode 100644 abs/core/python_modules/python-pytest/PKGBUILD
 create mode 100644 abs/core/python_modules/python-pytest/__changelog

diff --git a/abs/core/python_modules/python-pytest/PKGBUILD b/abs/core/python_modules/python-pytest/PKGBUILD
new file mode 100644
index 0000000..d8db835
--- /dev/null
+++ b/abs/core/python_modules/python-pytest/PKGBUILD
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Felix Kaiser <felix.kaiser@fxkr.net>
+
+pkgbase=python-pytest
+pkgname=('python2-pytest')
+pkgver=2.5.2
+pkgrel=3
+pkgdesc="Simple powerful testing with Python"
+arch=('any')
+license=('MIT')
+url="http://pytest.org/"
+makedepends=('python2-setuptools' 'python2-py')
+checkdepends=('lsof' 'python2-nose' 'twisted' 'python2-mock' 'python2-yaml' 'python2-pexpect')
+source=("http://pypi.python.org/packages/source/p/pytest/pytest-$pkgver.tar.gz")
+
+prepare() {
+  cp -r pytest-${pkgver}{,-py2}
+}
+
+build() {
+#  cd "$srcdir/pytest-${pkgver}"
+#  python setup.py build
+
+  cd "$srcdir/pytest-${pkgver}-py2"
+  python2 setup.py build
+}
+
+check() {
+#  cd "$srcdir/pytest-${pkgver}"
+#  python setup.py test
+
+  cd "$srcdir/pytest-${pkgver}-py2"
+  # Tests fail with 2.5.2: https://bitbucket.org/hpk42/pytest/issue/493/example-failure-in-pytests-own-testcase
+  python2 setup.py test
+}
+
+#package_python-pytest() {
+#  depends=('python' 'python-py' 'python-setuptools')
+
+#  cd pytest-${pkgver}
+#  python setup.py install --root="${pkgdir}" --optimize=1
+#  install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+
+package_python2-pytest() {
+  depends=('python2' 'python2-py' 'python2-setuptools')
+
+  cd pytest-${pkgver}-py2
+  python2 setup.py install --root="${pkgdir}" --optimize=1
+  install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+  mv "${pkgdir}/usr/bin/py.test" "${pkgdir}/usr/bin/py.test2"
+}
+
+sha512sums=('d291f229f4c0a2132c437dde6ca04bf87701fe270c2fa314104badad9221ab866251890c66387d23fefd3ab1f928ee3b290dac21e3d62e7660af8903e85a2f36')
diff --git a/abs/core/python_modules/python-pytest/__changelog b/abs/core/python_modules/python-pytest/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-pytest/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff
-- 
cgit v0.12