From a9a99348fcef6230ad628bf80083ea007ce6d6b0 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 23 Feb 2018 21:32:51 +0000
Subject: wget: update to 1.19.4

---
 abs/core/wget/PKGBUILD     | 34 +++++++++++++++++++++-------------
 abs/core/wget/wget.install | 20 --------------------
 2 files changed, 21 insertions(+), 33 deletions(-)
 delete mode 100644 abs/core/wget/wget.install

diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index 9d6fe1d..fa01ffb 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,22 +1,23 @@
-# $Id$
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
 # Maintainer: Eric Bélanger <eric@archlinux.org>
 
 pkgname=wget
-pkgver=1.17.1
+pkgver=1.19.4
 pkgrel=1
-pkgdesc="A network utility to retrieve files from the Web"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/wget/wget.html"
+pkgdesc='Network utility to retrieve files from the Web'
+url='https://www.gnu.org/software/wget/wget.html'
+arch=('x86_64')
 license=('GPL3')
-depends=('openssl' 'libidn' 'libutil-linux')
+depends=('gnutls' 'libidn' 'libutil-linux' 'libpsl' 'pcre')
 checkdepends=('perl-http-daemon' 'perl-io-socket-ssl' 'python')
 optdepends=('ca-certificates: HTTPS downloads')
 backup=('etc/wgetrc')
-install=wget.install
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
-sha1sums=('8ae737ab2252607ce708f98d1dd7559ebf047f48'
-          'SKIP')
-validpgpkeys=('AC404C1C0BF735C63FF4D562263D6DF2E163E1EA')
+source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.lz{,.sig})
+sha256sums=('2fc0ffb965a8dc8f1e4a89cbe834c0ae7b9c22f559ebafc84c7874ad1866559a'
+            'SKIP')
+validpgpkeys=('AC404C1C0BF735C63FF4D562263D6DF2E163E1EA'
+              '7845120B07CBD8D6ECE5FF2B2A1743EDA91A35B6'
+              '1CB27DBC98614B2D5841646D08302DB6A2670428') # Tim Rühsen <tim.ruehsen@gmx.de>
 
 prepare() {
   cd ${pkgname}-${pkgver}
@@ -29,16 +30,23 @@ EOF
 
 build() {
   cd ${pkgname}-${pkgver}
-  ./configure --prefix=/usr --sysconfdir=/etc --enable-nls --with-ssl=openssl
+  ./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --disable-rpath \
+    --enable-nls \
+    --with-ssl=gnutls
   make
 }
 
 check() {
   cd ${pkgname}-${pkgver}
-  make check
+  make check < /dev/null
 }
 
 package() {
   cd ${pkgname}-${pkgver}
   make DESTDIR="${pkgdir}" install
 }
+
+# vim: ts=2 sw=2 et:
diff --git a/abs/core/wget/wget.install b/abs/core/wget/wget.install
deleted file mode 100644
index 8eb6a2c..0000000
--- a/abs/core/wget/wget.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=usr/share/info
-filelist=(wget.info)
-
-post_install() {
-  [ -x usr/bin/install-info ] || return 0
-  for file in ${filelist[@]}; do
-    install-info $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-
-post_upgrade() {
-  post_install $1
-}
-
-pre_remove() {
-  [ -x usr/bin/install-info ] || return 0
-  for file in ${filelist[@]}; do
-    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-- 
cgit v0.12