From b36b8522a551bf843b46be92cee0dddecd6e7451 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 7 Dec 2010 01:39:56 +0000
Subject: firefox: upgrade

---
 abs/extra/community/firefox/PKGBUILD               | 84 +++++++++-------------
 abs/extra/community/firefox/__changelog            |  2 +
 .../community/firefox/browser-defaulturls.patch    | 14 ++--
 abs/extra/community/firefox/firefox-agent.patch    | 12 ++++
 abs/extra/community/firefox/firefox-safe.desktop   |  2 +-
 abs/extra/community/firefox/firefox-version.patch  |  2 +-
 abs/extra/community/firefox/firefox.desktop        |  6 +-
 abs/extra/community/firefox/firefox.install        | 12 ----
 abs/extra/community/firefox/mozconfig              |  5 +-
 abs/extra/community/firefox/python2.7.patch        | 11 +++
 10 files changed, 72 insertions(+), 78 deletions(-)
 create mode 100644 abs/extra/community/firefox/__changelog
 create mode 100644 abs/extra/community/firefox/firefox-agent.patch
 create mode 100644 abs/extra/community/firefox/python2.7.patch

diff --git a/abs/extra/community/firefox/PKGBUILD b/abs/extra/community/firefox/PKGBUILD
index 17a70b3..a450301 100644
--- a/abs/extra/community/firefox/PKGBUILD
+++ b/abs/extra/community/firefox/PKGBUILD
@@ -1,77 +1,57 @@
-# $Id: PKGBUILD 46468 2009-07-18 13:24:45Z jgc $
+# $Id: PKGBUILD 97212 2010-10-27 20:58:06Z ibiru $
 # Contributor: Jakub Schmidtke <sjakub@gmail.com>
 
 pkgname=firefox
-pkgver=3.5.1
-pkgrel=4
-_xulver=1.9.1.1
+pkgver=3.6.12
+pkgrel=1
+_xulver=1.9.2.12
 pkgdesc="Standalone web browser from mozilla.org"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
 license=('MPL' 'GPL' 'LGPL')
-depends=("xulrunner>=${_xulver}" 'desktop-file-utils' "nspr>=4.8" gconf)
-makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1' 'python')
-replaces=('firefox3')
+depends=("xulrunner=${_xulver}" 'desktop-file-utils')
+makedepends=('zip' 'pkg-config' 'diffutils' 'libgnomeui>=2.24.1' 'python2' 'wireless_tools' 'autoconf2.13')
 install=firefox.install
 url="http://www.mozilla.org/projects/firefox"
-source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}-source.tar.bz2
+source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}.source.tar.bz2
         mozconfig
         firefox.desktop
         firefox-safe.desktop
         mozilla-firefox-1.0-lang.patch
         browser-defaulturls.patch
         firefox-version.patch
-	browser-app-makefile.patch
-	http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz)
-md5sums=('18169e189785d680827d4fce94524449'
-         '3c928b11918d22377eba01de34debc19'
-         '68cf02788491c6e846729b2f2913bf79'
-         '5e68cabfcf3c021806b326f664ac505e'
+	firefox-agent.patch
+        python2.7.patch)
+md5sums=('80f4d83f23a7c45fc3f1904964ea2a5a'
+         'ca385167401b98ef7adc6529e4b53205'
+         'ba96924ece1d77453e462429037a2ce5'
+         '6f38a5899034b7786cb1f75ad42032b8'
          'bd5db57c23c72a02a489592644f18995'
-         '346d74ec560e7bbf453c02ff21f4b868'
-         '1dd9a10df0b9e4cf332eadc326d78e07'
-         '165c43a5b03a0bf7ad2e7210b0d8c82c'
-         '6306980e40a3266b4b6c173bfcfdc946')
+         '1807651225b021e043154f8bba715a19'
+         '92c11c66dd69b03f214002fededd1fc8'
+         'f437e94acff8f810991271ef4677d859'
+         'ab3dc9aecae7f08b9492fb3c00a5fd28')
 
 build() {
-  cd "${srcdir}/mozilla-1.9.1"
-  patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch" || return 1
-  patch -Np0 -i "${srcdir}/browser-defaulturls.patch" || return 1
-  patch -Np1 -i "${srcdir}/firefox-version.patch" || return 1
+  cd "${srcdir}/mozilla-1.9.2"
+  patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch"
+  patch -Np1 -i "${srcdir}/browser-defaulturls.patch"
+  patch -Np1 -i "${srcdir}/firefox-version.patch"
+  patch -Np1 -i "${srcdir}/firefox-agent.patch"
+  patch -Np0 -i "${srcdir}/python2.7.patch"
 
   cp "${srcdir}/mozconfig" .mozconfig
   unset CFLAGS
   unset CXXFLAGS
 
-  export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.5"
+  export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.6"
 
-  make -j1 -f client.mk configure MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
-  cd browser/app
-  patch -p2 < "${srcdir}/browser-app-makefile.patch" || return 1
-  cd ../..
-  make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
-  make -j1 DESTDIR="${pkgdir}" install || return 1
+  make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
+  make -j1 DESTDIR="${pkgdir}" install
 
-  rm -f ${pkgdir}/usr/lib/firefox-3.5/libjemalloc.so
+  rm -f ${pkgdir}/usr/lib/firefox-3.6/libjemalloc.so
 
-  install -m755 -d ${pkgdir}/usr/share/applications
-  install -m755 -d ${pkgdir}/usr/share/pixmaps
-  install -m644 ${srcdir}/mozilla-1.9.1/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
-  install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ || return 1
-  install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
-
-  # Install the flash player plugin.
-
-  mkdir -p ${pkgdir}/usr/lib/firefox-3.5/plugins
-  install -m755 ${srcdir}/libflashplayer.so ${pkgdir}/usr/lib/firefox-3.5/plugins || return 1
-
-  # This is to stop firefox from crashing when the flashplayer (youtube) is 
-  # set to full screen. To test if it is still necessary with updates to 
-  # this package, run /usr/bin/firefox.bin without setting the LD_PRELOAD var.
-
-  mv ${pkgdir}/usr/bin/firefox ${pkgdir}/usr/bin/firefox.bin
-  echo "#!/bin/bash
-/usr/lib/GConf/gconfd-2 &
-export LD_PRELOAD=/usr/lib/libGL.so.1
-/usr/bin/firefox.bin" > ${pkgdir}/usr/bin/firefox
-  chmod 755 ${pkgdir}/usr/bin/firefox
+  install -m755 -d ${pkgdir}/usr/share/{applications,pixmaps}
+  install -m644 ${srcdir}/mozilla-1.9.2/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png
+  install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/
+  install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/
 }
diff --git a/abs/extra/community/firefox/__changelog b/abs/extra/community/firefox/__changelog
new file mode 100644
index 0000000..46f7f96
--- /dev/null
+++ b/abs/extra/community/firefox/__changelog
@@ -0,0 +1,2 @@
+adjusted xulrunner version = 1.9.1.1
+fixed autoconf dependency typo 'autoconf2.13' -> autoconf>=2.13'
diff --git a/abs/extra/community/firefox/browser-defaulturls.patch b/abs/extra/community/firefox/browser-defaulturls.patch
index 42a2e1d..d3cdb47 100644
--- a/abs/extra/community/firefox/browser-defaulturls.patch
+++ b/abs/extra/community/firefox/browser-defaulturls.patch
@@ -1,12 +1,14 @@
---- browser/branding/unofficial/locales/browserconfig.properties~	2009-06-13 17:04:42.000000000 +0200
-+++ browser/branding/unofficial/locales/browserconfig.properties	2009-06-13 17:05:28.000000000 +0200
+diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties
+--- mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties	2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties	2010-04-20 23:55:32.036959438 +0300
 @@ -1,3 +1,3 @@
  # Do NOT localize or otherwise change these values
--browser.startup.homepage=http://www.mozilla.org/projects/shiretoko/
+-browser.startup.homepage=http://www.mozilla.org/projects/namoroka/
 +browser.startup.homepage=http://www.google.com/firefox
  
---- browser/branding/unofficial/pref/firefox-branding.js~	2009-06-13 16:57:53.000000000 +0200
-+++ browser/branding/unofficial/pref/firefox-branding.js	2009-06-13 16:59:17.000000000 +0200
+diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js
+--- mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js	2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js	2010-04-20 23:55:01.290102941 +0300
 @@ -1,5 +1,5 @@
 -pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
 -pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
@@ -15,7 +17,7 @@
  // The time interval between checks for a new version (in seconds)
  // nightly=8 hours, official=24 hours
  pref("app.update.interval", 28800);
-@@ -11,7 +11,7 @@
+@@ -14,7 +14,7 @@
  pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
  
  // Release notes URL
diff --git a/abs/extra/community/firefox/firefox-agent.patch b/abs/extra/community/firefox/firefox-agent.patch
new file mode 100644
index 0000000..299f327
--- /dev/null
+++ b/abs/extra/community/firefox/firefox-agent.patch
@@ -0,0 +1,12 @@
+diff -Nur mozilla-1.9.2.orig/browser/app/profile/firefox.js mozilla-1.9.2/browser/app/profile/firefox.js
+--- mozilla-1.9.2.orig/browser/app/profile/firefox.js	2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/app/profile/firefox.js	2010-04-21 00:16:59.673528609 +0300
+@@ -183,7 +183,7 @@
+ 
+ pref("general.useragent.locale", "@AB_CD@");
+ pref("general.skins.selectedSkin", "classic/1.0");
+-pref("general.useragent.extra.firefox", "@APP_UA_NAME@/@APP_VERSION@");
++pref("general.useragent.extra.firefox", "Firefox/@APP_VERSION@");
+ 
+ pref("general.smoothScroll", false);
+ #ifdef UNIX_BUT_NOT_MAC
diff --git a/abs/extra/community/firefox/firefox-safe.desktop b/abs/extra/community/firefox/firefox-safe.desktop
index afb4cdb..1538fc6 100644
--- a/abs/extra/community/firefox/firefox-safe.desktop
+++ b/abs/extra/community/firefox/firefox-safe.desktop
@@ -8,4 +8,4 @@ MultipleArgs=false
 Name=Firefox - Safe Mode
 GenericName=Web Browser - Safe Mode
 StartupNotify=false
-Categories=Application;Network;
+Categories=Network;WebBrowser;
diff --git a/abs/extra/community/firefox/firefox-version.patch b/abs/extra/community/firefox/firefox-version.patch
index b0a4552..a7f3740 100644
--- a/abs/extra/community/firefox/firefox-version.patch
+++ b/abs/extra/community/firefox/firefox-version.patch
@@ -4,7 +4,7 @@
  
  include $(DEPTH)/config/autoconf.mk
  
-+MOZ_APP_VERSION="3.5"
++MOZ_APP_VERSION="3.6"
 +
  NO_PKG_FILES = \
  	$(MOZ_APP_NAME)-config \
diff --git a/abs/extra/community/firefox/firefox.desktop b/abs/extra/community/firefox/firefox.desktop
index 2a4b678..d048ce4 100644
--- a/abs/extra/community/firefox/firefox.desktop
+++ b/abs/extra/community/firefox/firefox.desktop
@@ -1,10 +1,8 @@
 [Desktop Entry]
-Encoding=UTF-8
 Exec=firefox %u
 Icon=firefox
 Type=Application
 Terminal=false
-MultipleArgs=false
 Name=Firefox
 Name[bn]=ফায়ারফক্স3
 Name[eo]=Fajrovulpo3
@@ -78,6 +76,6 @@ GenericName[xh]=Umkhangeli zincwadi we Web
 GenericName[zh_CN]=网页浏览器
 GenericName[zh_TW]=網頁瀏覽器
 GenericName[zu]=Umcingi we-Web
-MimeType=text/html
+MimeType=text/html;
 StartupNotify=true
-Categories=Application;Network;
+Categories=Network;WebBrowser;
diff --git a/abs/extra/community/firefox/firefox.install b/abs/extra/community/firefox/firefox.install
index cd50dec..7463b6e 100644
--- a/abs/extra/community/firefox/firefox.install
+++ b/abs/extra/community/firefox/firefox.install
@@ -1,17 +1,5 @@
 post_install() {
   update-desktop-database -q
-
-  # For LinHES: check for a fluxbox keys file that doesnt have a mapping
-  # for Alt-w and map it to firefox.
-
-  if [ -e /home/mythtv/.fluxbox/keys ] 
-  then
-    if ! grep -q "Mod1 w" /home/mythtv/.fluxbox/keys 
-    then
-      echo Adding fluxbox key for firefox.
-      echo "Mod1 w :ExecCommand firefox" >> /home/mythtv/.fluxbox/keys
-    fi
-  fi
 }
 
 post_upgrade() {
diff --git a/abs/extra/community/firefox/mozconfig b/abs/extra/community/firefox/mozconfig
index 030317d..68db641 100644
--- a/abs/extra/community/firefox/mozconfig
+++ b/abs/extra/community/firefox/mozconfig
@@ -17,13 +17,14 @@ ac_add_options --enable-default-toolkit=cairo-gtk2
 ac_add_options --disable-xprint
 ac_add_options --enable-strip
 ac_add_options --enable-pango
-ac_add_options --enable-system-cairo
+#ac_add_options --enable-system-cairo
 ac_add_options --enable-svg
 ac_add_options --enable-canvas
 ac_add_options --enable-startup-notification
 ac_add_options --enable-libxul
 ac_add_options --disable-crashreporter
-ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.1.1
+ac_add_options --disable-updater
+ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.2
 ac_add_options --enable-safe-browsing
 ac_add_options --with-branding=browser/branding/unofficial
 
diff --git a/abs/extra/community/firefox/python2.7.patch b/abs/extra/community/firefox/python2.7.patch
new file mode 100644
index 0000000..05a3e91
--- /dev/null
+++ b/abs/extra/community/firefox/python2.7.patch
@@ -0,0 +1,11 @@
+--- configure.in	2010-10-12 10:44:37.000000000 -0700
++++ configure.in~	2010-10-19 09:51:49.660019364 -0700
+@@ -811,7 +811,7 @@
+     AC_MSG_RESULT([yes])    
+ fi
+ 
+-MOZ_PATH_PROGS(PYTHON, $PYTHON python2.5 python2.4 python)
++MOZ_PATH_PROGS(PYTHON, $PYTHON python2.7 python2.5 python2.4 python)
+ if test -z "$PYTHON"; then
+     AC_MSG_ERROR([python was not found in \$PATH])
+ fi
-- 
cgit v0.12