From 05afed13b6033db8d14ab0f7e18f2cba9b277a3a Mon Sep 17 00:00:00 2001
From: Michael Hanson <mihanson@linhes.org>
Date: Fri, 18 May 2012 22:01:34 +0000
Subject: normalize: initial inclusion. Dep for myth2mp3

---
 abs/extra/normalize/PKGBUILD                       |  44 ++
 .../normalize-0.7.7-audiofile-pkgconfig.patch      |  55 ++
 abs/extra/normalize/normalize-0.7.7-m4.patch       | 553 +++++++++++++++++++++
 3 files changed, 652 insertions(+)
 create mode 100644 abs/extra/normalize/PKGBUILD
 create mode 100644 abs/extra/normalize/normalize-0.7.7-audiofile-pkgconfig.patch
 create mode 100644 abs/extra/normalize/normalize-0.7.7-m4.patch

diff --git a/abs/extra/normalize/PKGBUILD b/abs/extra/normalize/PKGBUILD
new file mode 100644
index 0000000..0d3ce58
--- /dev/null
+++ b/abs/extra/normalize/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 149021 2012-02-05 14:18:12Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=normalize
+pkgver=0.7.7
+pkgrel=6
+pkgdesc="A tool for adjusting the volume of WAV files to a standard level"
+arch=('i686' 'x86_64')
+url="http://normalize.nongnu.org"
+license=('GPL')
+depends=('audiofile' 'libmad' 'vorbis-tools' 'lame' 'flac' 'mpg123')
+makedepends=('pkg-config' 'intltool')
+source=("http://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+        'normalize-0.7.7-audiofile-pkgconfig.patch'
+        'normalize-0.7.7-m4.patch')
+md5sums=('1749b16fc7a08aa5d0cf9f76eeaa8436'
+         '77d565e29bef11837e80347adfd42b58'
+         '0b4bca7bf183275b9f939576ebad4233')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  patch -Np1 -i "${srcdir}/normalize-0.7.7-audiofile-pkgconfig.patch"
+  patch -Np0 -i "${srcdir}/normalize-0.7.7-m4.patch"
+
+  touch AUTHORS NEWS ChangeLog
+  libtoolize --force --copy
+  aclocal -I m4
+  autoreconf
+  automake --add-missing
+
+  ./configure --prefix=/usr \
+              --mandir=/usr/share/man \
+              --with-audiofile \
+              --with-mad
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/extra/normalize/normalize-0.7.7-audiofile-pkgconfig.patch b/abs/extra/normalize/normalize-0.7.7-audiofile-pkgconfig.patch
new file mode 100644
index 0000000..09f211c
--- /dev/null
+++ b/abs/extra/normalize/normalize-0.7.7-audiofile-pkgconfig.patch
@@ -0,0 +1,55 @@
+Use pkgconfig to check for audiofile since the audiofile-config script was
+removed from >=audiofile-0.3.0.
+
+--- normalize-0.7.7/configure.ac.orig
++++ normalize-0.7.7/configure.ac
+@@ -248,33 +248,16 @@
+ 
+ 
+ dnl *** Stuff for audiofile library ***
+-dnl v0.2.1 and before have bugs with 24-bit LE files
+-AM_PATH_AUDIOFILE([ 0.2.2 ], [ have_audiofile=true ])
+-dnl AC_CHECK_LIB(audiofile, afSetVirtualSampleFormat, have_audiofile=true)
++AC_ARG_WITH(audiofile, AC_HELP_STRING([--with-audiofile],
++		   [use the audiofile library (default yes)]))
+ AH_TEMPLATE([USE_AUDIOFILE],
+ 	    [Define if you want to use the audiofile library.])
+-AC_ARG_WITH(audiofile,
+-    AC_HELP_STRING([--with-audiofile],
+-		   [use the audiofile library (default yes)]),
+-    [ case "$withval" in
+-	  no) with_audiofile=false ;;
+-	  *) with_audiofile=true ;;
+-      esac ])
+ 
+-use_audiofile=false
+-if test x$with_audiofile != xfalse; then
+-    if test x$have_audiofile = xtrue; then
+-	AC_DEFINE(USE_AUDIOFILE)
+-	use_audiofile=true
+-dnl	AUDIOFILELIBS="-laudiofile"
+-    elif test x$with_audiofile = xtrue; then
+-	AC_MSG_ERROR([--with-audiofile specified, but audiofile library not found])
+-    fi
+-fi
+-dnl AC_SUBST(AUDIOFILELIBS)
+-test x$use_audiofile = xfalse && AUDIOFILE_LIBS=
+-test x$use_audiofile = xfalse && AUDIOFILE_CFLAGS=
+-AM_CONDITIONAL(AUDIOFILE, test x$use_audiofile = xtrue)
++AS_IF([test "x$with_audiofile" = "xyes"], [
++    PKG_CHECK_MODULES([AUDIOFILE], [audiofile])
++    AC_DEFINE(USE_AUDIOFILE)
++])
++AM_CONDITIONAL(AUDIOFILE, test x$with_audiofile = xyes)
+ 
+ 
+ dnl *** Stuff for mad mpeg audio decoder library ***
+@@ -330,7 +313,7 @@
+ 
+ echo
+ echo "Configuration:"
+-echo "    audiofile library:         $use_audiofile"
++echo "    audiofile library:         $with_audiofile"
+ echo "    mpeg audio support:        $use_mad"
+ echo "    xmms volume adjust plugin: $use_xmms"
+ echo
diff --git a/abs/extra/normalize/normalize-0.7.7-m4.patch b/abs/extra/normalize/normalize-0.7.7-m4.patch
new file mode 100644
index 0000000..2aeb3e4
--- /dev/null
+++ b/abs/extra/normalize/normalize-0.7.7-m4.patch
@@ -0,0 +1,553 @@
+--- m4/extra.m4
++++ m4/extra.m4
+@@ -0,0 +1,550 @@
++# Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004,
++# 2005  Free Software Foundation, Inc.
++# This file is free software; the Free Software Foundation
++# gives unlimited permission to copy and/or distribute it,
++# with or without modifications, as long as this notice is preserved.
++
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
++# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
++# PARTICULAR PURPOSE.
++# Configure paths for GLIB
++# Owen Taylor     97-11-3
++
++dnl AM_PATH_GLIB([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or 
++dnl gthread is specified in MODULES, pass to glib-config
++dnl
++AC_DEFUN(AM_PATH_GLIB,
++[dnl 
++dnl Get the cflags and libraries from the glib-config script
++dnl
++AC_ARG_WITH(glib-prefix,[  --with-glib-prefix=PFX   Prefix where GLIB is installed (optional)],
++            glib_config_prefix="$withval", glib_config_prefix="")
++AC_ARG_WITH(glib-exec-prefix,[  --with-glib-exec-prefix=PFX Exec prefix where GLIB is installed (optional)],
++            glib_config_exec_prefix="$withval", glib_config_exec_prefix="")
++AC_ARG_ENABLE(glibtest, [  --disable-glibtest       Do not try to compile and run a test GLIB program],
++		    , enable_glibtest=yes)
++
++  if test x$glib_config_exec_prefix != x ; then
++     glib_config_args="$glib_config_args --exec-prefix=$glib_config_exec_prefix"
++     if test x${GLIB_CONFIG+set} != xset ; then
++        GLIB_CONFIG=$glib_config_exec_prefix/bin/glib-config
++     fi
++  fi
++  if test x$glib_config_prefix != x ; then
++     glib_config_args="$glib_config_args --prefix=$glib_config_prefix"
++     if test x${GLIB_CONFIG+set} != xset ; then
++        GLIB_CONFIG=$glib_config_prefix/bin/glib-config
++     fi
++  fi
++
++  for module in . $4
++  do
++      case "$module" in
++         gmodule) 
++             glib_config_args="$glib_config_args gmodule"
++         ;;
++         gthread) 
++             glib_config_args="$glib_config_args gthread"
++         ;;
++      esac
++  done
++
++  AC_PATH_PROG(GLIB_CONFIG, glib-config, no)
++  min_glib_version=ifelse([$1], ,0.99.7,$1)
++  AC_MSG_CHECKING(for GLIB - version >= $min_glib_version)
++  no_glib=""
++  if test "$GLIB_CONFIG" = "no" ; then
++    no_glib=yes
++  else
++    GLIB_CFLAGS=`$GLIB_CONFIG $glib_config_args --cflags`
++    GLIB_LIBS=`$GLIB_CONFIG $glib_config_args --libs`
++    glib_config_major_version=`$GLIB_CONFIG $glib_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++    glib_config_minor_version=`$GLIB_CONFIG $glib_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++    glib_config_micro_version=`$GLIB_CONFIG $glib_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++    if test "x$enable_glibtest" = "xyes" ; then
++      ac_save_CFLAGS="$CFLAGS"
++      ac_save_LIBS="$LIBS"
++      CFLAGS="$CFLAGS $GLIB_CFLAGS"
++      LIBS="$GLIB_LIBS $LIBS"
++dnl
++dnl Now check if the installed GLIB is sufficiently new. (Also sanity
++dnl checks the results of glib-config to some extent
++dnl
++      rm -f conf.glibtest
++      AC_TRY_RUN([
++#include <glib.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int 
++main ()
++{
++  int major, minor, micro;
++  char *tmp_version;
++
++  system ("touch conf.glibtest");
++
++  /* HP/UX 9 (%@#!) writes to sscanf strings */
++  tmp_version = g_strdup("$min_glib_version");
++  if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++     printf("%s, bad version string\n", "$min_glib_version");
++     exit(1);
++   }
++
++  if ((glib_major_version != $glib_config_major_version) ||
++      (glib_minor_version != $glib_config_minor_version) ||
++      (glib_micro_version != $glib_config_micro_version))
++    {
++      printf("\n*** 'glib-config --version' returned %d.%d.%d, but GLIB (%d.%d.%d)\n", 
++             $glib_config_major_version, $glib_config_minor_version, $glib_config_micro_version,
++             glib_major_version, glib_minor_version, glib_micro_version);
++      printf ("*** was found! If glib-config was correct, then it is best\n");
++      printf ("*** to remove the old version of GLIB. You may also be able to fix the error\n");
++      printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++      printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++      printf("*** required on your system.\n");
++      printf("*** If glib-config was wrong, set the environment variable GLIB_CONFIG\n");
++      printf("*** to point to the correct copy of glib-config, and remove the file config.cache\n");
++      printf("*** before re-running configure\n");
++    } 
++  else if ((glib_major_version != GLIB_MAJOR_VERSION) ||
++	   (glib_minor_version != GLIB_MINOR_VERSION) ||
++           (glib_micro_version != GLIB_MICRO_VERSION))
++    {
++      printf("*** GLIB header files (version %d.%d.%d) do not match\n",
++	     GLIB_MAJOR_VERSION, GLIB_MINOR_VERSION, GLIB_MICRO_VERSION);
++      printf("*** library (version %d.%d.%d)\n",
++	     glib_major_version, glib_minor_version, glib_micro_version);
++    }
++  else
++    {
++      if ((glib_major_version > major) ||
++        ((glib_major_version == major) && (glib_minor_version > minor)) ||
++        ((glib_major_version == major) && (glib_minor_version == minor) && (glib_micro_version >= micro)))
++      {
++        return 0;
++       }
++     else
++      {
++        printf("\n*** An old version of GLIB (%d.%d.%d) was found.\n",
++               glib_major_version, glib_minor_version, glib_micro_version);
++        printf("*** You need a version of GLIB newer than %d.%d.%d. The latest version of\n",
++	       major, minor, micro);
++        printf("*** GLIB is always available from ftp://ftp.gtk.org.\n");
++        printf("***\n");
++        printf("*** If you have already installed a sufficiently new version, this error\n");
++        printf("*** probably means that the wrong copy of the glib-config shell script is\n");
++        printf("*** being found. The easiest way to fix this is to remove the old version\n");
++        printf("*** of GLIB, but you can also set the GLIB_CONFIG environment to point to the\n");
++        printf("*** correct copy of glib-config. (In this case, you will have to\n");
++        printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++        printf("*** so that the correct libraries are found at run-time))\n");
++      }
++    }
++  return 1;
++}
++],, no_glib=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++       CFLAGS="$ac_save_CFLAGS"
++       LIBS="$ac_save_LIBS"
++     fi
++  fi
++  if test "x$no_glib" = x ; then
++     AC_MSG_RESULT(yes)
++     ifelse([$2], , :, [$2])     
++  else
++     AC_MSG_RESULT(no)
++     if test "$GLIB_CONFIG" = "no" ; then
++       echo "*** The glib-config script installed by GLIB could not be found"
++       echo "*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in"
++       echo "*** your path, or set the GLIB_CONFIG environment variable to the"
++       echo "*** full path to glib-config."
++     else
++       if test -f conf.glibtest ; then
++        :
++       else
++          echo "*** Could not run GLIB test program, checking why..."
++          CFLAGS="$CFLAGS $GLIB_CFLAGS"
++          LIBS="$LIBS $GLIB_LIBS"
++          AC_TRY_LINK([
++#include <glib.h>
++#include <stdio.h>
++],      [ return ((glib_major_version) || (glib_minor_version) || (glib_micro_version)); ],
++        [ echo "*** The test program compiled, but did not run. This usually means"
++          echo "*** that the run-time linker is not finding GLIB or finding the wrong"
++          echo "*** version of GLIB. If it is not finding GLIB, you'll need to set your"
++          echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++          echo "*** to the installed location  Also, make sure you have run ldconfig if that"
++          echo "*** is required on your system"
++	  echo "***"
++          echo "*** If you have an old version installed, it is best to remove it, although"
++          echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
++          echo "***"
++          echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
++          echo "*** came with the system with the command"
++          echo "***"
++          echo "***    rpm --erase --nodeps gtk gtk-devel" ],
++        [ echo "*** The test program failed to compile or link. See the file config.log for the"
++          echo "*** exact error that occured. This usually means GLIB was incorrectly installed"
++          echo "*** or that you have moved GLIB since it was installed. In the latter case, you"
++          echo "*** may want to edit the glib-config script: $GLIB_CONFIG" ])
++          CFLAGS="$ac_save_CFLAGS"
++          LIBS="$ac_save_LIBS"
++       fi
++     fi
++     GLIB_CFLAGS=""
++     GLIB_LIBS=""
++     ifelse([$3], , :, [$3])
++  fi
++  AC_SUBST(GLIB_CFLAGS)
++  AC_SUBST(GLIB_LIBS)
++  rm -f conf.glibtest
++])
++
++# Configure paths for GTK+
++# Owen Taylor     97-11-3
++
++dnl AM_PATH_GTK([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GTK, and define GTK_CFLAGS and GTK_LIBS
++dnl
++AC_DEFUN(AM_PATH_GTK,
++[dnl 
++dnl Get the cflags and libraries from the gtk-config script
++dnl
++AC_ARG_WITH(gtk-prefix,[  --with-gtk-prefix=PFX   Prefix where GTK is installed (optional)],
++            gtk_config_prefix="$withval", gtk_config_prefix="")
++AC_ARG_WITH(gtk-exec-prefix,[  --with-gtk-exec-prefix=PFX Exec prefix where GTK is installed (optional)],
++            gtk_config_exec_prefix="$withval", gtk_config_exec_prefix="")
++AC_ARG_ENABLE(gtktest, [  --disable-gtktest       Do not try to compile and run a test GTK program],
++		    , enable_gtktest=yes)
++
++  for module in . $4
++  do
++      case "$module" in
++         gthread) 
++             gtk_config_args="$gtk_config_args gthread"
++         ;;
++      esac
++  done
++
++  if test x$gtk_config_exec_prefix != x ; then
++     gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
++     if test x${GTK_CONFIG+set} != xset ; then
++        GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
++     fi
++  fi
++  if test x$gtk_config_prefix != x ; then
++     gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
++     if test x${GTK_CONFIG+set} != xset ; then
++        GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
++     fi
++  fi
++
++  AC_PATH_PROG(GTK_CONFIG, gtk-config, no)
++  min_gtk_version=ifelse([$1], ,0.99.7,$1)
++  AC_MSG_CHECKING(for GTK - version >= $min_gtk_version)
++  no_gtk=""
++  if test "$GTK_CONFIG" = "no" ; then
++    no_gtk=yes
++  else
++    GTK_CFLAGS=`$GTK_CONFIG $gtk_config_args --cflags`
++    GTK_LIBS=`$GTK_CONFIG $gtk_config_args --libs`
++    gtk_config_major_version=`$GTK_CONFIG $gtk_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++    gtk_config_minor_version=`$GTK_CONFIG $gtk_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++    gtk_config_micro_version=`$GTK_CONFIG $gtk_config_args --version | \
++           sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++    if test "x$enable_gtktest" = "xyes" ; then
++      ac_save_CFLAGS="$CFLAGS"
++      ac_save_LIBS="$LIBS"
++      CFLAGS="$CFLAGS $GTK_CFLAGS"
++      LIBS="$GTK_LIBS $LIBS"
++dnl
++dnl Now check if the installed GTK is sufficiently new. (Also sanity
++dnl checks the results of gtk-config to some extent
++dnl
++      rm -f conf.gtktest
++      AC_TRY_RUN([
++#include <gtk/gtk.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int 
++main ()
++{
++  int major, minor, micro;
++  char *tmp_version;
++
++  system ("touch conf.gtktest");
++
++  /* HP/UX 9 (%@#!) writes to sscanf strings */
++  tmp_version = g_strdup("$min_gtk_version");
++  if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++     printf("%s, bad version string\n", "$min_gtk_version");
++     exit(1);
++   }
++
++  if ((gtk_major_version != $gtk_config_major_version) ||
++      (gtk_minor_version != $gtk_config_minor_version) ||
++      (gtk_micro_version != $gtk_config_micro_version))
++    {
++      printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n", 
++             $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
++             gtk_major_version, gtk_minor_version, gtk_micro_version);
++      printf ("*** was found! If gtk-config was correct, then it is best\n");
++      printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
++      printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++      printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++      printf("*** required on your system.\n");
++      printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
++      printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
++      printf("*** before re-running configure\n");
++    } 
++#if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
++  else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
++	   (gtk_minor_version != GTK_MINOR_VERSION) ||
++           (gtk_micro_version != GTK_MICRO_VERSION))
++    {
++      printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
++	     GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
++      printf("*** library (version %d.%d.%d)\n",
++	     gtk_major_version, gtk_minor_version, gtk_micro_version);
++    }
++#endif /* defined (GTK_MAJOR_VERSION) ... */
++  else
++    {
++      if ((gtk_major_version > major) ||
++        ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
++        ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
++      {
++        return 0;
++       }
++     else
++      {
++        printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
++               gtk_major_version, gtk_minor_version, gtk_micro_version);
++        printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
++	       major, minor, micro);
++        printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
++        printf("***\n");
++        printf("*** If you have already installed a sufficiently new version, this error\n");
++        printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
++        printf("*** being found. The easiest way to fix this is to remove the old version\n");
++        printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
++        printf("*** correct copy of gtk-config. (In this case, you will have to\n");
++        printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++        printf("*** so that the correct libraries are found at run-time))\n");
++      }
++    }
++  return 1;
++}
++],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++       CFLAGS="$ac_save_CFLAGS"
++       LIBS="$ac_save_LIBS"
++     fi
++  fi
++  if test "x$no_gtk" = x ; then
++     AC_MSG_RESULT(yes)
++     ifelse([$2], , :, [$2])     
++  else
++     AC_MSG_RESULT(no)
++     if test "$GTK_CONFIG" = "no" ; then
++       echo "*** The gtk-config script installed by GTK could not be found"
++       echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
++       echo "*** your path, or set the GTK_CONFIG environment variable to the"
++       echo "*** full path to gtk-config."
++     else
++       if test -f conf.gtktest ; then
++        :
++       else
++          echo "*** Could not run GTK test program, checking why..."
++          CFLAGS="$CFLAGS $GTK_CFLAGS"
++          LIBS="$LIBS $GTK_LIBS"
++          AC_TRY_LINK([
++#include <gtk/gtk.h>
++#include <stdio.h>
++],      [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
++        [ echo "*** The test program compiled, but did not run. This usually means"
++          echo "*** that the run-time linker is not finding GTK or finding the wrong"
++          echo "*** version of GTK. If it is not finding GTK, you'll need to set your"
++          echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++          echo "*** to the installed location  Also, make sure you have run ldconfig if that"
++          echo "*** is required on your system"
++	  echo "***"
++          echo "*** If you have an old version installed, it is best to remove it, although"
++          echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
++          echo "***"
++          echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that"
++          echo "*** came with the system with the command"
++          echo "***"
++          echo "***    rpm --erase --nodeps gtk gtk-devel" ],
++        [ echo "*** The test program failed to compile or link. See the file config.log for the"
++          echo "*** exact error that occured. This usually means GTK was incorrectly installed"
++          echo "*** or that you have moved GTK since it was installed. In the latter case, you"
++          echo "*** may want to edit the gtk-config script: $GTK_CONFIG" ])
++          CFLAGS="$ac_save_CFLAGS"
++          LIBS="$ac_save_LIBS"
++       fi
++     fi
++     GTK_CFLAGS=""
++     GTK_LIBS=""
++     ifelse([$3], , :, [$3])
++  fi
++  AC_SUBST(GTK_CFLAGS)
++  AC_SUBST(GTK_LIBS)
++  rm -f conf.gtktest
++])
++
++# CFLAGS and library paths for XMMS
++# written 15 December 1999 by Ben Gertzfield <che@debian.org>
++
++dnl Usage:
++dnl AM_PATH_XMMS([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
++dnl
++dnl Example:
++dnl AM_PATH_XMMS(0.9.5.1, , AC_MSG_ERROR([*** XMMS >= 0.9.5.1 not installed - please install first ***]))
++dnl
++dnl Defines XMMS_CFLAGS, XMMS_LIBS, XMMS_DATA_DIR, XMMS_PLUGIN_DIR, 
++dnl XMMS_VISUALIZATION_PLUGIN_DIR, XMMS_INPUT_PLUGIN_DIR, 
++dnl XMMS_OUTPUT_PLUGIN_DIR, XMMS_GENERAL_PLUGIN_DIR, XMMS_EFFECT_PLUGIN_DIR,
++dnl and XMMS_VERSION for your plugin pleasure.
++dnl
++
++dnl XMMS_TEST_VERSION(AVAILABLE-VERSION, NEEDED-VERSION [, ACTION-IF-OKAY [, ACTION-IF-NOT-OKAY]])
++AC_DEFUN(XMMS_TEST_VERSION, [
++
++# Determine which version number is greater. Prints 2 to stdout if	
++# the second number is greater, 1 if the first number is greater,	
++# 0 if the numbers are equal.						
++									
++# Written 15 December 1999 by Ben Gertzfield <che@debian.org>		
++# Revised 15 December 1999 by Jim Monty <monty@primenet.com>		
++									
++    AC_PROG_AWK
++    xmms_got_version=[` $AWK '						\
++BEGIN {									\
++    print vercmp(ARGV[1], ARGV[2]);					\
++}									\
++									\
++function vercmp(ver1, ver2,    ver1arr, ver2arr,			\
++                               ver1len, ver2len,			\
++                               ver1int, ver2int, len, i, p) {		\
++									\
++    ver1len = split(ver1, ver1arr, /\./);				\
++    ver2len = split(ver2, ver2arr, /\./);				\
++									\
++    len = ver1len > ver2len ? ver1len : ver2len;			\
++									\
++    for (i = 1; i <= len; i++) {					\
++        p = 1000 ^ (len - i);						\
++        ver1int += ver1arr[i] * p;					\
++        ver2int += ver2arr[i] * p;					\
++    }									\
++									\
++    if (ver1int < ver2int)						\
++        return 2;							\
++    else if (ver1int > ver2int)						\
++        return 1;							\
++    else								\
++        return 0;							\
++}' $1 $2`]								
++
++    if test $xmms_got_version -eq 2; then 	# failure
++	ifelse([$4], , :, $4)			
++    else  					# success!
++	ifelse([$3], , :, $3)
++    fi
++])
++
++AC_DEFUN(AM_PATH_XMMS,
++[
++AC_ARG_WITH(xmms-prefix,[  --with-xmms-prefix=PFX  Prefix where XMMS is installed (optional)],
++	xmms_config_prefix="$withval", xmms_config_prefix="")
++AC_ARG_WITH(xmms-exec-prefix,[  --with-xmms-exec-prefix=PFX Exec prefix where XMMS is installed (optional)],
++	xmms_config_exec_prefix="$withval", xmms_config_exec_prefix="")
++
++if test x$xmms_config_exec_prefix != x; then
++    xmms_config_args="$xmms_config_args --exec-prefix=$xmms_config_exec_prefix"
++    if test x${XMMS_CONFIG+set} != xset; then
++	XMMS_CONFIG=$xmms_config_exec_prefix/bin/xmms-config
++    fi
++fi
++
++if test x$xmms_config_prefix != x; then
++    xmms_config_args="$xmms_config_args --prefix=$xmms_config_prefix"
++    if test x${XMMS_CONFIG+set} != xset; then
++  	XMMS_CONFIG=$xmms_config_prefix/bin/xmms-config
++    fi
++fi
++
++AC_PATH_PROG(XMMS_CONFIG, xmms-config, no)
++min_xmms_version=ifelse([$1], ,0.9.5.1, $1)
++
++if test "$XMMS_CONFIG" = "no"; then
++    no_xmms=yes
++else
++    XMMS_CFLAGS=`$XMMS_CONFIG $xmms_config_args --cflags`
++    XMMS_LIBS=`$XMMS_CONFIG $xmms_config_args --libs`
++    XMMS_VERSION=`$XMMS_CONFIG $xmms_config_args --version`
++    XMMS_DATA_DIR=`$XMMS_CONFIG $xmms_config_args --data-dir`
++    XMMS_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --plugin-dir`
++    XMMS_VISUALIZATION_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args \
++					--visualization-plugin-dir`
++    XMMS_INPUT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --input-plugin-dir`
++    XMMS_OUTPUT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --output-plugin-dir`
++    XMMS_EFFECT_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --effect-plugin-dir`
++    XMMS_GENERAL_PLUGIN_DIR=`$XMMS_CONFIG $xmms_config_args --general-plugin-dir`
++
++    XMMS_TEST_VERSION($XMMS_VERSION, $min_xmms_version, ,no_xmms=version)
++fi
++
++AC_MSG_CHECKING(for XMMS - version >= $min_xmms_version)
++
++if test "x$no_xmms" = x; then
++    AC_MSG_RESULT(yes)
++    ifelse([$2], , :, [$2])
++else
++    AC_MSG_RESULT(no)
++
++    if test "$XMMS_CONFIG" = "no" ; then
++	echo "*** The xmms-config script installed by XMMS could not be found."
++      	echo "*** If XMMS was installed in PREFIX, make sure PREFIX/bin is in"
++	echo "*** your path, or set the XMMS_CONFIG environment variable to the"
++	echo "*** full path to xmms-config."
++    else
++	if test "$no_xmms" = "version"; then
++	    echo "*** An old version of XMMS, $XMMS_VERSION, was found."
++	    echo "*** You need a version of XMMS newer than $min_xmms_version."
++	    echo "*** The latest version of XMMS is always available from"
++	    echo "*** http://www.xmms.org/"
++	    echo "***"
++
++            echo "*** If you have already installed a sufficiently new version, this error"
++            echo "*** probably means that the wrong copy of the xmms-config shell script is"
++            echo "*** being found. The easiest way to fix this is to remove the old version"
++            echo "*** of XMMS, but you can also set the XMMS_CONFIG environment to point to the"
++            echo "*** correct copy of xmms-config. (In this case, you will have to"
++            echo "*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf"
++            echo "*** so that the correct libraries are found at run-time)"
++	fi
++    fi
++    XMMS_CFLAGS=""
++    XMMS_LIBS=""
++    ifelse([$3], , :, [$3])
++fi
++AC_SUBST(XMMS_CFLAGS)
++AC_SUBST(XMMS_LIBS)
++AC_SUBST(XMMS_VERSION)
++AC_SUBST(XMMS_DATA_DIR)
++AC_SUBST(XMMS_PLUGIN_DIR)
++AC_SUBST(XMMS_VISUALIZATION_PLUGIN_DIR)
++AC_SUBST(XMMS_INPUT_PLUGIN_DIR)
++AC_SUBST(XMMS_OUTPUT_PLUGIN_DIR)
++AC_SUBST(XMMS_GENERAL_PLUGIN_DIR)
++AC_SUBST(XMMS_EFFECT_PLUGIN_DIR)
++])
-- 
cgit v0.12