From ed938f4f4470dd959305103a880c40efdda47f85 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 15 Dec 2014 17:38:26 +0000
Subject: llvm: update to 3.5.0

---
 abs/extra/llvm/PKGBUILD                            | 109 ++++++++++++++-------
 abs/extra/llvm/__changelog                         |   2 +
 abs/extra/llvm/clang-3.3-use-gold-linker.patch     |  12 ---
 .../llvm/llvm-3.5.0-fix-cmake-llvm-exports.patch   |  39 ++++++++
 abs/extra/llvm/llvm-3.5.0-force-link-pass.o.patch  |  28 ++++++
 5 files changed, 145 insertions(+), 45 deletions(-)
 create mode 100644 abs/extra/llvm/__changelog
 delete mode 100644 abs/extra/llvm/clang-3.3-use-gold-linker.patch
 create mode 100644 abs/extra/llvm/llvm-3.5.0-fix-cmake-llvm-exports.patch
 create mode 100644 abs/extra/llvm/llvm-3.5.0-force-link-pass.o.patch

diff --git a/abs/extra/llvm/PKGBUILD b/abs/extra/llvm/PKGBUILD
index 3a837d2..00a7eaa 100644
--- a/abs/extra/llvm/PKGBUILD
+++ b/abs/extra/llvm/PKGBUILD
@@ -11,49 +11,67 @@
 
 pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'clang' 'clang-analyzer'
          'clang-tools-extra')
-pkgver=3.4
-pkgrel=1
+pkgver=3.5.0
+pkgrel=2.1
 arch=('i686' 'x86_64')
 url="http://llvm.org/"
 license=('custom:University of Illinois/NCSA Open Source License')
-makedepends=('libffi' 'python2' 'ocaml' 'python2-sphinx')
+makedepends=('libffi' 'python2' 'ocaml' 'python2-sphinx' 'chrpath')
+# Use gcc-multilib to build 32-bit compiler-rt libraries on x86_64 (FS#41911)
+#[[ $CARCH = x86_64 ]] && makedepends+=('gcc-multilib')
+[[ $CARCH = x86_64 ]]
 options=('staticlibs')
-source=(http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.gz
-        http://llvm.org/releases/$pkgver/clang-$pkgver.src.tar.gz
-        http://llvm.org/releases/$pkgver/clang-tools-extra-$pkgver.src.tar.gz
-        http://llvm.org/releases/$pkgver/compiler-rt-$pkgver.src.tar.gz
-        clang-3.3-use-gold-linker.patch
+source=(http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
+        http://llvm.org/releases/$pkgver/cfe-$pkgver.src.tar.xz{,.sig}
+        http://llvm.org/releases/$pkgver/clang-tools-extra-$pkgver.src.tar.xz{,.sig}
+        http://llvm.org/releases/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
+        llvm-3.5.0-force-link-pass.o.patch
+        llvm-3.5.0-fix-cmake-llvm-exports.patch
         llvm-Config-config.h
         llvm-Config-llvm-config.h)
-sha256sums=('25a5612d692c48481b9b397e2b55f4870e447966d66c96d655241702d44a2628'
-            '22a9780db3b85a7f2eb9ea1f7f6e00da0249e3d12851e8dea0f62f1783242b1b'
-            'ba85187551ae97fe1c8ab569903beae5ff0900e21233e5eb5389f6ceab1028b4'
-            'f37c89b1383ce462d47537a0245ac798600887a9be9f63073e16b79ed536ab5c'
-            '8240adda155d7961eeb5d07ed50ead10cb7125f70283dff7f1c9fee9df3cea09'
+sha256sums=('28e199f368ef0a4666708f31c7991ad3bcc3a578342b0306526dd35f07595c03'
+            'SKIP'
+            'fc80992e004b06f6c7afb612de1cdaa9ac9d25811c55f94fcf7331d9b81cdb8b'
+            'SKIP'
+            '2981beb378afb5aa5c50ed017720a42a33e77e902c7086ad2d412ef4fa931f69'
+            'SKIP'
+            'a4b3e655832bf8d9a357ea2c771db347237460e131988cbb96cda40ff39a8136'
+            'SKIP'
+            '5702053503d49448598eda1b8dc8c263f0df9ad7486833273e3987b5dec25a19'
+            '841a153d0e9d2d196ea5318388ff295e69c41547eb73b24edf92a1b2cc3cccdd'
             '312574e655f9a87784ca416949c505c452b819fad3061f2cde8aced6540a19a3'
             '597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
 
 prepare() {
-  cd "$srcdir/llvm-$pkgver"
+  cd "$srcdir/llvm-$pkgver.src"
 
   # At the present, clang must reside inside the LLVM source code tree to build
   # See http://llvm.org/bugs/show_bug.cgi?id=4840
-  mv "$srcdir/clang-$pkgver" tools/clang
+  mv "$srcdir/cfe-$pkgver.src" tools/clang
 
-  mv "$srcdir/clang-tools-extra-$pkgver" tools/clang/tools/extra
+  mv "$srcdir/clang-tools-extra-$pkgver.src" tools/clang/tools/extra
 
-  mv "$srcdir/compiler-rt-$pkgver" projects/compiler-rt
+  mv "$srcdir/compiler-rt-$pkgver.src" projects/compiler-rt
 
   # Fix docs installation directory
-  sed -i 's:\$(PROJ_prefix)/docs/llvm:$(PROJ_prefix)/share/doc/llvm:' \
+  sed -i 's:$(PROJ_prefix)/docs/llvm:$(PROJ_prefix)/share/doc/llvm:' \
     Makefile.config.in
 
-  # Make -flto work; use ld.gold instead of the default linker
-  patch -d tools/clang -Np1 -i "$srcdir/clang-3.3-use-gold-linker.patch"
+  # Fix definition of LLVM_CMAKE_DIR in LLVMConfig.cmake
+  sed -i '/@LLVM_CONFIG_CMAKE_DIR@/s:$(PROJ_cmake):$(PROJ_prefix)/share/llvm/cmake:' \
+    cmake/modules/Makefile
+
+  # Fix build with GCC 4.9 (patch from Debian)
+  # http://llvm.org/bugs/show_bug.cgi?id=20067
+  patch -Np1 -i "$srcdir/llvm-3.5.0-force-link-pass.o.patch"
+
+  # Fix generation of broken LLVMExports.cmake file
+  # http://llvm.org/bugs/show_bug.cgi?id=20884
+  patch -Np0 -i "$srcdir/llvm-3.5.0-fix-cmake-llvm-exports.patch"
 }
 
 build() {
-  cd "$srcdir/llvm-$pkgver"
+  cd "$srcdir/llvm-$pkgver.src"
 
   # Apply strip option to configure
   _optimized_switch="enable"
@@ -87,7 +105,7 @@ package_llvm() {
   pkgdesc="Low Level Virtual Machine"
   depends=("llvm-libs=$pkgver-$pkgrel" 'perl')
 
-  cd "$srcdir/llvm-$pkgver"
+  cd "$srcdir/llvm-$pkgver.src"
 
   # We move the clang directory out of the tree so it won't get installed and
   # then we bring it back in for the clang package
@@ -98,7 +116,8 @@ package_llvm() {
   mv "$srcdir/clang" tools
 
   # The runtime library goes into llvm-libs
-  mv "$pkgdir/usr/lib/libLLVM-$pkgver.so" "$srcdir"
+  mv -f "$pkgdir/usr/lib/libLLVM-$pkgver.so" "$srcdir/"
+  mv -f "$pkgdir/usr/lib/libLLVM-${pkgver%.*}.so" "$srcdir/"
 
   # OCaml bindings go to a separate package
   rm -rf "$srcdir"/{ocaml,ocamldoc}
@@ -113,8 +132,8 @@ package_llvm() {
   # Get rid of example Hello transformation
   rm "$pkgdir"/usr/lib/*LLVMHello.*
 
-  # Symlink LLVMgold.so into /usr/lib/bfd-plugins
-  # (https://bugs.archlinux.org/task/28479)
+  # Symlink LLVMgold.so from /usr/lib/bfd-plugins
+  # https://bugs.archlinux.org/task/28479
   install -d "$pkgdir/usr/lib/bfd-plugins"
   ln -s ../LLVMgold.so "$pkgdir/usr/lib/bfd-plugins/LLVMgold.so"
 
@@ -143,9 +162,13 @@ package_llvm-libs() {
   pkgdesc="Low Level Virtual Machine (runtime library)"
   depends=('gcc-libs' 'zlib' 'libffi' 'ncurses')
 
-  install -D "$srcdir/libLLVM-$pkgver.so" "$pkgdir/usr/lib/libLLVM-$pkgver.so"
+  install -d "$pkgdir/usr/lib"
+  cp -P \
+    "$srcdir/libLLVM-$pkgver.so" \
+    "$srcdir/libLLVM-${pkgver%.*}.so" \
+    "$pkgdir/usr/lib/"
 
-  install -Dm644 "$srcdir/llvm-$pkgver/LICENSE.TXT" \
+  install -Dm644 "$srcdir/llvm-$pkgver.src/LICENSE.TXT" \
     "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
@@ -153,7 +176,7 @@ package_llvm-ocaml() {
   pkgdesc="OCaml bindings for LLVM"
   depends=("llvm=$pkgver-$pkgrel" 'ocaml')
 
-  cd "$srcdir/llvm-$pkgver"
+  cd "$srcdir/llvm-$pkgver.src"
 
   install -d "$pkgdir"/{usr/lib,usr/share/doc/llvm}
   cp -r "$srcdir/ocaml" "$pkgdir/usr/lib"
@@ -162,6 +185,9 @@ package_llvm-ocaml() {
   # Remove execute bit from static libraries
   chmod -x "$pkgdir"/usr/lib/ocaml/libllvm*.a
 
+  # Remove insecure rpath
+  chrpath -d "$pkgdir"/usr/lib/ocaml/*.so
+
   install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
@@ -172,9 +198,9 @@ package_clang() {
 
   # Fix installation path for clang docs
   sed -i 's:$(PROJ_prefix)/share/doc/llvm:$(PROJ_prefix)/share/doc/clang:' \
-    "$srcdir/llvm-$pkgver/Makefile.config"
+    "$srcdir/llvm-$pkgver.src/Makefile.config"
 
-  cd "$srcdir/llvm-$pkgver/tools/clang"
+  cd "$srcdir/llvm-$pkgver.src/tools/clang"
 
   # We move the extra tools directory out of the tree so it won't get
   # installed and then we bring it back in for the clang-tools-extra package
@@ -188,7 +214,7 @@ package_clang() {
 
   # Revert the path change in case we want to do a repackage later
   sed -i 's:$(PROJ_prefix)/share/doc/clang:$(PROJ_prefix)/share/doc/llvm:' \
-    "$srcdir/llvm-$pkgver/Makefile.config"
+    "$srcdir/llvm-$pkgver.src/Makefile.config"
 
   # Install html docs
   cp -r docs/_build/html/* "$pkgdir/usr/share/doc/$pkgname/html/"
@@ -200,6 +226,23 @@ package_clang() {
   python2 -m compileall "$pkgdir/usr/lib/python2.7/site-packages/clang"
   python2 -O -m compileall "$pkgdir/usr/lib/python2.7/site-packages/clang"
 
+  # Install clang-format editor integration files (FS#38485)
+  # Destination paths are copied from clang-format/CMakeLists.txt
+  install -d "$pkgdir/usr/share/$pkgname"
+  (
+    cd tools/clang-format
+    cp \
+      clang-format-diff.py \
+      clang-format-sublime.py \
+      clang-format.el \
+      clang-format.py \
+      "$pkgdir/usr/share/$pkgname/"
+    cp git-clang-format "$pkgdir/usr/bin/"
+    sed -i 's|/usr/bin/python$|&2|' \
+      "$pkgdir/usr/bin/git-clang-format" \
+      "$pkgdir/usr/share/$pkgname/clang-format-diff.py"
+  )
+
   install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
 }
 
@@ -208,7 +251,7 @@ package_clang-analyzer() {
   url="http://clang-analyzer.llvm.org/"
   depends=("clang=$pkgver-$pkgrel" 'python2')
 
-  cd "$srcdir/llvm-$pkgver/tools/clang"
+  cd "$srcdir/llvm-$pkgver.src/tools/clang"
 
   install -d "$pkgdir"/usr/{bin,lib/clang-analyzer}
   for _tool in scan-{build,view}; do
@@ -243,7 +286,7 @@ package_clang-tools-extra() {
   url="http://clang.llvm.org/"
   depends=("clang=$pkgver-$pkgrel")
 
-  cd "$srcdir/llvm-$pkgver/tools/clang/tools/extra"
+  cd "$srcdir/llvm-$pkgver.src/tools/clang/tools/extra"
 
   make DESTDIR="$pkgdir" install
 
diff --git a/abs/extra/llvm/__changelog b/abs/extra/llvm/__changelog
new file mode 100644
index 0000000..57db2dd
--- /dev/null
+++ b/abs/extra/llvm/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: change python-sphinx to python2-sphinx
+PKGBUILD: remove gcc-multilib
diff --git a/abs/extra/llvm/clang-3.3-use-gold-linker.patch b/abs/extra/llvm/clang-3.3-use-gold-linker.patch
deleted file mode 100644
index 76905a6..0000000
--- a/abs/extra/llvm/clang-3.3-use-gold-linker.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -upr cfe.src.orig/lib/Driver/ToolChains.cpp cfe.src/lib/Driver/ToolChains.cpp
---- cfe.src.orig/lib/Driver/ToolChains.cpp	2013-06-08 16:17:19.000000000 +0300
-+++ cfe.src/lib/Driver/ToolChains.cpp	2013-06-08 16:17:33.000000000 +0300
-@@ -2220,7 +2220,7 @@ Linux::Linux(const Driver &D, const llvm
-   PPaths.push_back(Twine(GCCInstallation.getParentLibPath() + "/../" +
-                          GCCInstallation.getTriple().str() + "/bin").str());
- 
--  Linker = GetProgramPath("ld");
-+  Linker = GetProgramPath("ld.gold");
- 
-   Distro Distro = DetectDistro(Arch);
- 
diff --git a/abs/extra/llvm/llvm-3.5.0-fix-cmake-llvm-exports.patch b/abs/extra/llvm/llvm-3.5.0-fix-cmake-llvm-exports.patch
new file mode 100644
index 0000000..7a7d42a
--- /dev/null
+++ b/abs/extra/llvm/llvm-3.5.0-fix-cmake-llvm-exports.patch
@@ -0,0 +1,39 @@
+Index: cmake/modules/Makefile
+===================================================================
+--- cmake/modules/Makefile	(revision 217483)
++++ cmake/modules/Makefile	(revision 217484)
+@@ -33,6 +33,16 @@
+ 	LLVM_ENABLE_RTTI := 0
+ endif
+ 
++LLVM_LIBS_TO_EXPORT := $(subst -l,,$(shell $(LLVM_CONFIG) --libs $(LINK_COMPONENTS) || echo Error))
++
++ifeq ($(LLVM_LIBS_TO_EXPORT),Error)
++$(error llvm-config --libs failed)
++endif
++
++ifndef LLVM_LIBS_TO_EXPORT
++$(error LLVM_LIBS_TO_EXPORT cannot be empty)
++endif
++
+ OBJMODS := LLVMConfig.cmake LLVMConfigVersion.cmake LLVMExports.cmake
+ 
+ $(PROJ_OBJ_DIR)/LLVMConfig.cmake: LLVMConfig.cmake.in $(LLVMBuildCMakeFrag)
+@@ -45,7 +55,7 @@
+ 	  -e 's/@LLVM_VERSION_PATCH@/'"$(LLVM_VERSION_PATCH)"'/' \
+ 	  -e 's/@PACKAGE_VERSION@/'"$(LLVMVersion)"'/' \
+ 	  -e 's/@LLVM_COMMON_DEPENDS@//' \
+-	  -e 's/@LLVM_AVAILABLE_LIBS@/'"$(subst -l,,$(LLVMConfigLibs))"'/' \
++	  -e 's/@LLVM_AVAILABLE_LIBS@/'"$(LLVM_LIBS_TO_EXPORT)"'/' \
+ 	  -e 's/@LLVM_ALL_TARGETS@/'"$(ALL_TARGETS)"'/' \
+ 	  -e 's/@LLVM_TARGETS_TO_BUILD@/'"$(TARGETS_TO_BUILD)"'/' \
+ 	  -e 's/@LLVM_TARGETS_WITH_JIT@/'"$(TARGETS_WITH_JIT)"'/' \
+@@ -83,7 +93,7 @@
+ 	$(Echo) 'Generating LLVM CMake target exports file'
+ 	$(Verb) ( \
+ 	  echo '# LLVM CMake target exports.  Do not include directly.' && \
+-	  for lib in $(subst -l,,$(LLVMConfigLibs)); do \
++	  for lib in $(LLVM_LIBS_TO_EXPORT); do \
+ 	    echo 'add_library('"$$lib"' STATIC IMPORTED)' && \
+ 	    echo 'set_property(TARGET '"$$lib"' PROPERTY IMPORTED_LOCATION "'"$(PROJ_libdir)/lib$$lib.a"'")' ; \
+ 	  done && \
diff --git a/abs/extra/llvm/llvm-3.5.0-force-link-pass.o.patch b/abs/extra/llvm/llvm-3.5.0-force-link-pass.o.patch
new file mode 100644
index 0000000..acc4c13
--- /dev/null
+++ b/abs/extra/llvm/llvm-3.5.0-force-link-pass.o.patch
@@ -0,0 +1,28 @@
+Index: llvm-toolchain-snapshot-3.5~svn211313/tools/bugpoint/Makefile
+===================================================================
+--- llvm-toolchain-snapshot-3.5~svn211313.orig/tools/bugpoint/Makefile
++++ llvm-toolchain-snapshot-3.5~svn211313/tools/bugpoint/Makefile
+@@ -12,6 +12,9 @@ TOOLNAME := bugpoint
+ LINK_COMPONENTS := asmparser instrumentation scalaropts ipo linker bitreader \
+                    bitwriter irreader vectorize objcarcopts codegen
+ 
++# Crappy workaround to make sure it links correctly.
++LLVMLibsOptions := ../../lib/IR/Release*/Pass.o
++
+ # Support plugins.
+ NO_DEAD_STRIP := 1
+ 
+Index: llvm-toolchain-snapshot-3.5~svn211313/tools/opt/Makefile
+===================================================================
+--- llvm-toolchain-snapshot-3.5~svn211313.orig/tools/opt/Makefile
++++ llvm-toolchain-snapshot-3.5~svn211313/tools/opt/Makefile
+@@ -10,7 +10,9 @@
+ LEVEL := ../..
+ TOOLNAME := opt
+ LINK_COMPONENTS := bitreader bitwriter asmparser irreader instrumentation scalaropts objcarcopts ipo vectorize all-targets codegen
++# Crappy workaround to make sure it links correctly.
+ 
++LLVMLibsOptions := ../../lib/IR/Release*/Pass.o
+ # Support plugins.
+ NO_DEAD_STRIP := 1
+ 
-- 
cgit v0.12