From 8c3ef1f72923acce99cb632e663d6f8cef751c62 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 13 Dec 2008 13:55:04 -0600
Subject: Add a delay and send more packets when checking the gw. The delay is
 needed  to give the interface time to fully init. closes FS#51

---
 abs/core-testing/LinHES-config/PKGBUILD         | 2 +-
 abs/core-testing/LinHES-config/install_proxy.sh | 7 ++++---
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 543d182..6adba49 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=103
+pkgrel=104
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index e6b0976..195d7af 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -437,7 +437,7 @@ echo "-----------------------------------------------------------------------3--
                                 check_self)
                                             myipdefault=`ifconfig  | grep -C1 $default_interface| grep -v $default_interface | cut -d: -f2 | awk '{ print $1}'`
                                             echo "network check myself"
-                                            ifconfig 
+                                            ifconfig
                                             ping -c 1 $myipdefault
                                                     if [ ! $? = 0 ]
                                                     then
@@ -448,12 +448,13 @@ echo "-----------------------------------------------------------------------3--
                                 check_gw)
                                             #check gateway
                                             echo "network check gateway"
-                                            /sbin/route -n 
+                                            /sbin/route -n
                                             mygwdefault=`/sbin/route -n  |grep $default_interface|grep UG|awk '{ print $2}'`
                                             echo "Default gateway seems to be $mygwdefault"
 					                        if  [ !  x$mygwdefault = x ]
 					                        then
-	                                            ping -c 1 $mygwdefault
+                                                sleep 2
+	                                            ping -c 5 $mygwdefault
         	                                    if [ ! $? = 0 ]
                 	                            then
                         	                        exit 4
-- 
cgit v0.12