From d90fb08baf941884021d37b592a1952a8bac7cbc Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 22 Apr 2016 18:26:33 +0000
Subject: pacman: update to 5.0.1

---
 .../0001-libmakepkg-fix-is_array-function.patch    | 32 ++++++++++++++++++
 abs/core/pacman/PKGBUILD                           | 38 ++++++++++++++--------
 abs/core/pacman/makepkg-asroot.patch               | 18 +++++-----
 abs/core/pacman/makepkg.conf                       |  9 ++---
 abs/core/pacman/pacman.conf.i686                   |  1 +
 abs/core/pacman/pacman.conf.x86_64                 |  1 +
 6 files changed, 72 insertions(+), 27 deletions(-)
 create mode 100644 abs/core/pacman/0001-libmakepkg-fix-is_array-function.patch

diff --git a/abs/core/pacman/0001-libmakepkg-fix-is_array-function.patch b/abs/core/pacman/0001-libmakepkg-fix-is_array-function.patch
new file mode 100644
index 0000000..b8ada06
--- /dev/null
+++ b/abs/core/pacman/0001-libmakepkg-fix-is_array-function.patch
@@ -0,0 +1,32 @@
+From 2822a45fa91b430c99b4b8bd3531ee745ada1ab7 Mon Sep 17 00:00:00 2001
+From: Allan McRae <allan@archlinux.org>
+Date: Fri, 26 Feb 2016 15:01:11 +1000
+Subject: [PATCH] libmakepkg: fix is_array function
+
+This happened to work for the majority of cases because the only calling
+function used a variable named "i" that was related to the variable being
+passed to the function.
+
+Fixes FS#48340.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+---
+ scripts/libmakepkg/util/util.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/libmakepkg/util/util.sh b/scripts/libmakepkg/util/util.sh
+index 675e75d..f9f1c20 100644
+--- a/scripts/libmakepkg/util/util.sh
++++ b/scripts/libmakepkg/util/util.sh
+@@ -46,7 +46,7 @@ is_array() {
+ 	local shellopts=$(shopt -p)
+ 	shopt -s extglob
+ 
+-	if [[ $(declare -p "$i") == declare\ -*([[:alnum:]])a*([[:alnum:]])\ * ]]; then
++	if [[ $(declare -p "$v") == declare\ -*([[:alnum:]])a*([[:alnum:]])\ * ]]; then
+ 		ret=0
+ 	fi
+ 
+-- 
+2.7.1
+
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index c7f2af8..877dc11 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -4,14 +4,14 @@
 # Maintainer: Dave Reisner <dreisner@archlinux.org>
 
 pkgname=pacman
-pkgver=4.2.1
-pkgrel=5
+pkgver=5.0.1
+pkgrel=2
 pkgdesc="A library-based package manager with dependency support"
 arch=('i686' 'x86_64')
 url="http://www.archlinux.org/pacman/"
 license=('GPL')
 groups=('base' 'base-devel')
-depends=('bash' 'glibc' 'libarchive>=3.1.2' 'curl>=7.39.0'
+depends=('bash' 'glibc' 'libarchive' 'curl'
          'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
 makedepends=('asciidoc')   # roundup patch alters docs
 checkdepends=('python2' 'fakechroot')
@@ -21,14 +21,22 @@ replaces=('pacman-contrib')
 backup=(etc/pacman.conf etc/makepkg.conf)
 install=pacman.install
 options=('strip' 'debug')
-source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
+source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
+        0001-libmakepkg-fix-is_array-function.patch
         pacman.conf.i686
         pacman.conf.x86_64
-        makepkg.conf
         makepkg-asroot.patch
-        pacman.cron)
+        pacman.cron
+        makepkg.conf)
 validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD')  # Allan McRae <allan@archlinux.org>
 
+
+prepare() {
+  cd "$pkgname-$pkgver"
+  
+  patch -p1 -i $srcdir/0001-libmakepkg-fix-is_array-function.patch
+}
+
 build() {
   cd "$pkgname-$pkgver"
 
@@ -36,8 +44,8 @@ build() {
     --localstatedir=/var --enable-doc \
     --with-scriptlet-shell=/usr/bin/bash \
     --with-ldconfig=/usr/bin/ldconfig
-  make
-  make -C contrib
+  make V=1
+  make -C contrib 
 }
 
 check() {
@@ -93,9 +101,11 @@ package() {
   mkdir -p "$pkgdir/usr/MythVantage/bin"
   install -m 0644 "$srcdir/pacman.cron" "$pkgdir/usr/MythVantage/bin/pacman.cron"
 }
-md5sums=('2a596fc8f723e99660c0869a74afcf47'
-         '2db6c94709bb30cc614a176ecf8badb1'
-         'de74a13618347f08ae4a9637f74471c4'
-         '03d578816b56852d803cbafac85b9f09'
-         'bd3319d98bfc9560b0a765241f9ad80c'
-         'd62e10ea6cc7ae617ba1a99d8f11eaf5')
+md5sums=('377a2664d6007d72d6d8a126add83bcf'
+         'SKIP'
+         '55732144f1048f714f1f93203e9b7728'
+         'bdb40c76225c2fd8874bd34b6a3f6ad7'
+         'c511ee4c7a86a37e8841440ede89300d'
+         '4950b7c5adf80e082a726dd11b9cb12f'
+         'd62e10ea6cc7ae617ba1a99d8f11eaf5'
+         'f5b59fe5f016eebd9590318530bbd996')
diff --git a/abs/core/pacman/makepkg-asroot.patch b/abs/core/pacman/makepkg-asroot.patch
index f45f0ee..8da3fb0 100644
--- a/abs/core/pacman/makepkg-asroot.patch
+++ b/abs/core/pacman/makepkg-asroot.patch
@@ -1,22 +1,22 @@
---- makepkg.orig	2015-02-16 13:15:31.079071494 +0000
-+++ makepkg	2015-02-16 13:18:14.735730577 +0000
-@@ -3372,7 +3372,7 @@
+--- makepkg.orig	2016-04-22 15:35:51.860386914 +0000
++++ makepkg	2016-04-22 15:39:19.543784899 +0000
+@@ -1917,7 +1917,7 @@
            'help' 'holdver' 'ignorearch' 'install' 'key:' 'log' 'noarchive' 'nobuild'
-           'nocolor' 'nocheck' 'nodeps' 'noextract' 'noprepare' 'nosign' 'pkg:' 'repackage'
-           'rmdeps' 'sign' 'skipchecksums' 'skipinteg' 'skippgpcheck' 'source' 'syncdeps'
--          'verifysource' 'version')
-+          'verifysource' 'version' 'asroot')
+           'nocolor' 'nocheck' 'nodeps' 'noextract' 'noprepare' 'nosign' 'packagelist'
+           'printsrcinfo' 'repackage' 'rmdeps' 'sign' 'skipchecksums' 'skipinteg'
+-          'skippgpcheck' 'source' 'syncdeps' 'verifysource' 'version')
++          'skippgpcheck' 'source' 'syncdeps' 'verifysource' 'version' 'asroot')
  
  # Pacman Options
  OPT_LONG+=('asdeps' 'noconfirm' 'needed' 'noprogressbar')
-@@ -3581,9 +3581,7 @@
+@@ -2114,9 +2114,7 @@
  
  if (( ! INFAKEROOT )); then
  	if (( EUID == 0 )); then
 -		error "$(gettext "Running %s as root is not allowed as it can cause permanent,\n\
 -catastrophic damage to your system.")" "makepkg"
 -		exit 1 # $E_USER_ABORT
-+               :  
++               :
  	fi
  else
  	if [[ -z $FAKEROOTKEY ]]; then
diff --git a/abs/core/pacman/makepkg.conf b/abs/core/pacman/makepkg.conf
index e147806..bd0e0cf 100644
--- a/abs/core/pacman/makepkg.conf
+++ b/abs/core/pacman/makepkg.conf
@@ -37,8 +37,8 @@ CHOST="@CHOST@"
 # -march (or -mcpu) builds exclusively for an architecture
 # -mtune optimizes for an architecture, but builds for whole processor family
 CPPFLAGS="-D_FORTIFY_SOURCE=2"
-CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
-CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4"
+CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong"
+CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong"
 LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro"
 #-- Make Flags: change this for DistCC/SMP systems
 #MAKEFLAGS="-j2"
@@ -73,7 +73,7 @@ BUILDENV=(!distcc color !ccache check !sign)
 #   These are default values for the options=() settings
 #########################################################################
 #
-# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !upx !debug)
+# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
 #  A negated option will do the opposite of the comments below.
 #
 #-- strip:      Strip symbols from binaries/libraries
@@ -84,9 +84,10 @@ BUILDENV=(!distcc color !ccache check !sign)
 #-- zipman:     Compress manual (man and info) pages in MAN_DIRS with gzip
 #-- purge:      Remove files specified by PURGE_TARGETS
 #-- upx:        Compress binary executable files using UPX
+#-- optipng:    Optimize PNG images with optipng
 #-- debug:      Add debugging flags as specified in DEBUG_* variables
 #
-OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !upx !debug)
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
 
 #-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
 INTEGRITY_CHECK=(md5)
diff --git a/abs/core/pacman/pacman.conf.i686 b/abs/core/pacman/pacman.conf.i686
index 92e76b4..0ea1570 100644
--- a/abs/core/pacman/pacman.conf.i686
+++ b/abs/core/pacman/pacman.conf.i686
@@ -14,6 +14,7 @@
 #CacheDir    = /var/cache/pacman/pkg/
 #LogFile     = /var/log/pacman.log
 #GPGDir      = /etc/pacman.d/gnupg/
+#HookDir     = /etc/pacman.d/hooks/
 HoldPkg     = pacman glibc
 #XferCommand = /usr/bin/curl -C - -f %u > %o
 #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
diff --git a/abs/core/pacman/pacman.conf.x86_64 b/abs/core/pacman/pacman.conf.x86_64
index f43fe39..8ce6919 100644
--- a/abs/core/pacman/pacman.conf.x86_64
+++ b/abs/core/pacman/pacman.conf.x86_64
@@ -14,6 +14,7 @@
 #CacheDir    = /var/cache/pacman/pkg/
 #LogFile     = /var/log/pacman.log
 #GPGDir      = /etc/pacman.d/gnupg/
+#HookDir     = /etc/pacman.d/hooks/
 HoldPkg     = pacman glibc
 #XferCommand = /usr/bin/curl -C - -f %u > %o
 #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-- 
cgit v0.12