From 9e540eace91dfd8da305ba816e40be3d9eb4e306 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 31 Jan 2010 20:53:59 -0600
Subject: linhes-config: addsupport for mupen and remove vodka

---
 abs/core-testing/LinHES-config/PKGBUILD       |  2 +-
 abs/core-testing/LinHES-config/mv_common.py   |  6 ++++++
 abs/core-testing/LinHES-config/mv_software.py | 10 +++++-----
 3 files changed, 12 insertions(+), 6 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 84bcbda..201c16e 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.1
-pkgrel=17
+pkgrel=23
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted' 
diff --git a/abs/core-testing/LinHES-config/mv_common.py b/abs/core-testing/LinHES-config/mv_common.py
index a492597..28b53d7 100755
--- a/abs/core-testing/LinHES-config/mv_common.py
+++ b/abs/core-testing/LinHES-config/mv_common.py
@@ -107,6 +107,8 @@ def pacinstall(pkg):
         add_service("webmin")
     elif pkg == "fuppes":
         pacinstall("fuppes-svn")
+    elif pkg == "mupen64":
+        pacinstall("mupen64plus-svn")
 
     if  not pkg_blacklist_check(pkg):
         if pkg_installed_check(pkg):
@@ -126,6 +128,10 @@ def pacremove(pkg):
         pacremove("libdvdcss")
     elif pkg == "webmin":
         remove_service("webmin")
+    elif pkg == "fuppes":
+        pacremove("fuppes-svn")
+    elif pkg == "mupen64":
+        pacremove("mupen64plus-svn")
 
     if  not pkg_blacklist_check(pkg):
         if not pkg_installed_check(pkg):
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index aabcf89..4ee2e4d 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -13,23 +13,23 @@ def setup_software(systemconfig, data_config):
         postfix = "-release-fixes"
       else:
         postfix = "-svn"
-
+#This section is for MythVantage OS, not LINHES
       default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
                           "mythgame", "mythflix", "mythweather",
-			  "mythzoneminder" )
+			  "mythzoneminder","mythnetvision" )
 
       default_installed=("mythcontrols", "mythgallery", "mythmovies",
                           "mythmusic", "mythsmolt", "mythvideo")
-      other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mythvodka")
+      other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mupen64")
     else:
       default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
                           "mythgame", "mythflix", "mythweather",
                           "mythappletrailers", "mythstream", "mythvodka",
-			  "mythzoneminder" )
+			  "mythzoneminder","mythnetvision" )
 
       default_installed=("mythcontrols", "mythgallery", "mythmovies",
                           "mythmusic", "mythsmolt", "mythvideo")
-      other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome")
+      other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome","mupen64")
 
     for pkg in default_disabled:
         pkgname=pkg+postfix
-- 
cgit v0.12