From 67c5698d8b76e2020442bb6327625cb1396064d3 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 16 Aug 2014 12:50:32 -0500
Subject: hddtemp: .03-beta refs #961

---
 abs/extra/hddtemp/PKGBUILD | 15 ++++-----------
 abs/extra/hddtemp/conf.d   |  2 --
 abs/extra/hddtemp/rc.d     | 39 ---------------------------------------
 abs/extra/hddtemp/service  |  3 +--
 4 files changed, 5 insertions(+), 54 deletions(-)
 delete mode 100644 abs/extra/hddtemp/conf.d
 delete mode 100644 abs/extra/hddtemp/rc.d

diff --git a/abs/extra/hddtemp/PKGBUILD b/abs/extra/hddtemp/PKGBUILD
index 94073ce..dcf2b6b 100644
--- a/abs/extra/hddtemp/PKGBUILD
+++ b/abs/extra/hddtemp/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 163630 2012-07-17 14:24:03Z bisson $
+# $Id: PKGBUILD 198097 2013-10-30 12:47:12Z allan $
 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
 # Contributor: Ionut Biru <ibiru@archlinux.org>
 # Contributor: Andrea Scarpino <andrea@archlinux.org>
@@ -9,24 +9,18 @@ pkgname=hddtemp
 _origver=0.3-beta15
 _patchver=${_origver}-52
 pkgver=${_patchver//-/.}
-pkgrel=1
+pkgrel=2
 pkgdesc="Gives you the temperature of your hard drive by reading S.M.A.R.T. information"
 url='https://savannah.nongnu.org/projects/hddtemp/'
 license=('GPL')
 arch=('i686' 'x86_64')
-backup=('etc/conf.d/hddtemp')
 source=("http://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${_origver}.tar.bz2"
         "http://ftp.debian.org/debian/pool/main/h/${pkgname}/${pkgname}_${_patchver}.diff.gz"
-        'rc.d'
-        'conf.d'
         'service')
 sha1sums=('65393b0a4d9862c030c81702d95c1acd00da275b'
           'b9bcdd0537c1540e55e5056445b571ea61d5a4a3'
-          '71159486b1505ec6acfb7585e0d8fbe78afe54ec'
-          'd45e3022f614dbf8904ecb1a3e702bb71fcaa808'
-          '501fcf4faf8b2689d010f9cbbf39f917211f611f')
+          '9b02e5bed22f81ceab2b69bae788a9a3aa5c2147')
 
-options=('!libtool')
 
 build() {
 	cd "${srcdir}/${pkgname}-${_origver}"
@@ -35,6 +29,7 @@ build() {
 
 	./configure \
 		--prefix=/usr \
+		--sbindir=/usr/bin \
 		--mandir=/usr/share/man \
 		--with-db-path="/usr/share/${pkgname}/hddtemp.db"
 
@@ -48,6 +43,4 @@ package() {
 
 	install -Dm644 "../${pkgname}-${_origver}/debian/hddtemp.db" "${pkgdir}/usr/share/${pkgname}/hddtemp.db"
 	install -Dm644 '../service' "${pkgdir}/usr/lib/systemd/system/hddtemp.service"
-	install -Dm644 '../conf.d' "${pkgdir}/etc/conf.d/hddtemp"
-	install -Dm755 '../rc.d' "${pkgdir}/etc/rc.d/hddtemp"
 }
diff --git a/abs/extra/hddtemp/conf.d b/abs/extra/hddtemp/conf.d
deleted file mode 100644
index 6a1e18e..0000000
--- a/abs/extra/hddtemp/conf.d
+++ /dev/null
@@ -1,2 +0,0 @@
-PARAMS="-q -l 127.0.0.1"
-DRIVES="/dev/sda"
diff --git a/abs/extra/hddtemp/rc.d b/abs/extra/hddtemp/rc.d
deleted file mode 100644
index 62f0908..0000000
--- a/abs/extra/hddtemp/rc.d
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PARAMS=
-DRIVES=
-[ -f /etc/conf.d/hddtemp ] && . /etc/conf.d/hddtemp
-PID=$(pidof -o %PPID /usr/sbin/hddtemp)
-case "$1" in
-  start)
-    stat_busy "Starting HDDTemp"
-    [ -z "$PID" ] && /usr/sbin/hddtemp -d $PARAMS $DRIVES
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      add_daemon hddtemp
-      stat_done
-    fi
-    ;;
-  stop)
-    stat_busy "Stopping HDDTemp"
-    [ ! -z "$PID" ]  && kill $PID &> /dev/null
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      rm_daemon hddtemp
-      stat_done
-    fi 
-    ;;
-  restart)
-    $0 stop
-    sleep 2
-    $0 start
-    ;;
-  *)
-    echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/extra/hddtemp/service b/abs/extra/hddtemp/service
index bc56d16..992b898 100644
--- a/abs/extra/hddtemp/service
+++ b/abs/extra/hddtemp/service
@@ -2,8 +2,7 @@
 Description=Hard drive temperature monitor daemon
 
 [Service]
-EnvironmentFile=/etc/conf.d/hddtemp 
-ExecStart=/usr/sbin/hddtemp -dF $PARAMS $DRIVES
+ExecStart=/usr/bin/hddtemp -dF /dev/sda
 
 [Install]
 WantedBy=multi-user.target
-- 
cgit v0.12