From 3e0887cb811e0e1bb9fa730c50a22c101117c9fd Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 20 Mar 2010 22:47:12 -0500
Subject: php: fix sed in install file to account for / in the timezone closes
 649

---
 abs/core-testing/php/PKGBUILD    | 2 +-
 abs/core-testing/php/php.install | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 65862a9..9e297f0 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=php
 pkgver=5.2.6
-pkgrel=29
+pkgrel=31
 _suhosinver=0.9.6.2
 pkgdesc='A high-level scripting language'
 arch=('i686' 'x86_64')
diff --git a/abs/core-testing/php/php.install b/abs/core-testing/php/php.install
index 469db4a..1981a63 100644
--- a/abs/core-testing/php/php.install
+++ b/abs/core-testing/php/php.install
@@ -4,7 +4,7 @@ post_install() {
 		. /etc/systemconfig
 		if [ -f /etc/php/php.ini ]
 		then
-	       	    sed -i 's/^.*date.timezone.*$/date.timezone='${timezone}'/' /etc/php/php.ini
+	       	    sed -i 's|^.*date.timezone.*$|date.timezone='${timezone}'|' /etc/php/php.ini
 		fi
 	fi
 }
@@ -40,7 +40,7 @@ post_upgrade() {
 		. /etc/systemconfig
 		if [ -f /etc/php/php.ini ]
 		then
-	       	    sed -i 's/^.*date.timezone.*$/date.timezone='${timezone}'/' /etc/php/php.ini
+	       	    sed -i 's|^.*date.timezone.*$|date.timezone='${timezone}'|' /etc/php/php.ini
 		fi
 	fi
     echo 'Updating extension dir...'
-- 
cgit v0.12