From a256cea7231ed200a5dc44d4f15e9cbd5f04e6e6 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 16 Feb 2014 18:05:02 -0600
Subject: gnu-efi-libs: first include update binary path to /usr/bin refs #961

---
 abs/extra/gnu-efi-libs/PKGBUILD | 47 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
 create mode 100644 abs/extra/gnu-efi-libs/PKGBUILD

diff --git a/abs/extra/gnu-efi-libs/PKGBUILD b/abs/extra/gnu-efi-libs/PKGBUILD
new file mode 100644
index 0000000..7487c8b
--- /dev/null
+++ b/abs/extra/gnu-efi-libs/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Keshav Padram <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+_pkgver="3.0"
+pkgname="gnu-efi-libs"
+pkgver="${_pkgver}u"
+pkgrel="4"
+pkgdesc="Library for building UEFI Applications using GNU toolchain"
+url="http://sourceforge.net/projects/gnu-efi/"
+license=('GPL')
+arch=('x86_64' 'i686')
+options=('!strip' '!makeflags' 'staticlibs')
+makedepends=('pciutils')
+
+source=("http://download.sourceforge.net/gnu-efi/gnu-efi_${pkgver}.orig.tar.gz")
+
+[[ "${CARCH}" == "x86_64" ]] && _EFI_ARCH="x86_64"
+[[ "${CARCH}" == "i686" ]] && _EFI_ARCH="ia32"
+
+build() {
+	
+	cd "${srcdir}/gnu-efi-${_pkgver}/"
+	
+	## Unset all compiler FLAGS
+	unset CFLAGS
+	unset CPPFLAGS
+	unset CXXFLAGS
+	unset LDFLAGS
+	unset MAKEFLAGS
+	
+	make -j1
+	make -j1 -C apps all
+	
+}
+
+package() {
+	
+	cd "${srcdir}/gnu-efi-${_pkgver}/"
+	
+	make INSTALLROOT="${pkgdir}" PREFIX="/usr" LIBDIR="/usr/lib" install
+	
+	install -d "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
+	install -D -m0644 "${srcdir}/gnu-efi-${_pkgver}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
+	
+}
+md5sums=('d15d3c700e79a1e2938544d73edc572d')
-- 
cgit v0.12