From 215fbfb801eb609acb4244dcb38e6e36b11a4f36 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 12 Feb 2014 00:09:07 +0000
Subject: mythtv mythplugins mythinstall: update to latest fixes

mytharchive: patch menu files with descriptions
---
 abs/core/mythinstall/PKGBUILD                      |  2 +-
 abs/core/mythtv/stable-0.27/git_src/git_hash       |  2 +-
 abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD   | 10 +++++--
 .../stable-0.27/mythplugins/archivemenu.xml.patch  | 32 ++++++++++++++++++++++
 .../stable-0.27/mythplugins/archiveutils.xml.patch | 27 ++++++++++++++++++
 abs/core/mythtv/stable-0.27/mythtv/PKGBUILD        |  2 +-
 6 files changed, 69 insertions(+), 6 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch
 create mode 100644 abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch

diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 5a64034..a161985 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.1
-pkgrel=7
+pkgrel=8
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
diff --git a/abs/core/mythtv/stable-0.27/git_src/git_hash b/abs/core/mythtv/stable-0.27/git_src/git_hash
index 76debbd..bb4009e 100644
--- a/abs/core/mythtv/stable-0.27/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.27/git_src/git_hash
@@ -1 +1 @@
-7f548de029ed84870538c87193b8b9f650cf0c5a
+9bf1070d86ab4ca515830f4d330f7b720830463c
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
index 8a651cd..b7a5006 100644
--- a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=0.27
-pkgrel=9
+pkgrel=10
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
@@ -19,7 +19,7 @@ makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexi
              'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
              'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python-imaging'
              'python-pycurl' 'zlib')
-source=('mythburn.py-aspectratio.patch')
+source=('mythburn.py-aspectratio.patch' 'archivemenu.xml.patch' 'archiveutils.xml.patch')
 
 build() {
     if [ -e ${srcdir}/mythplugins ]
@@ -49,6 +49,8 @@ package_mytharchive() {
              'python-imaging')
     cd "${srcdir}/${_gitname}/${pkgbase}/mytharchive"
     patch mythburn/scripts/mythburn.py < $srcdir/mythburn.py-aspectratio.patch || return 1
+    patch theme/menus/archivemenu.xml < $srcdir/archivemenu.xml.patch || return 1
+    patch theme/menus/archiveutils.xml < $srcdir/archiveutils.xml.patch || return 1
     make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
@@ -113,4 +115,6 @@ package_mythzoneminder() {
     make INSTALL_ROOT="${pkgdir}" install || return 1
 }
 
-md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2')
+md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
+         '0364d2613f22943f3d4c9d5ee43c1982'
+         '1063cf62878cd341476f28f63cb12782')
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch b/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch
new file mode 100644
index 0000000..f53e9d0
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/archivemenu.xml.patch
@@ -0,0 +1,32 @@
+--- archivemenu.xml.orig	2014-02-11 23:01:41.292364208 +0000
++++ archivemenu.xml	2014-02-11 23:02:13.544892518 +0000
+@@ -3,12 +3,14 @@
+    <button>
+       <type>ARCHIVE_CREATE_DVD</type>
+       <text>Create DVD</text>
++      <description>Save recordings and videos to video DVD</description>
+       <action>ARCHIVE_CREATE_DVD</action>
+    </button>
+ 
+    <button>
+       <type>ARCHIVE_CREATE_ARCHIVE</type>
+       <text>Create Archive</text>
++      <description>Save recordings and videos to a native archive</description>
+       <action>ARCHIVE_CREATE_ARCHIVE</action>
+   </button>
+ 
+@@ -22,12 +24,14 @@
+    <button>
+        <type>ARCHIVE_IMPORT_VIDEO</type>
+        <text>Import Archive</text>
++       <description>Import recordings from a native archive</description>
+        <action>ARCHIVE_IMPORT_VIDEO</action>
+    </button>
+ 
+    <button>
+        <type>ARCHIVE_UTILITIES</type>
+        <text>Archive Utilities</text>
++       <description>Utilities for MythArchive</description>
+        <action>MENU archiveutils.xml</action>
+    </button>
+ 
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch b/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch
new file mode 100644
index 0000000..9c17678
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/archiveutils.xml.patch
@@ -0,0 +1,27 @@
+--- archiveutils.xml.orig	2014-02-11 23:01:41.292364208 +0000
++++ archiveutils.xml	2014-02-11 23:02:13.544892518 +0000
+@@ -2,19 +2,22 @@
+ 
+    <button>
+       <type>ARCHIVE_LAST_LOG</type>
+-      <text>Show Log Viewer</text>
++      <text>Log Viewer</text>
++      <description>Show the Archive Log Viewer</description>
+       <action>ARCHIVE_LAST_LOG</action>
+    </button>
+ 
+    <button>
+        <type>ARCHIVE_TEST_DVD</type>
+        <text>Play Created DVD</text>
++       <description>Play the last created archive DVD</description>
+        <action>ARCHIVE_TEST_DVD</action>
+    </button>
+ 
+    <button>
+        <type>ARCHIVE_BURN_DVD</type>
+-       <text>Burn DVD</text>
++       <text>Burn Created DVD</text>
++       <description>Burn the last created archive to DVD</description>
+        <action>ARCHIVE_BURN_DVD</action>
+    </button>
+ 
diff --git a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
index 973fed4..4500705 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.27
-pkgrel=9
+pkgrel=10
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
-- 
cgit v0.12