From 922c15990fa416ab24e5bb0cbf2a65891e69bbc6 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 13 May 2014 19:15:03 +0000
Subject: python-beaker: initial inclusion. dep of python-mako

---
 abs/core/python_modules/python-beaker/PKGBUILD    | 42 +++++++++++++++++++++++
 abs/core/python_modules/python-beaker/__changelog |  1 +
 2 files changed, 43 insertions(+)
 create mode 100644 abs/core/python_modules/python-beaker/PKGBUILD
 create mode 100644 abs/core/python_modules/python-beaker/__changelog

diff --git a/abs/core/python_modules/python-beaker/PKGBUILD b/abs/core/python_modules/python-beaker/PKGBUILD
new file mode 100644
index 0000000..fbc3bae
--- /dev/null
+++ b/abs/core/python_modules/python-beaker/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Massimiliano Torromeo < massimiliano DOT torromeo AT gmail DOT com >
+
+pkgname=('python2-beaker')
+pkgver=1.6.4
+pkgrel=2
+arch=('any')
+license=('custom')
+pkgdesc="Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications"
+url="http://beaker.groovie.org/"
+makedepends=('python2-setuptools')
+source=("http://cheeseshop.python.org/packages/source/B/Beaker/Beaker-${pkgver}.tar.gz")
+md5sums=('c2e102870ed4c53104dec48ceadf8e9d')
+
+build() {
+    cp -r Beaker-${pkgver} python2-Beaker-${pkgver}
+
+    cd "${srcdir}/Beaker-${pkgver}"
+    sed -i "s#/usr/bin/python#/usr/bin/python3#" beaker/crypto/pbkdf2.py
+#    python3 setup.py build
+
+    cd "${srcdir}/python2-Beaker-${pkgver}"
+    sed -i "s#/usr/bin/python#/usr/bin/python2#" beaker/crypto/pbkdf2.py
+    python2 setup.py build
+}
+
+#package_python-beaker() {
+#    depends=('python')
+
+#    cd "${srcdir}/Beaker-${pkgver}"
+#    python3 setup.py install --root="${pkgdir}" --optimize=1
+#    install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-beaker/LICENSE"
+#}
+
+package_python2-beaker() {
+    depends=('python2')
+
+    cd "${srcdir}/python2-Beaker-${pkgver}"
+    python2 setup.py install --root="${pkgdir}" --optimize=1
+    install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python2-beaker/LICENSE"
+}
diff --git a/abs/core/python_modules/python-beaker/__changelog b/abs/core/python_modules/python-beaker/__changelog
new file mode 100644
index 0000000..9715c21
--- /dev/null
+++ b/abs/core/python_modules/python-beaker/__changelog
@@ -0,0 +1 @@
+PKGBUILD - comment out all python 3 stuff and only build for py 2
-- 
cgit v0.12