From 435b126345ee80909cdcf4b37bd1eb3678a7f02c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 3 Dec 2014 20:22:55 +0000
Subject: mplayer: update to 37224

---
 abs/core/mplayer/PKGBUILD               | 42 ++++++++++++---------
 abs/core/mplayer/__changelog            |  1 -
 abs/core/mplayer/giflib51.patch         | 24 ++++++++++++
 abs/core/mplayer/revert-icl-fixes.patch | 66 +++++++++++++++++++++++++++++++++
 4 files changed, 114 insertions(+), 19 deletions(-)
 create mode 100644 abs/core/mplayer/giflib51.patch
 create mode 100644 abs/core/mplayer/revert-icl-fixes.patch

diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index 01b69c4..7dbdf3f 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -5,42 +5,48 @@
 
 pkgbase=mplayer
 pkgname=('mplayer' 'mencoder')
-pkgver=37051
+pkgver=37224
 pkgrel=3
 arch=('i686' 'x86_64')
 makedepends=(
   'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
   'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'libcaca'
-  'x264' 'faac' 'faad2' 'lirc-utils'  'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
+  'faac' 'faad2' 'lirc-utils'  'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
   'libdca' 'a52dec' 'schroedinger' 'libvpx' 'fribidi' 'unzip' 'mesa'
   'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
-  'libcdio-paranoia' 'opus'
+  'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gsm'
 )
 license=('GPL')
 url='http://www.mplayerhq.hu/'
 options=('!buildflags' '!emptydirs')
 source=($pkgbase-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver
-        http://ffmpeg.org/releases/ffmpeg-2.2.tar.bz2
+        http://ffmpeg.org/releases/ffmpeg-2.2.10.tar.bz2
         mplayer.desktop
         cdio-includes.patch
-        include-samba-4.0.patch)
+        include-samba-4.0.patch
+        giflib51.patch
+        revert-icl-fixes.patch)
 md5sums=('SKIP'
-         '744febca199548c9393b1f1ed05ccdd8'
+         'f40a829f5075c8ee901e5dbc6d40c209'
          '62f44a58f072b2b1a3c3d3e4976d64b3'
          '7b5be7191aafbea64218dc4916343bbc'
-         '868a92bdef148df7f38bfa992b26ce9d')
+         '868a92bdef148df7f38bfa992b26ce9d'
+         '14461fb94b7aa5dda091ba4f737df2d9'
+         '3579402002b7302fdf2d146639333efd')
 
-#pkgver() {
-#  cd $pkgbase-$pkgver
-#  svnversion
-#}
+pkgver() {
+  cd $pkgbase-$pkgver
+  svnversion
+}
 
 prepare() {
   cd $pkgbase-$pkgver
-  mv ../ffmpeg-2.2 ./ffmpeg
+  mv ../ffmpeg-2.2.10 ./ffmpeg
 
   patch -p0 -i ../cdio-includes.patch
   patch -p1 -i ../include-samba-4.0.patch
+  patch -Np0 -i ../giflib51.patch
+  patch -Np0 -i ../revert-icl-fixes.patch
 
   ./version.sh
 }
@@ -78,11 +84,12 @@ package_mplayer() {
   backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
   depends=(
     'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
-    'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
+    'lirc-utils' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
     'libgl' 'libxinerama' 'libvdpau' 'smbclient' 'xvidcore'
     'opencore-amr' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
     'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
-    'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus'
+    'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
+    'gsm'
   )
 
   cd $pkgbase-$pkgver
@@ -101,14 +108,13 @@ package_mplayer() {
 package_mencoder() {
   pkgdesc='Free command line video decoding, encoding and filtering tool'
   depends=(
-    'enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame'
+    'enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'bzip2' 'lame'
     'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
     'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
     'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
-    'libvorbis' 'opus'
+    'libvorbis' 'opus' 'rtmpdump' 'gsm'
   )
 
   make -C $pkgbase-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
-  #find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
-  rm -rf $pkgdir/usr/share/man
+  find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
 }
diff --git a/abs/core/mplayer/__changelog b/abs/core/mplayer/__changelog
index 46c977a..c723332 100644
--- a/abs/core/mplayer/__changelog
+++ b/abs/core/mplayer/__changelog
@@ -1,3 +1,2 @@
 PKGBUILD - remove dep libpulse
 PKGBUILD - remove dep jack
-PKGBUILD - remove man pages from mencoder
diff --git a/abs/core/mplayer/giflib51.patch b/abs/core/mplayer/giflib51.patch
new file mode 100644
index 0000000..e884b39
--- /dev/null
+++ b/abs/core/mplayer/giflib51.patch
@@ -0,0 +1,24 @@
+--- libvo/vo_gif89a.c.orig	2014-06-11 10:06:29.243216331 +0000
++++ libvo/vo_gif89a.c	2014-06-11 10:08:37.346078847 +0000
+@@ -75,6 +75,9 @@
+ #define MakeMapObject GifMakeMapObject
+ #define FreeMapObject GifFreeMapObject
+ #define QuantizeBuffer GifQuantizeBuffer
++#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
++#define EGifCloseFile(a) EGifCloseFile(a, NULL)
++#endif
+ #endif
+ 
+ // how many frames per second we are aiming for during output.
+--- libmpdemux/demux_gif.c.orig	2014-06-11 10:46:48.120883788 +0000
++++ libmpdemux/demux_gif.c	2014-06-11 10:47:28.290732272 +0000
+@@ -50,6 +50,9 @@
+ #define DGifOpenFileHandle(a) DGifOpenFileHandle(a, NULL)
+ #define GifError() (gif ? gif->Error : 0)
+ #define GifErrorString() GifErrorString(gif->Error)
++#if defined GIFLIB_MINOR && GIFLIB_MINOR >= 1
++#define DGifCloseFile(a) DGifCloseFile(a, NULL)
++#endif
+ #endif
+ 
+ /* >= 4.2 prior GIFLIB did not have MAJOR/MINOR defines */
diff --git a/abs/core/mplayer/revert-icl-fixes.patch b/abs/core/mplayer/revert-icl-fixes.patch
new file mode 100644
index 0000000..e5f049f
--- /dev/null
+++ b/abs/core/mplayer/revert-icl-fixes.patch
@@ -0,0 +1,66 @@
+Index: libmpcodecs/vf_fspp.c
+===================================================================
+--- libmpcodecs/vf_fspp.c	(revision 37183)
++++ libmpcodecs/vf_fspp.c	(revision 37181)
+@@ -1598,10 +1598,6 @@
+ 
+         : "+S"(data), "+D"(output), "+c"(cnt), "=o"(temps)
+         : "d"(thr_adr)
+-          NAMED_CONSTRAINTS_ADD(ff_MM_FIX_0_707106781,MM_2,MM_FIX_1_414213562_A,MM_FIX_1_414213562,MM_FIX_0_382683433,
+-          ff_MM_FIX_0_541196100,MM_FIX_1_306562965,MM_FIX_0_847759065)
+-          NAMED_CONSTRAINTS_ADD(MM_FIX_0_566454497,MM_FIX_0_198912367,MM_FIX_2_613125930,MM_FIX_1_847759065,
+-          MM_FIX_1_082392200)
+         : "%"REG_a
+         );
+ }
+@@ -1871,8 +1867,6 @@
+ 
+         : "+S"(workspace), "+D"(output_adr), "+c"(cnt), "=o"(temps)
+         : "a"(output_stride*sizeof(short))
+-        NAMED_CONSTRAINTS_ADD(MM_FIX_1_414213562_A,MM_FIX_2_613125930,MM_FIX_1_847759065,MM_FIX_1_082392200,
+-        MM_FIX_1_414213562,MM_DESCALE_RND)
+         : "%"REG_d
+         );
+ }
+@@ -1980,10 +1974,10 @@
+         "movd (%%"REG_S",%%"REG_a",2), %%mm3    \n\t" //5
+         "paddw %%mm4, %%mm1            \n\t"
+ 
+-        "movq %%mm5, %3                \n\t" //t7
++        "movq %%mm5, 0*8+%3            \n\t" //t7
+         "punpcklbw %%mm7, %%mm3        \n\t"
+ 
+-        "movq %%mm6, %4                \n\t" //t6
++        "movq %%mm6, 1*8+%3            \n\t" //t6
+         "movq %%mm2, %%mm4             \n\t"
+ 
+         "movd (%%"REG_S"), %%mm5           \n\t" //3
+@@ -2029,7 +2023,7 @@
+         "psubw %%mm1, %%mm5            \n\t" //d1
+         "movq %%mm0, %%mm6             \n\t"
+ 
+-        "movq %4, %%mm1                \n\t"
++        "movq 1*8+%3, %%mm1            \n\t"
+         "punpcklwd %%mm5, %%mm0        \n\t"
+ 
+         "punpckhwd %%mm5, %%mm6        \n\t"
+@@ -2053,7 +2047,7 @@
+         "movq %%mm7, "DCTSIZE_S"*3*2(%%"REG_D") \n\t"
+         "psllw $2, %%mm3              \n\t" //t10
+ 
+-        "movq %3, %%mm2               \n\t"
++        "movq 0*8+%3, %%mm2           \n\t"
+         "psllw $2, %%mm4              \n\t" //t11
+ 
+         "pmulhw "MANGLE(MM_FIX_0_707106781)", %%mm4 \n\t" //z3
+@@ -2116,9 +2110,8 @@
+         "dec %%"REG_c"                   \n\t"
+         "jnz 6b                  \n\t"
+ 
+-        : "+S"(pixels), "+D"(data), "+c"(cnt), "=o"(temps), "=o"(temps[1])
++        : "+S"(pixels), "+D"(data), "+c"(cnt), "=o"(temps)
+         : "a"(line_size)
+-        NAMED_CONSTRAINTS_ADD(ff_MM_FIX_0_707106781,ff_MM_FIX_0_541196100,MM_FIX_0_382683433,MM_FIX_1_306562965)
+         : "%"REG_d);
+ }
+ 
-- 
cgit v0.12