From 63cd6b6bf8541516ed0539bcb3a95c6454b69a3d Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 15 Aug 2012 10:42:06 -0500
Subject: lua : removed from extra

---
 abs/extra/community/lua/PKGBUILD            | 36 -------------------
 abs/extra/community/lua/lua-5.1-cflags.diff | 13 -------
 abs/extra/community/lua/lua-arch.patch      | 55 -----------------------------
 3 files changed, 104 deletions(-)
 delete mode 100644 abs/extra/community/lua/PKGBUILD
 delete mode 100644 abs/extra/community/lua/lua-5.1-cflags.diff
 delete mode 100644 abs/extra/community/lua/lua-arch.patch

diff --git a/abs/extra/community/lua/PKGBUILD b/abs/extra/community/lua/PKGBUILD
deleted file mode 100644
index 9b30c5b..0000000
--- a/abs/extra/community/lua/PKGBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id: PKGBUILD 86292 2010-07-28 06:43:46Z juergen $
-# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
-# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-
-pkgname=lua 
-pkgver=5.1.4
-pkgrel=6
-pkgdesc="A powerful light-weight programming language designed for extending applications." 
-arch=('i686' 'x86_64')
-url="http://www.lua.org/" 
-depends=('readline' 'ncurses') 
-license=('MIT')
-options=('!makeflags')
-source=(http://www.lua.org/ftp/${pkgname}-${pkgver}.tar.gz http://www.lua.org/ftp/patch-lua-5.1.4-2 lua-arch.patch lua-5.1-cflags.diff)
-md5sums=('d0870f2de55d59c1c8419f36e8fac150' '1239310e0c4a581c7831e596f95cc6cd'\
-         '6c5953f63904bf20a0183cdab05b80de' '249582bf1fd861ccf492d2c35a9fe732')
-
-build() { 
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  patch -p1 -i "${srcdir}/lua-arch.patch"
-  patch -i ${srcdir}/patch-lua-5.1.4-2 -d src
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  [ "$CARCH" == "x86_64" ] && patch -Np1 -i ../lua-5.1-cflags.diff
-  [ "$CARCH" == "x86_64" ] && export CFLAGS="$CFLAGS -fPIC"
-  make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" LUA_SO=liblua.so  INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
-    linux install  || return 1
-  install -D -m 644 etc/lua.pc "${pkgdir}/usr/lib/pkgconfig/lua.pc"
-  install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
-
-  # Install the documentation
-  mkdir -p "${pkgdir}/usr/share/doc/lua"
-  cp -R doc/* "${pkgdir}/usr/share/doc/lua"
-}
diff --git a/abs/extra/community/lua/lua-5.1-cflags.diff b/abs/extra/community/lua/lua-5.1-cflags.diff
deleted file mode 100644
index db658ae..0000000
--- a/abs/extra/community/lua/lua-5.1-cflags.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
---- lua-5.1.orig/src/Makefile	2006-02-16 16:45:09.000000000 +0100
-+++ lua-5.1/src/Makefile	2006-03-01 14:55:29.000000000 +0100
-@@ -8,7 +8,8 @@
- PLAT= none
- 
- CC= gcc
--CFLAGS= -O2 -Wall $(MYCFLAGS)
-+CFLAGS ?= -O2 -Wall
-+CFLAGS += $(MYCFLAGS)
- AR= ar rcu
- RANLIB= ranlib
- RM= rm -f
diff --git a/abs/extra/community/lua/lua-arch.patch b/abs/extra/community/lua/lua-arch.patch
deleted file mode 100644
index cc1f3ce..0000000
--- a/abs/extra/community/lua/lua-arch.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -ur lua-5.1.orig/etc/lua.pc lua-5.1/etc/lua.pc
---- lua-5.1.orig/etc/lua.pc	2006-03-21 11:51:53.000000000 +0100
-+++ lua-5.1/etc/lua.pc	2006-03-21 11:52:05.000000000 +0100
-@@ -6,7 +6,7 @@
- V= 5.1
- 
- # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
--prefix= /usr/local
-+prefix= /usr
- INSTALL_BIN= ${prefix}/bin
- INSTALL_INC= ${prefix}/include
- INSTALL_LIB= ${prefix}/lib
-diff -ur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
---- lua-5.1.orig/src/Makefile	2006-03-21 11:51:53.000000000 +0100
-+++ lua-5.1/src/Makefile	2006-03-21 11:52:09.000000000 +0100
-@@ -23,6 +23,7 @@
- PLATS= aix ansi bsd generic linux macosx mingw posix solaris
- 
- LUA_A=	liblua.a
-+LUA_SO=	liblua.so
- CORE_O=	lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
- 	lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o  \
- 	lundump.o lvm.o lzio.o
-@@ -36,7 +37,7 @@
- LUAC_O=	luac.o print.o
- 
- ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
--ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
- ALL_A= $(LUA_A)
- 
- default: $(PLAT)
-@@ -51,6 +52,10 @@
- 	$(AR) $@ $?
- 	$(RANLIB) $@
- 
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+	$(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? -lm $(MYLDFLAGS)
-+	ln -s $@.5.1 $@
-+
- $(LUA_T): $(LUA_O) $(LUA_A)
- 	$(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
- 
-diff -ur lua-5.1.orig/src/luaconf.h lua-5.1/src/luaconf.h
---- lua-5.1.orig/src/luaconf.h	2006-03-21 11:51:53.000000000 +0100
-+++ lua-5.1/src/luaconf.h	2006-03-21 11:52:05.000000000 +0100
-@@ -82,7 +82,7 @@
- 	".\\?.dll;"  LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
- 
- #else
--#define LUA_ROOT	"/usr/local/"
-+#define LUA_ROOT	"/usr/"
- #define LUA_LDIR	LUA_ROOT "share/lua/5.1/"
- #define LUA_CDIR	LUA_ROOT "lib/lua/5.1/"
- #define LUA_PATH_DEFAULT  \
-- 
cgit v0.12