From 45163f12cc62e53c723c28c9e4dd2eb45493d2ed Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 3 Apr 2009 17:45:34 -0500
Subject: nxtvepg: adding to community.

---
 abs/extra-testing/community/nxtvepg.tar.gz         | Bin 0 -> 2018 bytes
 abs/extra-testing/community/nxtvepg/PKGBUILD       |  45 +++++++++++++++++++++
 .../community/nxtvepg/nxtvepg-icon-16.png          | Bin 0 -> 193 bytes
 .../community/nxtvepg/nxtvepg-icon-32.png          | Bin 0 -> 267 bytes
 .../community/nxtvepg/nxtvepg-icon-48.png          | Bin 0 -> 333 bytes
 .../community/nxtvepg/nxtvepg.desktop              |  10 +++++
 abs/extra-testing/community/nxtvepg/tcl_85.patch   |  13 ++++++
 7 files changed, 68 insertions(+)
 create mode 100644 abs/extra-testing/community/nxtvepg.tar.gz
 create mode 100644 abs/extra-testing/community/nxtvepg/PKGBUILD
 create mode 100644 abs/extra-testing/community/nxtvepg/nxtvepg-icon-16.png
 create mode 100644 abs/extra-testing/community/nxtvepg/nxtvepg-icon-32.png
 create mode 100644 abs/extra-testing/community/nxtvepg/nxtvepg-icon-48.png
 create mode 100644 abs/extra-testing/community/nxtvepg/nxtvepg.desktop
 create mode 100644 abs/extra-testing/community/nxtvepg/tcl_85.patch

diff --git a/abs/extra-testing/community/nxtvepg.tar.gz b/abs/extra-testing/community/nxtvepg.tar.gz
new file mode 100644
index 0000000..fe8da09
Binary files /dev/null and b/abs/extra-testing/community/nxtvepg.tar.gz differ
diff --git a/abs/extra-testing/community/nxtvepg/PKGBUILD b/abs/extra-testing/community/nxtvepg/PKGBUILD
new file mode 100644
index 0000000..5de6bc7
--- /dev/null
+++ b/abs/extra-testing/community/nxtvepg/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Perry3D <perry3d at gmail dot com>
+# Previous: Gilles CHAUVIN <gcnweb at gmail dot com>
+
+pkgname=nxtvepg
+pkgver=2.8.1
+pkgrel=2
+pkgdesc="A decoder for nexTView EPG an Electronic TV Programme Guide"
+url="http://nxtvepg.sf.net/"
+license="GPL"
+depends=('tcl>=8.5.0' 'tk' 'libxmu')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz \
+tcl_85.patch \
+$pkgname-icon-16.png $pkgname-icon-32.png $pkgname-icon-48.png \
+$pkgname.desktop)
+arch=('i686' 'x86_64')
+
+build() {
+	cd $startdir/src/$pkgname-$pkgver
+
+	msg "Applying patch for tcl/tk8.5..."
+	patch -p0 < ../tcl_85.patch
+
+	make || return 1
+
+	make prefix=$startdir/pkg/usr/ \
+	bindir=$startdir/pkg/usr/bin \
+	resdir=$startdir/pkg/usr/share/X11 \
+	INST_DB_DIR=$startdir/pkg/var/tmp/nxtvdb \
+	cfgdir=$startdir/pkg/usr/share/nxtvepg \
+	install
+
+	# Icons
+	for size in 16 32 48; do
+		install $startdir/src/$pkgname-icon-$size.png -D -m644 $startdir/pkg/usr/share/pixmaps/$pkgname-icon-$size.png
+	done
+
+	# .desktop file
+	install $startdir/src/$pkgname.desktop -D -m644 $startdir/pkg/usr/share/applications/$pkgname.desktop
+}
+md5sums=('0811b1b95537b3cbab9f8d18d1501411'
+         'db5e77089204aeb35e84c7f5505664a6'
+         '5f7c220d3355b6f043a2bdd5acec8608'
+         '8988d3f33a90bd99f9a61d8f7e4f46c3'
+         '26d86bd935df1dc9328f07b879f30de2'
+         '5d14ff096ef811ccb7dc330e5d3a76fd')
diff --git a/abs/extra-testing/community/nxtvepg/nxtvepg-icon-16.png b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-16.png
new file mode 100644
index 0000000..e6d8a85
Binary files /dev/null and b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-16.png differ
diff --git a/abs/extra-testing/community/nxtvepg/nxtvepg-icon-32.png b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-32.png
new file mode 100644
index 0000000..9071f10
Binary files /dev/null and b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-32.png differ
diff --git a/abs/extra-testing/community/nxtvepg/nxtvepg-icon-48.png b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-48.png
new file mode 100644
index 0000000..a5f991b
Binary files /dev/null and b/abs/extra-testing/community/nxtvepg/nxtvepg-icon-48.png differ
diff --git a/abs/extra-testing/community/nxtvepg/nxtvepg.desktop b/abs/extra-testing/community/nxtvepg/nxtvepg.desktop
new file mode 100644
index 0000000..6703dfc
--- /dev/null
+++ b/abs/extra-testing/community/nxtvepg/nxtvepg.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Comment=Electronic TV Programme Guide
+Icon=/usr/share/pixmaps/nxtvepg-icon-48.png
+Exec=nxtvepg
+Name=nexTView EPG
+GenericName=electronic TV Programme Guide
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;
diff --git a/abs/extra-testing/community/nxtvepg/tcl_85.patch b/abs/extra-testing/community/nxtvepg/tcl_85.patch
new file mode 100644
index 0000000..9059a6c
--- /dev/null
+++ b/abs/extra-testing/community/nxtvepg/tcl_85.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig	2008-02-03 20:01:14.000000000 +0100
++++ Makefile	2008-02-03 20:01:23.000000000 +0100
+@@ -58,8 +58,8 @@
+ YACC    = /usr/bin/yacc
+ 
+ # select Tcl/Tk version (8.5 recommended due to modernized widget appearence)
+-TCL_VER := $(shell echo 'puts [package require Tcl]' | tclsh)
+-#TCL_VER = 8.5
++#TCL_VER := $(shell echo 'puts [package require Tcl]' | tclsh)
++TCL_VER = 8.5
+ 
+ ifeq ($(shell test -d /usr/include/tcl$(TCL_VER) && echo YES),YES)
+ INCS   += -I/usr/include/tcl$(TCL_VER)
-- 
cgit v0.12