From 3d0a10290106d0da8902bd4b7b622eb7c66adf2e Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 11 Jan 2013 16:42:42 -0600
Subject: enlightenment:  modify startup patch to also clear the delay when
 MythVantage window is displayed This was needed for making E the WM of choice
 for installs.

refs #895
---
 abs/core/enlightenment/PKGBUILD      | 4 ++--
 abs/core/enlightenment/startup.patch | 7 +++++--
 2 files changed, 7 insertions(+), 4 deletions(-)

diff --git a/abs/core/enlightenment/PKGBUILD b/abs/core/enlightenment/PKGBUILD
index ea2bd1c..4f04151 100644
--- a/abs/core/enlightenment/PKGBUILD
+++ b/abs/core/enlightenment/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=enlightenment
 pkgver=1.0.10
 _themever=1.0.1
-pkgrel=7
+pkgrel=8
 pkgdesc="A fast, flexible, and very extensible Window Manager"
 arch=('i686' 'x86_64')
 url="http://www.enlightenment.org"
@@ -36,4 +36,4 @@ package() {
 #  chown -R root:root "${pkgdir}"/usr/share/*
 }
 md5sums=('87441a2e7c4639e5d23198ed7bc834ea'
-         '3aac55d552d0e77764fd8398796d4096')
+         'ed24a9be5437ca5c53e723cc1a584abd')
diff --git a/abs/core/enlightenment/startup.patch b/abs/core/enlightenment/startup.patch
index 68641fc..369b39c 100644
--- a/abs/core/enlightenment/startup.patch
+++ b/abs/core/enlightenment/startup.patch
@@ -1,6 +1,6 @@
 --- src/startup.c.orig	2013-01-11 02:14:16.690976774 +0000
-+++ src/startup.c	2013-01-11 02:18:38.781047513 +0000
-@@ -173,5 +173,59 @@
++++ src/startup.c	2013-01-11 21:00:59.344248500 +0000
+@@ -173,5 +173,62 @@
  
     Mode.place.enable_features--;
     ESync(ESYNC_STARTUP);
@@ -42,6 +42,9 @@
 +        ret = system("xwininfo -name \"MythTV Setup\" 2>/dev/null >/dev/null " );
 +        if ( ret == 0 )
 +            break;
++        ret = system("xwininfo -name \"MythVantage\" 2>/dev/null >/dev/null " );
++        if ( ret == 0 )
++            break;
 +     }
 +     if ( ret != 0 )
 +      printf("ENLIGHTENMENT: Couldn't find mythfrontend/mythwelcome, starting anyhow \n");
-- 
cgit v0.12