From d55995f590d34a5db2a9671750b6bfbc79544652 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 5 Aug 2011 23:59:46 -0500
Subject: sdl_image: Bump to latest.

---
 abs/extra/sdl_image/PKGBUILD                       | 27 +++++++++------------
 abs/extra/sdl_image/SDL_image-IMG_lbm.patch        | 28 ----------------------
 .../sdl_image/SDL_image-buffer-overflow.patch      | 13 ----------
 3 files changed, 11 insertions(+), 57 deletions(-)
 delete mode 100644 abs/extra/sdl_image/SDL_image-IMG_lbm.patch
 delete mode 100644 abs/extra/sdl_image/SDL_image-buffer-overflow.patch

diff --git a/abs/extra/sdl_image/PKGBUILD b/abs/extra/sdl_image/PKGBUILD
index f3ab8cb..062490b 100644
--- a/abs/extra/sdl_image/PKGBUILD
+++ b/abs/extra/sdl_image/PKGBUILD
@@ -1,27 +1,22 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id$
+# Maintainer: Allan McRae <allan@archlinux.org>
 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
 pkgname=sdl_image
-pkgver=1.2.6
-pkgrel=3
+pkgver=1.2.10
+pkgrel=2
 pkgdesc="A simple library to load images of various formats as SDL surfaces"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
 license=('LGPL')
-depends=('sdl>=1.2.13' 'libpng' 'libjpeg' 'libtiff' 'zlib')
+depends=('sdl>=1.2.13' 'libpng' 'libjpeg>=7' 'libtiff' 'zlib')
 options=('!libtool')
 url="http://www.libsdl.org/projects/SDL_image/"
-source=(http://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz
-	SDL_image-IMG_lbm.patch
-	SDL_image-buffer-overflow.patch)
-md5sums=('b866dc4f647517bdaf57f6ffdefd013e'
-         '81424f716513845f27e1b69459343327'
-         'e774a12d1a07b788233f6c15aca05780')
+source=(http://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz)
+md5sums=('6c06584b31559e2b59f2b982d0d1f628')
 
 build() {
-  cd ${startdir}/src/SDL_image-${pkgver}
-  patch -Np2 -i ${startdir}/src/SDL_image-IMG_lbm.patch || return 1
-  patch -Np2 -i ${startdir}/src/SDL_image-buffer-overflow.patch || return 1
+  cd ${srcdir}/SDL_image-${pkgver}
   ./configure --prefix=/usr
   make || return 1
-  make DESTDIR=${startdir}/pkg install
+  make DESTDIR=${pkgdir} install
 }
diff --git a/abs/extra/sdl_image/SDL_image-IMG_lbm.patch b/abs/extra/sdl_image/SDL_image-IMG_lbm.patch
deleted file mode 100644
index cc4a29b..0000000
--- a/abs/extra/sdl_image/SDL_image-IMG_lbm.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- trunk/SDL_image/IMG_lbm.c	2007/07/20 04:37:11	3341
-+++ trunk/SDL_image/IMG_lbm.c	2008/01/03 20:05:34	3521
-@@ -28,6 +28,7 @@
-    EHB and HAM (specific Amiga graphic chip modes) support added by Marc Le Douarain
-    (http://www.multimania.com/mavati) in December 2003.
-    Stencil and colorkey fixes by David Raulo (david.raulo AT free DOT fr) in February 2004.
-+   Buffer overflow fix in RLE decompression by David Raulo in January 2008.
- */
- 
- #include <stdio.h>
-@@ -328,7 +329,7 @@
- 						count ^= 0xFF;
- 						count += 2; /* now it */
- 
--						if ( !SDL_RWread( src, &color, 1, 1 ) )
-+						if ( ( count > remainingbytes ) || !SDL_RWread( src, &color, 1, 1 ) )
- 						{
- 						   error="error reading BODY chunk";
- 							goto done;
-@@ -339,7 +340,7 @@
- 					{
- 						++count;
- 
--						if ( !SDL_RWread( src, ptr, count, 1 ) )
-+						if ( ( count > remainingbytes ) || !SDL_RWread( src, ptr, count, 1 ) )
- 						{
- 						   error="error reading BODY chunk";
- 							goto done;
diff --git a/abs/extra/sdl_image/SDL_image-buffer-overflow.patch b/abs/extra/sdl_image/SDL_image-buffer-overflow.patch
deleted file mode 100644
index 0be82dc..0000000
--- a/abs/extra/sdl_image/SDL_image-buffer-overflow.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- trunk/SDL_image/IMG_gif.c	2007/12/28 08:17:23	3461
-+++ trunk/SDL_image/IMG_gif.c	2007/12/28 16:43:56	3462
-@@ -418,6 +418,10 @@
-     static int stack[(1 << (MAX_LWZ_BITS)) * 2], *sp;
-     register int i;
- 
-+    /* Fixed buffer overflow found by Michael Skladnikiewicz */
-+    if (input_code_size > MAX_LWZ_BITS)
-+        return -1;
-+
-     if (flag) {
- 	set_code_size = input_code_size;
- 	code_size = set_code_size + 1;
-- 
cgit v0.12