From ee01e37d0775a4720f2a6d0e093507bef1c3f266 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 7 Apr 2012 20:50:13 -0500
Subject: bluez: update to 4.99

needed to fix compile error with xbmc 11
---
 abs/extra/bluez/PKGBUILD         | 68 +++++++++++++++++++++++-----------------
 abs/extra/bluez/__changelog      |  5 +++
 abs/extra/bluez/bluetooth.conf.d |  5 +--
 3 files changed, 45 insertions(+), 33 deletions(-)

diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index 4090fdc..c1f675a 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -1,20 +1,23 @@
-# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
+# $Id$
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
+
 pkgname=bluez
-pkgver=4.98
+pkgver=4.99
 pkgrel=2
 pkgdesc="Libraries and tools for the Bluetooth protocol stack"
 url="http://www.bluez.org/"
 arch=('i686' 'x86_64')
 license=('GPL2')
-depends=('dbus-core')
-makedepends=('gstreamer0.10-base' 'libusb-compat' 'libnl' 'libsndfile')
+depends=('dbus-core' 'python2' 'udev')
+makedepends=('gstreamer0.10-base' 'libusb-compat' 'libsndfile')
 optdepends=("gstreamer0.10-base: bluetooth GStreamer support"
-	"alsa-lib: Audio bluetooth devices support"
-	"dbus-python: to run bluez-simple-agent"
-	"pygobject: to run bluez-simple-agent"
-	"libusb-compat: USB adapters support"
-	"cups: CUPS backend"
-	"libnl: netlink plugin")
+            "alsa-lib: Audio bluetooth devices support"
+            "dbus-python: to run bluez-simple-agent"
+            "pygobject: to run bluez-simple-agent"
+            "libusb-compat: USB adapters support"
+            "cups: CUPS backend")
 conflicts=('bluez-libs' 'bluez-utils')
 provides=('bluez-libs' 'bluez-utils')
 replaces=('bluez-libs' 'bluez-utils')
@@ -22,15 +25,11 @@ options=('!libtool')
 backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
         'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
 install='bluez.install'
-source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
-        'bluez-4.98_audio-streaming.patch'
+source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
         'bluetooth.conf.d')
 
 build() {
-  cd "$srcdir/$pkgname-$pkgver"
-
-  # Add directive that allows audio streaming
-  patch -Np1 -i ${srcdir}/bluez-4.98_audio-streaming.patch || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
 
   ./configure --prefix=/usr \
     --sysconfdir=/etc \
@@ -42,32 +41,43 @@ build() {
     --enable-tools \
     --enable-bccmd \
     --enable-dfutool \
+    --enable-hid2hci \
     --enable-hidd \
     --enable-pand \
     --enable-dund \
-    --disable-cups || return 1
-
-  make || return 1
+    --disable-cups \
+    --enable-wiimote \
+    --disable-test
+  make
 }
 
 package() {
-  cd "$srcdir/$pkgname-$pkgver"
-  make DESTDIR="$pkgdir" install || return 1
+  cd ${srcdir}/${pkgname}-${pkgver}
+  make DESTDIR=${pkgdir} install
 
+#  install -Dm755 ${srcdir}/rc.bluetooth ${pkgdir}/etc/rc.d/bluetooth
+  
   install -d ${pkgdir}/etc/bluetooth
   install -m644 network/network.conf \
                 input/input.conf \
                 audio/audio.conf \
                 serial/serial.conf \
     ${pkgdir}/etc/bluetooth/
-
-  install -D -m644 "$srcdir/bluetooth.conf.d" \
-                   "$pkgdir/etc/conf.d/bluetooth" || return 1
   
-  install -Dm755 test/simple-agent ${pkgdir}/usr/bin/bluez-simple-agent
+  install -Dm644 ${srcdir}/bluetooth.conf.d \
+    ${pkgdir}/etc/conf.d/bluetooth
+
+  # FS#27630
+  install -Dm755 test/simple-agent "${pkgdir}"/usr/bin/bluez-simple-agent
+  install -Dm755 test/test-device "${pkgdir}"/usr/bin/bluez-test-device
+  install -Dm755 test/test-input "${pkgdir}"/usr/bin/bluez-test-input
   sed -i 's#/usr/bin/python#/usr/bin/python2#' \
-         ${pkgdir}/usr/bin/bluez-simple-agent
+    "${pkgdir}"/usr/bin/bluez-simple-agent \
+    "${pkgdir}"/usr/bin/bluez-test-device \
+    "${pkgdir}"/usr/bin/bluez-test-input
+
+  # http://mailman.archlinux.org/pipermail/arch-general/2011-April/019787.html
+#  rm "${pkgdir}"/usr/lib/udev/rules.d/97-bluetooth.rules
 }
-md5sums=('4aca8a0929250212e9a75fb60dd75b05'
-         'da4ec22ee1a5c3e84d5d934440167526'
-         'd12be5b494525bb1ba6eac5c3983dd3e')
+md5sums=('2387053eb5a7b02f37df4871df022a02'
+         '7412982b440f29fa7f76a41a87fef985')
diff --git a/abs/extra/bluez/__changelog b/abs/extra/bluez/__changelog
index 124d0eb..1c3b324 100644
--- a/abs/extra/bluez/__changelog
+++ b/abs/extra/bluez/__changelog
@@ -9,3 +9,8 @@ own run scripts.  Of particular interest is rfcomm and hid2hci utilities.
 They are not daemons and I added "/sbin/sv <executable> down ." in their
 respective run files.  All based on this thread:
 http://article.gmane.org/gmane.comp.sysutils.supervision.general/1585/
+
+2012-04-07
+- remove rc.bluetooth as we use runit
+- disable-cups
+- comment out removal of udev line
diff --git a/abs/extra/bluez/bluetooth.conf.d b/abs/extra/bluez/bluetooth.conf.d
index 8f25ef4..1c1e025 100644
--- a/abs/extra/bluez/bluetooth.conf.d
+++ b/abs/extra/bluez/bluetooth.conf.d
@@ -5,9 +5,6 @@
 # Run the bluetoothd daemon (default: true)
 #DAEMON_ENABLE="false"
 
-# Run hid2hci (default: false)
-#HID2HCI_ENABLE="true"
-
 # Run the sdp daemon (default: false)
 # If this is disabled, hcid's internal sdp daemon will be used
 #SDPD_ENABLE="true"
@@ -28,6 +25,6 @@
 #RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
 
 # Options for hidd, dund and pand (default: none)
-#HIDD_OPTIONS=""
+HIDD_OPTIONS="--server"
 #DUND_OPTIONS=""
 #PAND_OPTIONS=""
-- 
cgit v0.12