From 56eb3736255e1d57d9083c353c6af73e6f97a69d Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 18 Nov 2010 01:56:26 +0000
Subject: python-numeric: update/bump

---
 abs/core/python-numeric/PKGBUILD | 36 ++++++++++++++++++++++++++----------
 1 file changed, 26 insertions(+), 10 deletions(-)

diff --git a/abs/core/python-numeric/PKGBUILD b/abs/core/python-numeric/PKGBUILD
index 67a8ab5..7c7f58c 100644
--- a/abs/core/python-numeric/PKGBUILD
+++ b/abs/core/python-numeric/PKGBUILD
@@ -1,19 +1,35 @@
-# $Id: PKGBUILD 16713 2008-10-22 02:37:43Z allan $
-# Maintainer: arjan <arjan@archlinux.org>
+# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Contributor: arjan <arjan@archlinux.org>
 # Contributor orelien <aurelien.foret@wanadoo.fr>
 
 pkgname=python-numeric
 pkgver=24.2
-pkgrel=3
-pkgdesc="Numerical Python adds a fast array facility to the Python language."
+pkgrel=5
+pkgdesc="Numerical Python adds a fast array facility to the Python language"
 arch=(i686 x86_64)
-depends=('python>=2.5')
-source=(http://downloads.sourceforge.net/sourceforge/numpy/Numeric-${pkgver}.tar.gz)
-replaces=('numeric')
 url="http://numeric.scipy.org/"
-md5sums=(2ae672656e06716a149acb048cca3093)
+license=('custom')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/numpy/Numeric-$pkgver.tar.gz)
+md5sums=('2ae672656e06716a149acb048cca3093')
 
 build() {
-  cd ${startdir}/src/Numeric-${pkgver}
-  python setup.py install --root=${startdir}/pkg
+
+  cd "$srcdir/Numeric-$pkgver"
+
+  # Python2 fix
+  sed \
+	-e "s_\(env python\).*_\12_" \
+	-e "s_\(bin/python\).*_\12_" \
+	-i `grep -rlE "(env python|bin/python)" .`
 }
+
+package() {
+
+  cd "$srcdir/Numeric-$pkgver"
+
+  # Install
+  python2 setup.py install --prefix=/usr --root="$pkgdir/"
+  install -D -m644 Legal.htm "$pkgdir/usr/share/licenses/$pkgname/Legal.htm"
+}
+
-- 
cgit v0.12