From 3b20f86a8dd042de6271c30ad8a2a2fed773b9c9 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 30 Dec 2011 17:25:42 -0600
Subject: certmaster: acl_fix_fstab.  Only add "acl" to ext3 and ext4.  
 JFS,XFS,resierfs  support acl  but do not need the mount option

---
 abs/core/certmaster/PKGBUILD         |  4 ++--
 abs/core/certmaster/acl_fix_fstab.py | 27 ++++++++++++++++++++++++++-
 2 files changed, 28 insertions(+), 3 deletions(-)

diff --git a/abs/core/certmaster/PKGBUILD b/abs/core/certmaster/PKGBUILD
index 3ce72f7..367ca78 100644
--- a/abs/core/certmaster/PKGBUILD
+++ b/abs/core/certmaster/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=certmaster
 pkgver=0.28
-pkgrel=1
+pkgrel=2
 pkgdesc="certmaster"
 url="https://fedorahosted.org/certmaster/ "
 license="gpl"
@@ -31,5 +31,5 @@ build() {
 md5sums=('f5acc9ff1efa34971296e26d794c5b35'
          '953ff601e5381b457383e7a3c4928192'
          'be7bd532ae103ab3c0048980314b4fd9'
-         '214e34c095f6f29277197a2a6666f8b2'
+         'cc9cdabcdfc969c2829b58c0e513488c'
          '6bc28ccd331a6c4c05e0a9c9755a848f')
diff --git a/abs/core/certmaster/acl_fix_fstab.py b/abs/core/certmaster/acl_fix_fstab.py
index 8e49a15..187cab1 100644
--- a/abs/core/certmaster/acl_fix_fstab.py
+++ b/abs/core/certmaster/acl_fix_fstab.py
@@ -1,12 +1,37 @@
 #!/usr/bin/python2
 import os
 import sys
+import subprocess as sub
+
+def should_add_acl(mount_point,fs_map):
+    acl_fs_list=["ext3","ext4"]
+    rc = False
+    for i in fs_map:
+        if i[0] == mount_point:
+            if i[1] in acl_fs_list:
+                rc = True
+
+    return rc
+
+
 cmd="cp -f /etc/fstab /etc/fstab.backup.pre_acl"
 os.system(cmd)
 f = open('/etc/fstab', 'r')
 fstab=f.readlines()
 f.close()
 
+p = sub.Popen(['/sbin/fsck','-N' ],stdout=sub.PIPE,stderr=sub.PIPE)
+output, errors = p.communicate()
+output = output.split("\n")
+fs_map=[]
+for i in output:
+    if i.startswith("["):
+	split_line=i.split()
+	#find mount_p and remove the last char
+	mount_p = split_line[3][:-1]
+	fstype = split_line[4].split(".")[1]
+	append_tuple=(mount_p,fstype)
+	fs_map.append(append_tuple)
 
 
 
@@ -16,7 +41,7 @@ for line in fstab:
     new_line=line
     split_line=line.split()
     try:
-        if split_line[1] in mp:
+        if split_line[1] in mp and should_add_acl(split_line[1],fs_map):
             #print split_line[3]
             if "acl" in split_line[3]:
                 pass
-- 
cgit v0.12