From 2c281b369b0fb3a42e0b79689742321528b41587 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 16 Jul 2017 01:58:41 +0000
Subject: python-feedparser: initial inclusion. dep of flexget

---
 abs/core/python_modules/python-feedparser/PKGBUILD | 58 ++++++++++++++++++++++
 .../python_modules/python-feedparser/__changelog   |  1 +
 2 files changed, 59 insertions(+)
 create mode 100644 abs/core/python_modules/python-feedparser/PKGBUILD
 create mode 100644 abs/core/python_modules/python-feedparser/__changelog

diff --git a/abs/core/python_modules/python-feedparser/PKGBUILD b/abs/core/python_modules/python-feedparser/PKGBUILD
new file mode 100644
index 0000000..6e21842
--- /dev/null
+++ b/abs/core/python_modules/python-feedparser/PKGBUILD
@@ -0,0 +1,58 @@
+# $Id$
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgbase=python-feedparser
+#pkgname=('python2-feedparser' 'python-feedparser' 'python-sgmllib')
+pkgname=('python2-feedparser')
+pkgver=5.2.1
+pkgrel=2
+pkgdesc="Parse RSS and Atom feeds in Python"
+arch=('any')
+url="https://github.com/kurtmckee/feedparser/"
+license=('custom')
+makedepends=('python2' 'libxml2' 'python2-setuptools')
+source=(feedparser-${pkgver}.tar.gz::https://github.com/kurtmckee/feedparser/archive/${pkgver}.tar.gz)
+sha1sums=('13c9a17f821e46ba9a34d8777e0ae47a6eb86de4')
+
+prepare() {
+  cp -r feedparser-${pkgver} feedparser-${pkgver}-python2
+  cp -r feedparser-${pkgver} feedparser-${pkgver}-python
+  cp -r feedparser-${pkgver} feedparser-${pkgver}-sgmllib
+
+  (cd feedparser-${pkgver}-python2; sed -i 's#env python$#env python2#' feedparser/feedparsertest.py)
+#  (cd feedparser-${pkgver}-python; 2to3 -w feedparser/feedparser.py feedparser/feedparsertest.py)
+}
+
+#build() {
+#  cd feedparser-${pkgver}-sgmllib
+#  python /usr/lib/python3.6/compileall.py feedparser/sgmllib3.py
+#}
+
+package_python2-feedparser() {
+  depends=('python2' 'libxml2' )
+  pkgdesc="Parse RSS and Atom feeds in Python2"
+
+  cd "${srcdir}/feedparser-${pkgver}-python2"
+  python2 setup.py install --root="${pkgdir}"
+  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/license"
+}
+
+package_python-feedparser() {
+  depends=('libxml2' 'python-sgmllib')
+
+  cd "${srcdir}/feedparser-${pkgver}-python"
+  python setup.py install --root="${pkgdir}"
+  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/license"
+}
+
+package_python-sgmllib() {
+  depends=('python')
+  pkgdesc="Port of sgmllib to Python3"
+  license=('PSF')
+
+  cd "${srcdir}/feedparser-${pkgver}-sgmllib"
+  install -Dm644 feedparser/sgmllib3.py \
+    "${pkgdir}/usr/lib/python3.6/site-packages/sgmllib.py"
+  install -Dm644 feedparser/__pycache__/sgmllib3.cpython-36.pyc \
+    "${pkgdir}/usr/lib/python3.6/site-packages/__pycache__/sgmllib.cpython-36.pyc"
+}
diff --git a/abs/core/python_modules/python-feedparser/__changelog b/abs/core/python_modules/python-feedparser/__changelog
new file mode 100644
index 0000000..c6e1e55
--- /dev/null
+++ b/abs/core/python_modules/python-feedparser/__changelog
@@ -0,0 +1 @@
+PKGBUILD: don't build py 3 stuff
-- 
cgit v0.12