From 04c0d379b9941e3aeb16707ff86f9c162d3efc7a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 7 Aug 2015 14:13:22 +0000
Subject: ffmpeg: update to 2.7.2

---
 .../0001-libx265-Support-API-version-9.patch       | 50 ----------------------
 abs/core/ffmpeg/PKGBUILD                           | 35 +++++++++------
 2 files changed, 21 insertions(+), 64 deletions(-)
 delete mode 100644 abs/core/ffmpeg/0001-libx265-Support-API-version-9.patch

diff --git a/abs/core/ffmpeg/0001-libx265-Support-API-version-9.patch b/abs/core/ffmpeg/0001-libx265-Support-API-version-9.patch
deleted file mode 100644
index 3b6a6e2..0000000
--- a/abs/core/ffmpeg/0001-libx265-Support-API-version-9.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From d67dbfa7c195fabce706ca03c439419450f9bd8a Mon Sep 17 00:00:00 2001
-From: Derek Buitenhuis <derek.buitenhuis@gmail.com>
-Date: Thu, 6 Mar 2014 20:01:17 +0000
-Subject: [PATCH] libx265: Support API version 9
-
-Signed-off-by: Derek Buitenhuis <derek.buitenhuis@gmail.com>
----
- configure            |    4 ++--
- libavcodec/libx265.c |   10 +++++-----
- 2 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/configure b/configure
-index d3f5f33..4d7382a 100755
---- a/configure
-+++ b/configure
-@@ -3980,8 +3980,8 @@ enabled libx264           && require libx264 x264.h x264_encoder_encode -lx264 &
-                              { check_cpp_condition x264.h "X264_BUILD >= 118" ||
-                                die "ERROR: libx264 version must be >= 0.118."; }
- enabled libx265           && require_pkg_config x265 x265.h x265_encoder_encode &&
--                             { check_cpp_condition x265.h "X265_BUILD >= 7" ||
--                               die "ERROR: libx265 version must be >= 7."; }
-+                             { check_cpp_condition x265.h "X265_BUILD >= 9" ||
-+                               die "ERROR: libx265 version must be >= 9."; }
- enabled libxavs           && require libxavs xavs.h xavs_encoder_encode -lxavs
- enabled libxvid           && require libxvid xvid.h xvid_global -lxvidcore
- enabled openssl           && { check_lib openssl/ssl.h SSL_library_init -lssl -lcrypto ||
-diff --git a/libavcodec/libx265.c b/libavcodec/libx265.c
-index 961fc74..a6e4193 100644
---- a/libavcodec/libx265.c
-+++ b/libavcodec/libx265.c
-@@ -121,11 +121,11 @@ static av_cold int libx265_encode_init(AVCodecContext *avctx)
-     av_reduce(&sar_num, &sar_den,
-               avctx->sample_aspect_ratio.num,
-               avctx->sample_aspect_ratio.den, 4096);
--    ctx->params->bEnableVuiParametersPresentFlag = 1;
--    ctx->params->bEnableAspectRatioIdc           = 1;
--    ctx->params->aspectRatioIdc                  = 255;
--    ctx->params->sarWidth                        = sar_num;
--    ctx->params->sarHeight                       = sar_den;
-+    ctx->params->vui.bEnableVuiParametersPresentFlag = 1;
-+    ctx->params->vui.bEnableAspectRatioIdc           = 1;
-+    ctx->params->vui.aspectRatioIdc                  = 255;
-+    ctx->params->vui.sarWidth                        = sar_num;
-+    ctx->params->vui.sarHeight                       = sar_den;
- 
-     if (x265_max_bit_depth == 8)
-         ctx->params->internalBitDepth = 8;
--- 
-1.7.10.4
-
diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 115ddfb..38458a6 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -1,26 +1,34 @@
 # $Id$
 # Maintainer:  Ionut Biru <ibiru@archlinux.org>
 # Maintainer:  Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer:  Maxime Gauduin <alucryd@archlinux.org>
 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
 # Contributor: Paul Mattal <paul@archlinux.org>
 
 pkgname=ffmpeg
-pkgver=2.4.3
-pkgrel=1
+pkgver=2.7.2
+pkgrel=2
 epoch=1
-pkgdesc='Complete and free Internet live audio and video broadcasting solution'
+pkgdesc='Complete solution to record, convert and stream audio and video'
 arch=('i686' 'x86_64')
 url='http://ffmpeg.org/'
-license=('GPL')
+license=('GPL3')
 depends=(
-      'alsa-lib' 'bzip2' 'fontconfig' 'gnutls' 'gsm' 'lame' 'libass' 'libvdpau'
-      'libbluray' 'libmodplug' 'libtheora' 'libva' 'libvorbis' 'libvpx'
-      'opencore-amr' 'openjpeg' 'opus' 'rtmpdump' 'schroedinger' 'sdl' 'speex'
-      'v4l-utils' 'libx264' 'xvidcore' 'zlib' 'x265' 'fribidi'
+      'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
+      'libbluray' 'libmodplug' 'libsoxr' 'libssh' 'libtheora'
+      'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
+      'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+      'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
+)
+makedepends=('hardening-wrapper' 'libvdpau' 'yasm')
+provides=(
+      'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+      'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+      'libswscale.so'
 )
-makedepends=('libvdpau' 'yasm')
 source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
-md5sums=('8da635baff57d7ab704b1daca5a99b47'
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
+md5sums=('7eb2140bab9f0a8669b65b50c8e4cfb5'
          'SKIP')
 
 build() {
@@ -48,20 +56,19 @@ build() {
     --enable-libopenjpeg \
     --enable-libopus \
     --disable-libpulse \
-    --enable-librtmp \
     --enable-libschroedinger \
+    --enable-libsoxr \
     --enable-libspeex \
+    --enable-libssh \
     --enable-libtheora \
     --enable-libv4l2 \
     --enable-libvorbis \
     --enable-libvpx \
+    --enable-libwebp \
     --enable-libx264 \
     --enable-libx265 \
     --enable-libxvid \
-    --enable-runtime-cpudetect \
     --enable-shared \
-    --enable-swresample \
-    --enable-vdpau \
     --enable-version3 \
     --enable-x11grab \
 
-- 
cgit v0.12