From 786685fc0b81f22f2219906de049c60b06f9d306 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 26 Nov 2012 09:03:19 -0600
Subject: p7zip: 9.20.1

---
 abs/extra/p7zip/7zFM.desktop |  9 +++++
 abs/extra/p7zip/PKGBUILD     | 83 +++++++++++++++++++++++++-------------------
 abs/extra/p7zip/install      | 13 +++++++
 3 files changed, 69 insertions(+), 36 deletions(-)
 create mode 100644 abs/extra/p7zip/7zFM.desktop
 create mode 100644 abs/extra/p7zip/install

diff --git a/abs/extra/p7zip/7zFM.desktop b/abs/extra/p7zip/7zFM.desktop
new file mode 100644
index 0000000..62b8e85
--- /dev/null
+++ b/abs/extra/p7zip/7zFM.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=7-Zip FM
+GenericName=7-Zip File Manager
+Type=Application
+Categories=GTK;Utility;Archiving;Compression;
+Terminal=false
+Icon=p7zip
+Exec=7zFM
diff --git a/abs/extra/p7zip/PKGBUILD b/abs/extra/p7zip/PKGBUILD
index 1776568..4bb2bb4 100644
--- a/abs/extra/p7zip/PKGBUILD
+++ b/abs/extra/p7zip/PKGBUILD
@@ -1,51 +1,62 @@
-# $Id: PKGBUILD 85904 2010-07-22 04:49:57Z dgriffiths $
+# $Id: PKGBUILD 143961 2011-11-30 22:27:42Z andrea $
 # Contributor: Thayer Williams <thayer@archlinux.org>
 # Contributor: Hugo Doria <hugo@archlinux.org>
 # Contributor: TuxSpirit<tuxspirit@archlinux.fr>  2007/11/17 21:22:36 UTC
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
 
 pkgname=p7zip
-pkgver=9.13
-pkgrel=2
-pkgdesc="A command-line port of the 7zip compression utility"
+pkgver=9.20.1
+pkgrel=6
+pkgdesc='Command-line version of the 7zip compressed file archiver'
+url='http://p7zip.sourceforge.net/'
+license=('GPL' 'custom')
 arch=('i686' 'x86_64')
-license=('GPL')
-url="http://p7zip.sourceforge.net"
 depends=('gcc-libs' 'bash')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}_${pkgver}_src_all.tar.bz2)
-md5sums=('8ddb5053db3b1f2696407d01be145779')
-options=(!emptydirs)
+optdepends=('wxgtk: GUI'
+            'desktop-file-utils: desktop entries')
+makedepends=('yasm' 'nasm' 'wxgtk')
+options=('!makeflags')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}_${pkgver}_src_all.tar.bz2"
+        '7zFM.desktop')
+sha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
+          'f2c370d6f1b286b7ce9a2804e22541b755616a40')
 
-build() {
-	cd ${srcdir}/${pkgname}_${pkgver}
+install=install
 
-	#Arch64 fix
-	if [ "$CARCH" == "x86_64" ]; then
-		cp makefile.linux_amd64 makefile.machine
-	else
-		cp makefile.linux_x86_ppc_alpha_gcc_4.X makefile.machine
-	fi
+build() {
+	cd "${srcdir}/${pkgname}_${pkgver}"
 
-	sed -i "s|usr/local|usr|g" makefile
+	[[ $CARCH = x86_64 ]] \
+	&& cp makefile.linux_amd64_asm makefile.machine \
+	|| cp makefile.linux_x86_asm_gcc_4.X makefile.machine
 
-	make all3 OPTFLAGS="${CXXFLAGS}" || return 1
+	make all4 OPTFLAGS="${CXXFLAGS}"
 }
 
 package() {
-	cd ${srcdir}/${pkgname}_${pkgver}
-
-	make install DEST_HOME="${pkgdir}/usr" \
-		DEST_MAN="${pkgdir}/usr/share/man" \
-		DEST_SHARE_DOC="http://www.bugaco.com/7zip"
-
-	mkdir -p ${pkgdir}/usr/share/doc/p7zip/DOCS
-	install -m555 bin/7z.so ${pkgdir}/usr/lib/p7zip/
-
-	sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7z
-	sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7za
-	sed -i "s|${pkgdir}/usr|/usr|g" ${pkgdir}/usr/bin/7zr
-
-	# Install mc's virtual filesystem
-	install -Dm755 contrib/VirtualFileSystemForMidnightCommander/u7z \
-		${pkgdir}/usr/lib/mc/extfs.d/u7z
+	cd "${srcdir}/${pkgname}_${pkgver}"
+
+	make install \
+		DEST_DIR="${pkgdir}" \
+		DEST_HOME="/usr" \
+		DEST_MAN="/usr/share/man"
+
+	# Licenses
+	install -d "${pkgdir}"/usr/share/licenses/p7zip
+	ln -s -t "${pkgdir}"/usr/share/licenses/p7zip \
+		/usr/share/doc/p7zip/DOCS/License.txt \
+		/usr/share/doc/p7zip/DOCS/unRarLicense.txt
+
+	# Integration with stuff...
+	install -D GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
+	install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
+	cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
+	cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/
+	ln -s 7zCon.sfx "${pkgdir}"/usr/lib/p7zip/7z.sfx
+
+	find GUI/help -type d -exec chmod 755 {} \;
+	cp -r GUI/help "${pkgdir}"/usr/lib/p7zip/
+
+	chmod -R u+w "${pkgdir}/usr"
 }
diff --git a/abs/extra/p7zip/install b/abs/extra/p7zip/install
new file mode 100644
index 0000000..7f3cc43
--- /dev/null
+++ b/abs/extra/p7zip/install
@@ -0,0 +1,13 @@
+post_install() {
+	[[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
+	[[ -x usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor || true
+}
+
+post_upgrade() {
+	post_install
+}
+
+
+post_remove() {
+	post_install
+}
-- 
cgit v0.12