From 3f6347c181e6e839e4804845373a977676a0d113 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 13 Apr 2018 23:11:47 +0000
Subject: perl-text-charwidth: dep of po4a

---
 abs/core/perl_modules/perl-text-charwidth/PKGBUILD | 38 ++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 abs/core/perl_modules/perl-text-charwidth/PKGBUILD

diff --git a/abs/core/perl_modules/perl-text-charwidth/PKGBUILD b/abs/core/perl_modules/perl-text-charwidth/PKGBUILD
new file mode 100644
index 0000000..74baaf1
--- /dev/null
+++ b/abs/core/perl_modules/perl-text-charwidth/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-text-charwidth
+pkgver=0.04
+pkgrel=15
+pkgdesc="Perl/CPAN Module Text::CharWidth"
+arch=("x86_64")
+url="http://search.cpan.org/dist/Text-CharWidth"
+license=("GPL" "PerlArtistic")
+options=('!emptydirs')
+source=("https://www.cpan.org/authors/id/K/KU/KUBOTA/Text-CharWidth-${pkgver}.tar.gz")
+sha256sums=('abded5f4fdd9338e89fd2f1d8271c44989dae5bf50aece41b6179d8e230704f8')
+
+build() {
+  cd Text-CharWidth-${pkgver}
+
+  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+
+  make
+}
+
+package() {
+  cd Text-CharWidth-${pkgver}
+
+  make install DESTDIR="$pkgdir"
+
+  find "$pkgdir" -name '.packlist' -delete
+  find "$pkgdir" -name '*.pod' -delete
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+	_perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+	_perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+	depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
+}
-- 
cgit v0.12