From 6b44b0fc2469ec3d8d5b35d42a84653c64aa4945 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 17 Aug 2014 18:07:38 -0500
Subject: supplemental-web / xymon:  Add restart MBE to web interface.   Tweaks
 to css for call log

---
 abs/core/supplemental-web/PKGBUILD            |   2 +-
 abs/core/supplemental-web/contents/frame.css  | 117 +++++++++++++-------------
 abs/core/supplemental-web/contents/process.py |   9 +-
 abs/core/xymon/PKGBUILD                       |   4 +-
 abs/core/xymon/hbnotes.py                     |  32 ++++---
 5 files changed, 89 insertions(+), 75 deletions(-)
 mode change 100644 => 100755 abs/core/supplemental-web/contents/process.py

diff --git a/abs/core/supplemental-web/PKGBUILD b/abs/core/supplemental-web/PKGBUILD
index dd73d51..42bbf6a 100644
--- a/abs/core/supplemental-web/PKGBUILD
+++ b/abs/core/supplemental-web/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=supplemental-web
 pkgname=('supplemental-web' 'supplemental-web-slave')
 pkgver=8.0
-pkgrel=15
+pkgrel=17
 arch=('i686' 'x86_64')
 license=('GPL')
 backup=('data/srv/httpd/cgi/extra.cfg.txt')
diff --git a/abs/core/supplemental-web/contents/frame.css b/abs/core/supplemental-web/contents/frame.css
index 59da3c7..63a6121 100644
--- a/abs/core/supplemental-web/contents/frame.css
+++ b/abs/core/supplemental-web/contents/frame.css
@@ -1,12 +1,12 @@
 * /* Our "universal rule" */
 {
-	padding: 0px;
-	margin: 0px;
-	border: 0px;
+    padding: 0px;
+    margin: 0px;
+    border: 0px;
 }
 body {
 /*    background: url("page_background.jpg") repeat-y #9FA9B3; */
-     background-color: #191c26;
+    background-color: #191c26;
 
 //background-color: #ebb81c;
 //background-image: -webkit-gradient(linear, left top, left bottom, from(#ebb81c), to(#0072bc)); /* Saf4+, Chrome */
@@ -38,27 +38,27 @@ body {
 
 #mainContainer {
     clear: both;
-	width: 770px;
-	margin: 10px auto;
-	text-align: left; /* Since we used text-align: center in the body to be sure some older IE versions are going to center our design, we now align the text left */
-	display: block;
+    width: 770px;
+    margin: 10px auto;
+    text-align: left; /* Since we used text-align: center in the body to be sure some older IE versions are going to center our design, we now align the text left */
+    display: block;
 }
 #header {
-	color: #fff;
-	text-align: center;	
+    color: #fff;
+    text-align: center;
 }
 #content {
-	float: left; /* Our content is going to be left aligned */
-	width: 320px; /* And it's going to have a 320px width */
-	/*background: #D9D9D9;*/
-	margin-left:60px;
+    float: left; /* Our content is going to be left aligned */
+    width: 320px; /* And it's going to have a 320px width */
+    /*background: #D9D9D9;*/
+    margin-left:60px;
 }
 
 #column {
-	float: right; /* Our column is going to be right aligned */
-	width: 320px; /* And it's going to have a 320px width */
-	/*background: #8A8AE6;*/
-	margin-right:60px;
+    float: right; /* Our column is going to be right aligned */
+    width: 320px; /* And it's going to have a 320px width */
+    /*background: #8A8AE6;*/
+    margin-right:60px;
 }
 
 #resultbox {
@@ -79,8 +79,8 @@ body {
 #netContainer {
     clear: both;
     width: 770px;
-	margin: 10px auto;
-	display: block;
+    margin: 10px auto;
+    display: block;
 }
 
 img.center {
@@ -93,10 +93,10 @@ img.center {
 }
 
 #footer {
-	clear: both; /* We have to clear our floats */
-	width: 770px; /* We need to set the width on the footer since it's outside the mainContainer, and therefor isn't controlled by it */
-	margin: 0px auto; /* We need to center the footer also */
-	color: gold;
+    clear: both; /* We have to clear our floats */
+    width: 770px; /* We need to set the width on the footer since it's outside the mainContainer, and therefor isn't controlled by it */
+    margin: 0px auto; /* We need to center the footer also */
+    color: gold;
     text-align: center;
     font-size: 10px;
 }
@@ -115,9 +115,9 @@ img.center {
 }
 #navlist a:link
 {
-	color: #fff;
+    color: #fff;
 #	background-color: #FDB14F;
-	text-decoration: underline;
+    text-decoration: underline;
 
 
 }
@@ -125,45 +125,48 @@ img.center {
 #navlist a:visited
 {
 #	color: #FDB14F;
-	color: gold;
-	text-decoration: underline;
+    color: gold;
+    text-decoration: underline;
 }
 
 table.sample {
-	border-width: 4px;
-	border-spacing: 2px;
-	border-style: outset;
-	border-color: #808080;
-	border-collapse: separate;
-	width:300px;
+    border-width: 4px;
+    border-spacing: 2px;
+    border-style: outset;
+    border-color: #808080;
+    border-collapse: separate;
+    width:300px;
 }
 
 table.sample td {
-	border-width: 1px;
-	padding: 1px;
-	border-style: inset;
-	border-color: #808080;
-	/*width:300px;*/
-	-moz-border-radius: ;
+    border-width: 1px;
+    padding: 1px;
+    border-style: inset;
+    border-color: #808080;
+    /*width:300px;*/
+    -moz-border-radius: ;
 }
 
 
 table.calllog {
-	border-width: 4px;
-	border-spacing: 2px;
-	border-style: outset;
-	border-color: #808080;
-	border-collapse: separate;
-	width:500px;
+    border-width: 4px;
+    border-spacing: 2px;
+    border-style: outset;
+    border-color: #808080;
+    border-collapse: separate;
+    width:500px;
+    margin-left:auto;
+    margin-right:auto;
+    body {text-align:center;}
 }
 
 table.calllog td {
-	border-width: 1px;
-	padding: 1px;
-	border-style: inset;
-	border-color: #808080;
-	/*width:300px;*/
-	-moz-border-radius: ;
+    border-width: 1px;
+    padding: 1px;
+    border-style: inset;
+    border-color: #808080;
+    /*width:300px;*/
+    -moz-border-radius: ;
 }
 
 
@@ -202,9 +205,9 @@ table.calllog td {
 
 a:link
 {
-	color: #fff;
+    color: #fff;
 #	background-color: #FDB14F;
-	text-decoration: underline;
+    text-decoration: underline;
 
 #    	 margin-left:10px;
 
@@ -213,9 +216,9 @@ a:link
 a:visited
 {
 #	color: #FDB14F;
-	color: gold;
-	text-decoration: underline;
-    	 margin-left:10px;
+    color: gold;
+    text-decoration: underline;
+        margin-left:10px;
 }
 
 #submitbutton {
diff --git a/abs/core/supplemental-web/contents/process.py b/abs/core/supplemental-web/contents/process.py
old mode 100644
new mode 100755
index 988ebfc..7ad9af6
--- a/abs/core/supplemental-web/contents/process.py
+++ b/abs/core/supplemental-web/contents/process.py
@@ -257,7 +257,12 @@ def go_kill(myhost,kill_type):
     results=os.popen(command,'r')
     return  results
 
-
+def go_restart_mbe_local():
+    cmd = "/usr/LH/bin/lh_backend_control.sh restart &"
+    #results=os.popen(cmd,'r')
+    os.popen(cmd,'r')
+    results = ["Attempting restart of backend service"]
+    return  results
 
 
 
@@ -342,6 +347,8 @@ if __name__ == '__main__':
         mylogfile=go_kill(myhost,kill_type)
     elif selection == "Upload":
         mylogfile = go_upload(up_file)
+    elif selection == "RestartMBE":
+        mylogfile = go_restart_mbe_local()
 
 
     cgiprint(contentheader)   # content header
diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index 69507d4..3f25614 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.17
-pkgrel=1
+pkgrel=2
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license="GPL"
 arch=('i686' 'x86_64')
@@ -138,7 +138,7 @@ md5sums=('d8d119a777e7b7204d1292fb27314312'
          '758cdd9f1ba5ae3e1b42e811172806f3'
          'ee608dcafc050d790e28647a670f6b60'
          'b2f98ac0df013332deedc1efae0a270d'
-         '9610356bd8c1f0b6d9f4a7a33b385e16'
+         '07c8312b7eb0dd943f80f81a81d6de2c'
          '526c169e020b570b5b02661a831aa4e6'
          '166279c006c3ef7bf0c21537cf89fc83'
          '80d9cfac86c6d96836e6f406e35e7cf5'
diff --git a/abs/core/xymon/hbnotes.py b/abs/core/xymon/hbnotes.py
index 6967aa4..3171cb0 100644
--- a/abs/core/xymon/hbnotes.py
+++ b/abs/core/xymon/hbnotes.py
@@ -167,7 +167,7 @@ def create_dot_file():
 
     results=os.popen(cmd,'r')
     return frontonly,masterbackend,masterbacked_w_fe,slave_w_fe,slave,stand_alone
-    
+
 
 
 
@@ -205,7 +205,7 @@ def createdropdown(currenthostype):
     #This is for the d/l backup option
     dropdown+='''
 
-
+    </br>
     <input name="param2" type="radio"  value="Dbackup" />Download Backup: </>
     <select name="param7">\n\n </br>'''
 
@@ -216,18 +216,16 @@ def createdropdown(currenthostype):
     dropdown+='''
     </select>
 
-    <br>
+    </br>
+    </br>
     <input name="param2" type="radio" value="Optimize"  />Optimize Database<br />
     '''
+
     if currenthostype == "Master_backend":
-        dropdown+='<input name="param2" type="radio" value="ShutdownAll"  />Shutdown All Systems (except master backend)<br /> \n'
-    #dropdown+='''<input name="param2" type="radio"  value="UpdateAll" />Update All Systems </>           <select name="param5">
-                   #<option value="Myth_only">Myth only</option>
-                   #<option value="All"> Full System</option>
-           #</select>
-       #</br>
-       #</br>
-           #</br>'''
+        dropdown+='</br><input name="param2" type="radio" value="ShutdownAll"  />Shutdown All Systems (except master backend)<br /> \n'
+
+    #Add option to restart MBE
+    dropdown+='</br> <input name="param2" type="radio" value="RestartMBE"  />Restart MBE service<br /> \n'
 
     dropdown+='''    </br></br>\n'''
     return dropdown
@@ -403,24 +401,29 @@ function Do_it ()
 
 
        buttonform_bottom='''
+       </br>
         <input name="param2" type="radio"  value="Update" />Update System: </>
             <select name="param3">
                 <option value="Myth_only">Myth only</option>
                 <option value="All"> Full System</option>
             </select>
         </br>
-
+        </br>
         <input name="param2" type="radio"  value="Kill" />Restart Interface: </>
             <select name="param6">
                 <option value="killX">Full UI</option>
                 <option value="killmyth">MythFrontend</option>
             </select>
         </br>
-
+        </br>
         <input name="param2" type="radio"  value="Shutdown" />Shutdown System<br />
+        </br>
         <input name="param2" type="radio"  value="Reboot" />Reboot System<br />
+        </br>
         <input name="param2" type="radio"  value="WOL" />Wake on LAN<br />
+        </br>
         <input name="hiddenparam" type="hidden" value="
+        </br>
     '''
 
        oldurlform=''' "/>
@@ -441,6 +444,7 @@ function Do_it ()
 
        if currenthostype == "Master_backend" or currenthostype == "Standalone":
             mbeoptions=createdropdown(currenthostype)
+
        else:
             mbeoptions=''
        returnurl="/xymon/notes/"
@@ -525,7 +529,7 @@ def main(argv):
                            slave_w_fe,
                            slave,
                            stand_alone)
-    
+
 
 if __name__ == "__main__":
     main(sys.argv[1:])
-- 
cgit v0.12