From 1e6a244c143a67383c507fe217f3357b398d0aa4 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 16 Jul 2017 04:20:50 +0000
Subject: python-urllib3: initial inclusion. dep of flexget

---
 abs/core/python_modules/python-urllib3/PKGBUILD    | 72 ++++++++++++++++++++++
 abs/core/python_modules/python-urllib3/__changelog |  1 +
 2 files changed, 73 insertions(+)
 create mode 100644 abs/core/python_modules/python-urllib3/PKGBUILD
 create mode 100644 abs/core/python_modules/python-urllib3/__changelog

diff --git a/abs/core/python_modules/python-urllib3/PKGBUILD b/abs/core/python_modules/python-urllib3/PKGBUILD
new file mode 100644
index 0000000..3f881d2
--- /dev/null
+++ b/abs/core/python_modules/python-urllib3/PKGBUILD
@@ -0,0 +1,72 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Patrice Peterson <runiq at archlinux dot us>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: BorgHunter <borghunter at gmail dot com>
+
+pkgbase=python-urllib3
+pkgname=(python2-urllib3)
+pkgver=1.21.1
+pkgrel=1
+pkgdesc="HTTP library with thread-safe connection pooling and file post support"
+arch=("any")
+url="https://github.com/shazow/urllib3"
+license=("MIT")
+makedepends=('python2-setuptools'
+             'python2-ndg-httpsclient' 'python2-pyasn1'
+             'python2-pyopenssl' 'python2-pysocks' 'python2-mock')
+checkdepends=('python2-nose' 'python2-tornado'
+              'python2-coverage' 'python2-psutil')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/shazow/urllib3/archive/$pkgver.tar.gz")
+md5sums=('b0a2c692ea273dc120b209a027b0df3c')
+
+prepare() {
+  cp -a urllib3-$pkgver{,-py2}
+}
+
+build() {
+#  cd "$srcdir"/urllib3-$pkgver
+#  python setup.py build
+
+  cd "$srcdir"/urllib3-$pkgver-py2
+  python2 setup.py build
+
+  # Build with Python 2 since autodoc produces errors on Python 3
+#  cd "$srcdir"/urllib3-$pkgver/docs
+#  make SPHINXBUILD=sphinx-build2 html
+}
+
+check() {
+#  cd "$srcdir"/urllib3-$pkgver
+#  nosetests3 || warning "Tests failed"
+
+  cd "$srcdir"/urllib3-$pkgver-py2
+  nosetests2 || warning "Tests failed"
+}
+
+package_python-urllib3() {
+  depends=('python')
+  optdepends=('python-pysocks: SOCKS support')
+
+  cd urllib3-$pkgver
+  python setup.py install --root="$pkgdir"
+  install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+package_python2-urllib3() {
+  depends=('python2')
+  optdepends=('python2-pysocks: SOCKS support')
+
+  cd urllib3-$pkgver-py2
+  python2 setup.py install --root="$pkgdir"
+  install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+package_python-urllib3-doc() {
+  pkgdesc="urllib3 Documentation"
+
+  cd urllib3-$pkgver/docs
+  install -d "$pkgdir"/usr/share/doc
+  cp -r _build/html "$pkgdir"/usr/share/doc/python-urllib3
+  install -Dm644 ../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
diff --git a/abs/core/python_modules/python-urllib3/__changelog b/abs/core/python_modules/python-urllib3/__changelog
new file mode 100644
index 0000000..49a28c7
--- /dev/null
+++ b/abs/core/python_modules/python-urllib3/__changelog
@@ -0,0 +1 @@
+PKGBUILD: don't build py 3 stuff or sphinx
-- 
cgit v0.12