From c4a7f47bcb488c4a2d1fe5fa047f4b42d0f4ce4a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Apr 2014 21:50:39 +0000
Subject: python-cryptography: initial inclusion. dep of pyopenssl

---
 .../python_modules/python-cryptography/PKGBUILD    | 54 ++++++++++++++++++++++
 .../python_modules/python-cryptography/__changelog |  1 +
 2 files changed, 55 insertions(+)
 create mode 100644 abs/core/python_modules/python-cryptography/PKGBUILD
 create mode 100644 abs/core/python_modules/python-cryptography/__changelog

diff --git a/abs/core/python_modules/python-cryptography/PKGBUILD b/abs/core/python_modules/python-cryptography/PKGBUILD
new file mode 100644
index 0000000..f916ada
--- /dev/null
+++ b/abs/core/python_modules/python-cryptography/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+
+pkgbase=python-cryptography
+pkgname=('python2-cryptography')
+pkgver=0.3
+pkgrel=1
+pkgdesc="A package designed to expose cryptographic recipes and primitives to Python developers"
+arch=('i686' 'x86_64')
+license=('Apache')
+url="http://pypi.python.org/pypi/cryptography"
+makedepends=('python2-setuptools' 'python2-six' 'python2-cffi')
+checkdepends=('python2-pytest' 'python2-cryptography-vectors'
+              'python2-iso8601' 'python2-pretend')
+source=("http://pypi.python.org/packages/source/c/cryptography/cryptography-${pkgver}.tar.gz")
+md5sums=('1a9f2520acfef9489ac42fdc9a7be441')
+
+check() {
+   # Check python3 module
+#   cd "${srcdir}"/cryptography-${pkgver}
+#   python3 setup.py test
+
+   # Check python2 module
+   cd "${srcdir}"/cryptography-${pkgver}-python2
+   python2 setup.py test
+}
+ 
+prepare() {
+   cp -a cryptography-${pkgver}{,-python2}
+}
+
+build() {
+   # Build python 3 module
+   cd cryptography-${pkgver}
+#   python3 setup.py build
+ 
+   # Build python 2 module
+   cd ../cryptography-${pkgver}-python2
+   python2 setup.py build
+}
+ 
+#package_python-cryptography() {
+#   depends=('python' 'python-six' 'python-cffi')
+ 
+#   cd cryptography-${pkgver}
+#   python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+#}
+ 
+package_python2-cryptography() {
+   depends=('python2' 'python2-six' 'python2-cffi')
+ 
+   cd cryptography-${pkgver}-python2
+   python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
diff --git a/abs/core/python_modules/python-cryptography/__changelog b/abs/core/python_modules/python-cryptography/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-cryptography/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff
-- 
cgit v0.12