From 53f8e3e3aefff6a11d7bdb4262436978532317a4 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 19 Jul 2009 16:47:51 -0700
Subject: faad2:Updated for new FFMPEG.

---
 abs/core-testing/faad2/ChangeLog | 12 ++++++++++++
 abs/core-testing/faad2/LICENSE   | 28 ++++++++++++++++++++-------
 abs/core-testing/faad2/PKGBUILD  | 41 +++++++++++-----------------------------
 3 files changed, 44 insertions(+), 37 deletions(-)

diff --git a/abs/core-testing/faad2/ChangeLog b/abs/core-testing/faad2/ChangeLog
index b4073ba..ed5548b 100644
--- a/abs/core-testing/faad2/ChangeLog
+++ b/abs/core-testing/faad2/ChangeLog
@@ -1,3 +1,15 @@
+2009-02-16  Eric Belanger  <eric@archlinux.org>
+
+	* faad2 2.7-1
+	* Upstream update
+	* Updated LICENSE file
+	* Compiled with -fPIC option
+
+2009-01-05  Eric Belanger  <eric@archlinux.org>
+
+	* faad2 2.6.1-2
+	* Applied security patch
+
 2008-07-19  Eric Belanger  <eric@archlinux.org>
 
 	* faad2 2.6.1-1
diff --git a/abs/core-testing/faad2/LICENSE b/abs/core-testing/faad2/LICENSE
index ecb2c75..a16abf6 100644
--- a/abs/core-testing/faad2/LICENSE
+++ b/abs/core-testing/faad2/LICENSE
@@ -1,19 +1,24 @@
-/*
+__________
+COPYRIGHTS
+
+For FAAD2 the following license applies:
+
+******************************************************************************
 ** FAAD2 - Freeware Advanced Audio (AAC) Decoder including SBR decoding
 ** Copyright (C) 2003-2005 M. Bakker, Nero AG, http://www.nero.com
-**  
+**
 ** This program is free software; you can redistribute it and/or modify
 ** it under the terms of the GNU General Public License as published by
 ** the Free Software Foundation; either version 2 of the License, or
 ** (at your option) any later version.
-** 
+**
 ** This program is distributed in the hope that it will be useful,
 ** but WITHOUT ANY WARRANTY; without even the implied warranty of
 ** MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 ** GNU General Public License for more details.
-** 
+**
 ** You should have received a copy of the GNU General Public License
-** along with this program; if not, write to the Free Software 
+** along with this program; if not, write to the Free Software
 ** Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
 **
 ** Any non-GPL usage of this software or parts of this software is strictly
@@ -24,5 +29,14 @@
 **
 ** Commercial non-GPL licensing of this software is possible.
 ** For more info contact Nero AG through Mpeg4AAClicense@nero.com.
-**
-*/
+******************************************************************************
+
+
+Please note that the use of this software may require the payment of
+patent royalties. You need to consider this issue before you start
+building derivative works. We are not warranting or indemnifying you in
+any way for patent royalities! YOU ARE SOLELY RESPONSIBLE FOR YOUR OWN
+ACTIONS!
+
+
+______
diff --git a/abs/core-testing/faad2/PKGBUILD b/abs/core-testing/faad2/PKGBUILD
index 227cc3b..729d69b 100644
--- a/abs/core-testing/faad2/PKGBUILD
+++ b/abs/core-testing/faad2/PKGBUILD
@@ -1,45 +1,26 @@
-# $Id: PKGBUILD 5668 2008-07-20 05:06:05Z eric $
+# $Id: PKGBUILD 27494 2009-02-22 04:26:47Z eric $
 # Maintainer: Eric Belanger <eric@archlinux.org>
 # Contributor: Sarah Hay <sarah@archlinux.org>
 
 pkgname=faad2
-pkgver=2.6.1
+pkgver=2.7
 pkgrel=1
 pkgdesc="ISO AAC audio decoder"
 arch=('i686' 'x86_64')
 url="http://www.audiocoding.com/"
 license=('custom:GPL')
 depends=('glibc')
-options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/faac/${pkgname}-${pkgver}.tar.gz 
-        faad2-2.6.1-libtool22.patch
-        faad2-2.6.1-broken-pipe.patch
-        faad2-2.6.1-implicitdeclar.patch
-	faad2-2.6.1-abi_has_changed.patch
-	LICENSE)
-md5sums=('74e92df40c270f216a8305fc87603c8a' 'ca9515b6617d7fd060d0d172616eb192'\
-         'bb6a345dd2e6c4df6609e6a374134066' 'bc43fd3f8cd582a8bc092b9b5e611865'\
-         '06e83633c609d20436794b62a382b3dc' 'b6a1c72534807b8a038b71e784f57e32')
-sha1sums=('b4ad33d3c4dfa6dbf3011a3da34c631926cabfad'
-          'ca4ee04aa1757b8f9deeef52b5bf35dc823da844'
-          '0b03728f40d00e552f738900e2f6215177af5417'
-          'd4ab5d38c9b75ed6417529c4d1a7ca204293c224'
-          'f7e9d89fc551e0b61a7b7555749ed7a3129a4ce8'
-          '6225fd997671206f5222c4a86d9e092359552c43')
+options=('!libtool' '!makeflags')
+source=(http://downloads.sourceforge.net/sourceforge/faac/${pkgname}-${pkgver}.tar.bz2 LICENSE)
+md5sums=('4c332fa23febc0e4648064685a3d4332' 'ec95f38142e14fb46c849503897a37a0')
+sha1sums=('b0e80481d27ae9faf9e46c8c8dfb617a0adb91b5' '00edd9b30d8d5098b5e91c03c595d96a3bbe56fd')
 
 build() {
-  cd ${srcdir}/${pkgname}
-  patch -p1 < ../faad2-2.6.1-libtool22.patch || return 1
-  patch -p1 < ../faad2-2.6.1-broken-pipe.patch || return 1
-  patch -p1 < ../faad2-2.6.1-implicitdeclar.patch || return 1
-  patch -p1 < ../faad2-2.6.1-abi_has_changed.patch || return 1
-
-  autoreconf -vif || return 1
+  cd ${srcdir}/${pkgname}-${pkgver}
   ./configure --prefix=/usr || return 1
-  make || return 1
-  make DESTDIR=${pkgdir} install || return 1
-  install -m644 ${srcdir}/${pkgname}/common/mp4ff/mp4ff.h ${pkgdir}/usr/include/ || return 1
-  install -m644 ${srcdir}/${pkgname}/common/mp4ff/mp4ff_int_types.h ${pkgdir}/usr/include/ || return 1
-  install -m644 ${srcdir}/${pkgname}/common/mp4ff/.libs/*.a ${pkgdir}/usr/lib/ || return 1
+  make CFLAGS="${CFLAGS} -fPIC" || return 1
+  make DESTDIR=${pkgdir} manmdir=/usr/share/man/man1 install || return 1
+  install -m644 common/mp4ff/mp4ff_int_types.h ${pkgdir}/usr/include/mp4ff_int_types.h || return 1
   install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+  mv ${pkgdir}/usr/share/man/man1/faad.man ${pkgdir}/usr/share/man/man1/faad.1
 }
-- 
cgit v0.12


From a711f6e028feb3ce805390c14026f213b6b50bbb Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 19 Jul 2009 16:48:14 -0700
Subject: x264: Update for newer ffmpeg.

---
 abs/core-testing/x264/PKGBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/x264/PKGBUILD b/abs/core-testing/x264/PKGBUILD
index 8d85cb5..4f1756b 100644
--- a/abs/core-testing/x264/PKGBUILD
+++ b/abs/core-testing/x264/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 24030 2009-01-11 23:42:22Z eric $
+# $Id: PKGBUILD 36085 2009-04-19 22:58:09Z eric $
 # Contributor: damir <damir@archlinux.org>
 # Maintainer: Paul Mattal <paul@archlinux.org>
 
 pkgname=x264
-pkgver=20090108
+pkgver=20090416
 pkgrel=1
 pkgdesc="free library for encoding H264/AVC video streams"
 arch=(i686 x86_64)
@@ -12,7 +12,7 @@ license=('GPL')
 depends=('libx11')
 makedepends=('yasm')
 source=(ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-$pkgver-2245.tar.bz2)
-md5sums=('27129d3cc2e93899069f3caf6eb51f68')
+md5sums=('f5730feaa6175539e8227e48e38b7d67')
 
 build() {
     cd "$srcdir/$pkgname-snapshot-$pkgver-2245" || return 1
-- 
cgit v0.12


From f5681911497798ddd74e9ac46c04ca9923a7805b Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 19 Jul 2009 16:48:57 -0700
Subject: nuvexport:modification to work with newer FFMPEG.

---
 abs/core-testing/nuvexport/MP4.pm   | 316 ++++++++++++++++++++++++++++++++++++
 abs/core-testing/nuvexport/PKGBUILD |   5 +-
 2 files changed, 319 insertions(+), 2 deletions(-)
 create mode 100755 abs/core-testing/nuvexport/MP4.pm

diff --git a/abs/core-testing/nuvexport/MP4.pm b/abs/core-testing/nuvexport/MP4.pm
new file mode 100755
index 0000000..e13d44b
--- /dev/null
+++ b/abs/core-testing/nuvexport/MP4.pm
@@ -0,0 +1,316 @@
+#!/usr/bin/perl -w
+#
+# ffmpeg-based MP4 (iPod) video module for nuvexport.
+#
+# Many thanks to cartman in #ffmpeg, and for the instructions at
+# http://rob.opendot.cl/index.php?active=3&subactive=1
+# http://videotranscoding.wikispaces.com/EncodeForIPodorPSP
+#
+# @url       $URL: svn+ssh://xris@svn.mythtv.org/var/lib/svn/trunk/mythextras/nuvexport/export/ffmpeg/MP4.pm $
+# @date      $Date: 2008-02-16 20:54:43 -0800 (Sat, 16 Feb 2008) $
+# @version   $Revision: 16110 $
+# @author    $Author: xris $
+# @copyright Silicon Mechanics
+#
+
+package export::ffmpeg::MP4;
+    use base 'export::ffmpeg';
+
+# Load the myth and nuv utilities, and make sure we're connected to the database
+    use nuv_export::shared_utils;
+    use nuv_export::cli;
+    use nuv_export::ui;
+    use mythtv::recordings;
+
+# Load the following extra parameters from the commandline
+    add_arg('quantisation|q=i', 'Quantisation');
+    add_arg('a_bitrate|a=i',    'Audio bitrate');
+    add_arg('v_bitrate|v=i',    'Video bitrate');
+    add_arg('multipass!',       'Enable two-pass encoding.');
+    add_arg('mp4_codec=s',      'Video codec to use for MP4/iPod video (mpeg4 or h264).');
+    add_arg('mp4_fps=s',        'Framerate to use:  auto, 25, 23.97, 29.97.');
+    add_arg('ipod!',            'Produce ipod-compatible output.');
+
+    sub new {
+        my $class = shift;
+        my $self  = {
+                     'cli'      => qr/\b(?:mp4|ipod)\b/i,
+                     'name'     => 'Export to MP4 (iPod)',
+                     'enabled'  => 1,
+                     'errors'   => [],
+                     'defaults' => {},
+                    };
+        bless($self, $class);
+
+    # Initialize the default parameters
+        $self->load_defaults();
+
+    # Verify any commandline or config file options
+        die "Audio bitrate must be > 0\n" unless (!defined $self->val('a_bitrate') || $self->{'a_bitrate'} > 0);
+        die "Video bitrate must be > 0\n" unless (!defined $self->val('v_bitrate') || $self->{'v_bitrate'} > 0);
+        die "Width must be > 0\n"         unless (!defined $self->val('width')     || $self->{'width'} =~ /^\s*\D/  || $self->{'width'}  > 0);
+        die "Height must be > 0\n"        unless (!defined $self->val('height')    || $self->{'height'} =~ /^\s*\D/ || $self->{'height'} > 0);
+
+    # VBR, multipass, etc.
+        if ($self->val('multipass')) {
+            $self->{'vbr'} = 1;
+        }
+        elsif ($self->val('quantisation')) {
+            die "Quantisation must be a number between 1 and 31 (lower means better quality).\n" if ($self->{'quantisation'} < 1 || $self->{'quantisation'} > 31);
+            $self->{'vbr'} = 1;
+        }
+
+    # Initialize and check for ffmpeg
+        $self->init_ffmpeg();
+
+    # Can we even encode mp4?
+        if (!$self->can_encode('mp4')) {
+            push @{$self->{'errors'}}, "Your ffmpeg installation doesn't support encoding to mp4 file formats.";
+        }
+        if (!$self->can_encode('aac') && !$self->can_encode('libfaac')) {
+            push @{$self->{'errors'}}, "Your ffmpeg installation doesn't support encoding to aac audio.";
+        }
+        if (!$self->can_encode('mpeg4') && !$self->can_encode('h264') && !$self->can_encode('libx264')) {
+            push @{$self->{'errors'}}, "Your ffmpeg installation doesn't support encoding to either mpeg4 or h264 video.";
+        }
+    # Any errors?  disable this function
+        $self->{'enabled'} = 0 if ($self->{'errors'} && @{$self->{'errors'}} > 0);
+    # Return
+        return $self;
+    }
+
+# Load default settings
+    sub load_defaults {
+        my $self = shift;
+    # Load the parent module's settings
+        $self->SUPER::load_defaults();
+    # Default settings
+        $self->{'defaults'}{'v_bitrate'}  = 384;
+        $self->{'defaults'}{'a_bitrate'}  = 64;
+        $self->{'defaults'}{'width'}      = 320;
+        $self->{'defaults'}{'mp4_codec'}  = 'mpeg4';
+    # Verify commandline options
+        if ($self->val('mp4_codec') !~ /^(?:mpeg4|h264)$/i) {
+            die "mp4_codec must be either mpeg4 or h264.\n";
+        }
+        $self->{'mp4_codec'} =~ tr/A-Z/a-z/;
+
+    }
+
+# Gather settings from the user
+    sub gather_settings {
+        my $self = shift;
+    # Load the parent module's settings
+        $self->SUPER::gather_settings();
+    # Audio Bitrate
+        $self->{'a_bitrate'} = query_text('Audio bitrate?',
+                                          'int',
+                                          $self->val('a_bitrate'));
+    # Video options
+        if (!$is_cli) {
+        # iPod compatibility mode?
+            $self->{'ipod'} = query_text('Enable iPod compatibility?',
+                                         'yesno',
+                                         $self->val('ipod'));
+        # Video codec
+            if ($self->{'ffmpeg_vers'} eq 'svn') {
+                while (1) {
+                    my $codec = query_text('Video codec (mpeg4 or h264)?',
+                                           'string',
+                                           $self->{'mp4_codec'});
+                    if ($codec =~ /^m/) {
+                        $self->{'mp4_codec'} = 'mpeg4';
+                        last;
+                    }
+                    elsif ($codec =~ /^h/) {
+                        $self->{'mp4_codec'} = 'h264';
+                        last;
+                    }
+                    print "Please choose either mpeg4 or h264\n";
+                }
+            }
+            else {
+                $self->{'mp4_codec'} = 'mpeg4';
+                print "Using the mpeg4 codec (h.264 mp4/ipod encoding requires the svn version of ffmpeg.)\n";
+            }
+        # Video bitrate options
+            $self->{'vbr'} = query_text('Variable bitrate video?',
+                                        'yesno',
+                                        $self->val('vbr'));
+            if ($self->{'vbr'}) {
+                $self->{'multipass'} = query_text('Multi-pass (slower, but better quality)?',
+                                                  'yesno',
+                                                  $self->val('multipass'));
+                if (!$self->{'multipass'}) {
+                    while (1) {
+                        my $quantisation = query_text('VBR quality/quantisation (1-31)?',
+                                                      'float',
+                                                      $self->val('quantisation'));
+                        if ($quantisation < 1) {
+                            print "Too low; please choose a number between 1 and 31.\n";
+                        }
+                        elsif ($quantisation > 31) {
+                            print "Too high; please choose a number between 1 and 31\n";
+                        }
+                        else {
+                            $self->{'quantisation'} = $quantisation;
+                            last;
+                        }
+                    }
+                }
+            } else {
+                $self->{'multipass'} = 0;
+            }
+        # Ask the user what video bitrate he/she wants
+            $self->{'v_bitrate'} = query_text('Video bitrate?',
+                                              'int',
+                                              $self->val('v_bitrate'));
+        }
+    # Complain about h264
+        if ($self->{'mp4_codec'} eq 'h264' && $self->{'ffmpeg_vers'} ne 'svn') {
+            die "h.264 mp4/ipod encoding requires the svn version of ffmpeg.\n";
+        }
+    # Loop, in case we need to verify ipod compatibility
+        while (1) {
+        # Query the resolution
+            $self->query_resolution();
+        # Warn about ipod resolution
+            if ($self->val('ipod') && ($self->{'height'} > 480 || $self->{'width'} > 640)) {
+                my $note = "WARNING:  Video larger than 640x480 will not play on an iPod.\n";
+                die $note if ($is_cli);
+                print $note;
+                next;
+            }
+        # Done looping
+            last;
+        }
+    }
+
+    sub export {
+        my $self    = shift;
+        my $episode = shift;
+    # Make sure this is set to anamorphic mode
+        $self->{'aspect_stretched'} = 1;
+    # Framerate
+        my $standard = ($episode->{'finfo'}{'fps'} =~ /^2(?:5|4\.9)/) ? 'PAL' : 'NTSC';
+        if ($standard eq 'PAL') {
+            $self->{'out_fps'} = 25;
+        }
+        elsif ($self->val('mp4_fps') =~ /^23/) {
+            $self->{'out_fps'} = 23.97;
+        }
+        elsif ($self->val('mp4_fps') =~ /^29/) {
+            $self->{'out_fps'} = 29.97;
+        }
+        else {
+            $self->{'out_fps'} = ($self->{'width'} > 320 || $self->{'height'} > 288) ? 29.97 : 23.97;
+        }
+    # Embed the title
+        $safe_title = $episode->{'title'};
+        if ($episode->{'subtitle'} ne 'Untitled') {
+            $safe_title .= ' - '.$episode->{'subtitle'};
+        }
+        my $safe_title = shell_escape($safe_title);
+    # Codec name changes between ffmpeg versions
+        my $codec = $self->{'mp4_codec'};
+        if ($codec eq 'h264' && $self->can_encode('libx264')) {
+            $codec = 'libx264';
+        }
+    # Build the common ffmpeg string
+        my $ffmpeg_xtra  = ' -vcodec '.$codec
+                           .$self->param('bit_rate', $self->{'v_bitrate'})
+    ;###                      ." -title $safe_title";
+    # Options required for the codecs separately
+        if ($self->{'mp4_codec'} eq 'h264') {
+            $ffmpeg_xtra .= ' -level 30'
+	    ###                    .' -loop 1'
+                           .' -g 250 -keyint_min 25'
+                           .' -sc_threshold 40'
+			   ###             .' -rc_eq \'blurCplx^(1-qComp)\''
+                           .$self->param('bit_rate_tolerance', $self->{'v_bitrate'})
+                           .$self->param('rc_max_rate',        1500 - $self->{'a_bitrate'})
+                           .$self->param('rc_buffer_size',     2000)
+                           .$self->param('i_quant_factor',     0.71428572)
+                           .$self->param('b_quant_factor',     0.76923078)
+                           .$self->param('max_b_frames',       0)
+			   ### .' -me umh'   # this will eventually be me_method, but not all ffmpeg versions support it yet
+                           ;
+        }
+        else {
+           $ffmpeg_xtra .= ' -flags +mv4' ## +trell+loop'
+	   ###                      .' -aic 1'
+                          .' -mbd 1'
+                          .' -cmp 2 -subcmp 2'
+                          ;
+        }
+    # Some shared options
+        if ($self->{'multipass'} || $self->{'vbr'}) {
+            $ffmpeg_xtra .= $self->param('qcompress', 0.6)
+                           .$self->param('qmax',      51)
+                           .$self->param('max_qdiff', 4)
+                           ;
+        }
+    # Dual pass?
+        if ($self->{'multipass'}) {
+        # Apparently, the -passlogfile option doesn't work for h264, so we need
+        # to be aware of other processes that might be working in this directory
+            if ($self->{'mp4_codec'} eq 'h264' && (-e 'x264_2pass.log.temp' || -e 'x264_2pass.log')) {
+                die "ffmpeg does not allow us to specify the name of the multi-pass log\n"
+                   ."file, and x264_2pass.log exists in this directory already.  Please\n"
+                   ."wait for the other process to finish, or remove the stale file.\n";
+            }
+        # Add all possible temporary files to the list
+            push @tmpfiles, 'x264_2pass.log',
+                            'x264_2pass.log.temp',
+                            'ffmpeg2pass-0.log';
+        # Build the ffmpeg string
+            print "First pass...\n";
+            $self->{'ffmpeg_xtra'} = ' -pass 1'
+                                    .$ffmpeg_xtra
+                                    .' -f mp4';
+            if ($self->{'mp4_codec'} eq 'h264') {
+                $self->{'ffmpeg_xtra'} .= ' -refs 1 -subq 1'
+                                         .' -trellis 0'
+                                         ;
+            }
+            $self->SUPER::export($episode, '', 1);
+        # Second Pass
+            print "Final pass...\n";
+            $ffmpeg_xtra = ' -pass 2 '
+                          .$ffmpeg_xtra;
+        }
+    # Single Pass
+        else {
+            if ($self->{'vbr'}) {
+                $ffmpeg_xtra .= ' -qmin '.$self->{'quantisation'};
+            }
+        }
+    # Single/final pass options
+        if ($self->{'mp4_codec'} eq 'h264') {
+            $ffmpeg_xtra .= ' -refs '.($self->val('ipod') ? 2 : 7)
+                           .' -subq 7'
+                           .' -partitions parti4x4+parti8x8+partp4x4+partp8x8+partb8x8'
+                           .' -flags2 +bpyramid+wpred+mixed_refs+8x8dct' ##+brdo'
+                           .' -me_range 21'
+                           .' -trellis 2'
+                           .' -chromaoffset 1'
+			   ###         .' -slice 2'
+			   ###         .' -cmp 1'
+                           # These should match the defaults:
+                           .' -deblockalpha 0 -deblockbeta 0'
+                           ;
+        }
+    # Audio codec name changes between ffmpeg versions
+        my $acodec = $self->can_encode('libfaac') ? 'libfaac' : 'aac';
+    # Don't forget the audio, etc.
+        $self->{'ffmpeg_xtra'} = $ffmpeg_xtra
+                                ." -acodec $acodec -ar 48000 -async 1"
+                                .$self->param('ab', $self->{'a_bitrate'});
+    # Execute the (final pass) encode
+        $self->SUPER::export($episode, '.mp4');
+    }
+
+1;  #return true
+
+# vim:ts=4:sw=4:ai:et:si:sts=4
+
diff --git a/abs/core-testing/nuvexport/PKGBUILD b/abs/core-testing/nuvexport/PKGBUILD
index e414b1e..9db2c4e 100644
--- a/abs/core-testing/nuvexport/PKGBUILD
+++ b/abs/core-testing/nuvexport/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=nuvexport
 pkgver=20080311
 relnum=0.5
-pkgrel=1
+pkgrel=2
 pkgdesc="Export for MythTV nuv files to other formats (DVD/SVCD/DivX,etc.)"
 arch=(i686 x86_64)
 url="http://forevermore.net/files/nuvexport"
@@ -15,7 +15,7 @@ conflicts=()
 replaces=()
 backup=()
 install=
-source=(http://forevermore.net/files/nuvexport/$pkgname-$relnum-0.$pkgver.svn.tar.bz2 $pkgname-ipod-disable.patch)
+source=(http://forevermore.net/files/nuvexport/archive/$pkgname-$relnum-0.$pkgver.svn.tar.bz2 $pkgname-ipod-disable.patch MP4.pm)
 md5sums=('2d0a99623f06394daf3bf8769536d3cd' 'acd2dad9987e68359ead8b0be5e5797c')
 
 build() {
@@ -28,4 +28,5 @@ build() {
   mkdir $startdir/pkg/usr || return 1
   make install || return 1
   sed -i "s|/tmp/fifodir|/var/tmp/fifodir|g" $startdir/pkg/usr/share/nuvexport/export/*.pm || return 1
+  cp $startdir/src/MP4.pm $startdir/pkg/usr/share/nuvexport/export/ffmpeg/MP4.pm
 }
-- 
cgit v0.12


From 2d8910d6514e8943df18e9fff9019b9971e71721 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 19 Jul 2009 16:49:12 -0700
Subject: FFMPEG from SVN.

---
 abs/core-testing/ffmpeg-svn/PKGBUILD | 59 ++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 abs/core-testing/ffmpeg-svn/PKGBUILD

diff --git a/abs/core-testing/ffmpeg-svn/PKGBUILD b/abs/core-testing/ffmpeg-svn/PKGBUILD
new file mode 100644
index 0000000..3144dfb
--- /dev/null
+++ b/abs/core-testing/ffmpeg-svn/PKGBUILD
@@ -0,0 +1,59 @@
+# Contributor: raubkopierer <mail[dot]sensenmann[at]googlemail[dot]com>
+
+pkgname=ffmpeg-svn
+pkgver=18717
+pkgrel=1
+pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
+arch=('i686' 'x86_64')
+url="http://ffmpeg.mplayerhq.hu/"
+license=('GPL')
+depends=('lame' 'sdl' 'faad2' 'faac' 'zlib' 'imlib2' 'x264' 'libtheora')
+makedepends=('subversion')
+provides=("ffmpeg=`date +%Y%m%d`")
+conflicts=('ffmpeg')
+source=()
+md5sums=()
+
+_svntrunk=svn://svn.ffmpeg.org/ffmpeg/trunk
+_svnmod=ffmpeg
+
+build() {
+  cd "$srcdir"
+
+  if [ -d $_svnmod/.svn ]; then
+    (cd $_svnmod && svn up -r $pkgver)
+  else
+    svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+  fi
+
+  msg "SVN checkout done or server timeout"
+  msg "Starting make..."
+
+  rm -rf "$_svnmod-build"
+  mkdir "$_svnmod-build"
+  cd "$_svnmod-build"
+
+  "$srcdir/$_svnmod/configure" \
+  --prefix=/usr \
+  --enable-gpl \
+  --enable-nonfree \
+  --enable-libmp3lame \
+  --enable-libfaac \
+  --enable-libfaad \
+  --enable-libx264 \
+  --enable-libtheora \
+  --enable-postproc \
+  --enable-shared \
+  --enable-pthreads \
+  --enable-x11grab \
+  --arch=`uname -m` \
+  --enable-libxvid \
+  || return 1
+
+  make || return 1
+  make doc/ff{mpeg,play,server}.1 || return 1
+
+  make DESTDIR="$pkgdir" install || return 1
+  make DESTDIR="$pkgdir" install-man || return 1
+
+}
-- 
cgit v0.12


From 5ab926984c6f18fcff5fa95bb8708a89fa708b79 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 19 Jul 2009 16:49:27 -0700
Subject: Removed ffmpeg.

---
 abs/core-testing/ffmpeg/PKGBUILD    | 48 -------------------------------------
 abs/core-testing/ffmpeg/__changelog |  2 --
 2 files changed, 50 deletions(-)
 delete mode 100644 abs/core-testing/ffmpeg/PKGBUILD
 delete mode 100644 abs/core-testing/ffmpeg/__changelog

diff --git a/abs/core-testing/ffmpeg/PKGBUILD b/abs/core-testing/ffmpeg/PKGBUILD
deleted file mode 100644
index 2b63545..0000000
--- a/abs/core-testing/ffmpeg/PKGBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# $Id: PKGBUILD 24006 2009-01-11 23:04:11Z eric $
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-# Maintainer: Paul Mattal <paul@archlinux.org>
-
-pkgname=ffmpeg
-pkgver=20081220
-pkgrel=3
-pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
-arch=(i686 x86_64)
-url="http://ffmpeg.mplayerhq.hu/"
-license=('LGPL')
-depends=('lame' 'sdl' 'libvorbis' 'faad2>=2.6.1' 'faac' 'xvidcore' 'zlib' 'imlib2' 'x264>=20090108' 'libtheora')
-#remake snapshot with: svn export svn://svn.mplayerhq.hu/ffmpeg/trunk@14236
-source=(ftp://ftp.archlinux.org/other/ffmpeg/ffmpeg-${pkgver}-16503.tar.bz2)
-md5sums=('3df85782e9fbbb4a40c6b807baaf6808')
-
-build() {
-  cd "$srcdir/$pkgname" || return 1
-
-  ./configure \
-  --prefix=/usr \
-  --enable-gpl \
-  --enable-libmp3lame \
-  --enable-libvorbis \
-  --enable-libfaac \
-  --enable-libfaad \
-  --enable-libxvid \
-  --enable-libx264 \
-  --enable-libtheora \
-  --enable-postproc \
-  --enable-shared \
-  --enable-pthreads \
-  --enable-x11grab \
-  --enable-swscale \
-  || return 1
-
-  make || return 1
-  make doc/ff{mpeg,play,server}.1 || return 1
-
-  make DESTDIR="$pkgdir" install install-man || return 1
-
-  # since makepkg currently declines to strip .a files, do this for now
-  strip --strip-debug $startdir/pkg/usr/lib/*.a || return 1
-  mkdir $startdir/pkg/usr/share/ffmpeg
-  cp $startdir/src/ffmpeg/ffpresets/* $startdir/pkg/usr/share/ffmpeg
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/ffmpeg/__changelog b/abs/core-testing/ffmpeg/__changelog
deleted file mode 100644
index b27f318..0000000
--- a/abs/core-testing/ffmpeg/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-CHW 5/25/09
-Added ffpresets to package.
-- 
cgit v0.12