From b634ffbdf44f00c91b8163ee66d8df3dee75ed69 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 12 Dec 2012 11:42:31 -0600
Subject: LinHES-system: if fluxbox is the Windowmanager, then symlink ~
 .fluxbox to /usr/share/fluxbox_settings

---
 abs/core/LinHES-system/LinHES-session | 17 +++++++++++++++++
 abs/core/LinHES-system/PKGBUILD       |  2 +-
 2 files changed, 18 insertions(+), 1 deletion(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index 0b35e89..a5632fd 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -110,6 +110,17 @@ function keylaunch(){
 
 }
 
+function fluxbox_settings(){
+    if [ ! -e $HOME/.fluxbox ]
+    then
+        echo "setting symlink fluxbox"
+        configdir=/usr/share/fluxbox_settings
+        ln -s $configdir /root/.fluxbox
+    fi
+
+}
+
+
 
 function load_nvidia_settings(){
     lsmod |cut -f1 -d" " |grep -q nvidia
@@ -399,6 +410,12 @@ then
     WM=fluxbox
 fi
 
+if [ $WM = "fluxbox" ]
+then
+    fluxbox_settings
+fi
+
+
 #if using mythvantage style, start the WM right away
 # this is done so that starting mythtv can loop.
 $WM &
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 7497028..0ebf41a 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -79,7 +79,7 @@ build() {
 
 
 }
-md5sums=('06bc649bce56c22b9a1f56890e0765b6'
+md5sums=('d35912d6b6b267bc6616205fa4776833'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
-- 
cgit v0.12