From d0b37ccccc013118824437c8afdf3c48dd4d6530 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 19 Jan 2017 21:41:00 +0000
Subject: lighttpd: update 1.4.45

---
 abs/core/lighttpd/PKGBUILD         | 27 ++++++---------------------
 abs/core/lighttpd/lighttpd.conf    | 18 ++++++++++--------
 abs/core/lighttpd/lighttpd.install |  4 ++++
 3 files changed, 20 insertions(+), 29 deletions(-)

diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index d389ecd..d7405ab 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=lighttpd
-pkgver=1.4.39
+pkgver=1.4.45
 pkgrel=1
 pkgdesc='A secure, fast, compliant and very flexible web-server'
 license=('custom')
@@ -15,8 +15,8 @@ optdepends=('libxml2: mod_webdav' \
             'libmysqlclient: mod_mysql_vhost' \
             'sqlite3: mod_webdav' \
             'gdbm: mod_trigger_b4_dl')
-backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf' 'etc/lighttpd/conf.include' 'etc/lighttpd/html.include')
-options=('!libtool' 'emptydirs')
+backup=('etc/lighttpd/auth-inc.conf' 'etc/lighttpd/conf.include' 'etc/lighttpd/html.include')
+options=('emptydirs')
 source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.gz"
         'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' 'ssl-inc.conf'
         'lighttpd.tmpfiles')
@@ -58,28 +58,13 @@ package() {
 	install -D -m644 ${srcdir}/ssl-inc.conf ${pkgdir}/etc/lighttpd/ssl-inc.conf
     install -D -m644 ${srcdir}/lighttpd.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/lighttpd.conf
 
-	# set sane defaults
-	sed -e 's|/srv/www/htdocs/|/srv/http/|' \
-	    -e 's|/srv/www/|/srv/http/|' \
-	    -e 's|#server.username            = "wwwrun"|server.username            = "http"|' \
-	    -e 's|#server.groupname           = "wwwrun"|server.groupname           = "http"|' \
-	    -e 's|#server.pid-file            = "/run/lighttpd.pid"|server.pid-file            = "/run/lighttpd/lighttpd.pid"|' \
-	    -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
-            -e 's|"^/mythweb|"^/{1,2}mythweb|' \
-            -e 's|#                               "mod_proxy",|                               "mod_proxy",|' \
-            -e 's|#                               "mod_ssi",|                               "mod_ssi",|' \
-            -e 's|#ssi.extension              = ( ".shtml" )|ssi.extension              = ( ".shtml" )|' \
-	    -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
-
-        /usr/bin/touch ${pkgdir}/etc/lighttpd/{conf,html}.include || return 1
-        /bin/echo 'include "/etc/lighttpd/conf.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
-        /bin/echo 'include "/etc/lighttpd/html.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+    /usr/bin/touch ${pkgdir}/etc/lighttpd/{conf,html}.include || return 1
 
 	install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
 }
-md5sums=('b49e133a4b321921331eba5a343872ab'
+md5sums=('98b97852441fc6b1942dfa9cf5c0beba'
          '42d106b101d21ffd76ed9f3f1621e164'
-         '7945bd60801295010e9e2cac1dba78b7'
+         '1ff60252037689b0419e4c11af34b1ef'
          '62779511e3f1127c3cc9b94c49f99c29'
          'ef64c496602b182a551416a8ba6b3d43'
          '1aeda5526e2cf1ca99d6e1571a6d9cf5')
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index 0d8becd..4d84dba 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -1,10 +1,8 @@
+#######################################################################
 # lighttpd configuration file
 #
-# use it as a base for lighttpd 1.0.0 and above
-#
-# $Id: lighttpd.conf,v 1.7 2004/11/03 22:26:05 weigon Exp $
-
-############ Options you really have to take care of ####################
+# /etc/lighttpd/lighttpd.conf
+#######################################################################
 
 ## modules to load
 # at least mod_access and mod_accesslog should be loaded
@@ -28,7 +26,7 @@ server.modules              = (
 #                               "mod_userdir",
                             "mod_cgi",
 #                               "mod_compress",
-#                               "mod_ssi",
+                            "mod_ssi",
 #                               "mod_usertrack",
 #                               "mod_expire",
 #                               "mod_secdownload",
@@ -242,10 +240,11 @@ fastcgi.server = (
 #### CGI module
 cgi.assign        = ( ".pl"  => "/usr/bin/perl",
                     ".cgi" => "/usr/bin/perl",
-                    ".sh"  => "/bin/bash",
+                    ".sh"  => "/usr/bin/bash",
                     ".py"  => "/usr/bin/python2")
-alias.url = ( "/unicorn" => "/data/srv/httpd/supercorn" )
+
 alias.url += ( "/cgi-bin" => "/data/srv/httpd/cgi-bin/")
+
 $HTTP["url"] =~ "^/cgi-bin" {
     cgi.assign = ( "" => "" )
     }
@@ -267,3 +266,6 @@ $HTTP["url"] =~ "^/cgi-bin" {
 #include_shell "echo var.a=1"
 ## the above is same as:
 #var.a=1
+
+include "/etc/lighttpd/conf.include"
+include "/etc/lighttpd/html.include"
diff --git a/abs/core/lighttpd/lighttpd.install b/abs/core/lighttpd/lighttpd.install
index 1b0a4d7..3526b71 100755
--- a/abs/core/lighttpd/lighttpd.install
+++ b/abs/core/lighttpd/lighttpd.install
@@ -2,7 +2,11 @@ post_install() {
     if [[ ! -d run/lighttpd ]]; then
         usr/bin/systemd-tmpfiles --create lighttpd.conf
     fi
+
+    echo "Generate lighttpd include..."
     gen_light_include.py
+    echo "Forcing a re-read of lighttpd's configuration file..."
+    /sbin/sv hup /service/lighttpd
 }
 
 post_upgrade() {
-- 
cgit v0.12