From 346120bb7c2c5b9df8ef885bf67349da9f6c6c04 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 1 Feb 2011 03:41:08 +0000
Subject: mythweb: patch modules path in mythweb.php. Ref #752

---
 abs/core/mythtv/stable-0.24/mythweb/PKGBUILD          | 13 ++++++++-----
 abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch | 11 +++++++++++
 2 files changed, 19 insertions(+), 5 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch

diff --git a/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD
index 59ba653..ad0f776 100644
--- a/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythweb
 pkgver=0.24
-pkgrel=9
+pkgrel=12
 pkgdesc="Web interface for MythTV's backend"
 url="http://www.mythtv.org"
 license="GPL"
@@ -9,8 +9,8 @@ arch=('i686' 'x86_64')
 depends=('mythtv>=0.24' 'lighttpd' 'php' 'local-website')
 groups=('mythtv-extras')
 
-patches=()
-source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo${patches[@]:0}`)
+patches=('mythweb.php.patch')
+source=('ftp://ftp.knoppmyth.net/R6/sources/mythweb-0.24-fixes.tar.bz2' `echo ${patches[@]:0}`)
 
 DOCROOT=/data/srv/httpd/htdocs/mythweb
 _gitroot="https://github.com/mythtv/mythweb.git"
@@ -25,7 +25,7 @@ build() {
 	do
 		echo applying $i
 		echo "-----------------------------"
-		patch -Np0  -i ${startdir}/src/$i  || return 1
+		patch -Np0  -i ${srcdir}/$i  || return 1
 	done
 	echo "--------------------------done applying patches-----------------------------------------------"
 	
@@ -39,4 +39,7 @@ build() {
 	chmod g+rw $pkgdir/$DOCROOT/{image_cache,php_sessions,data}
 
 }
-md5sums=('45703fa3899c4ee84d1b087bfcc6654e')
+
+
+md5sums=('45703fa3899c4ee84d1b087bfcc6654e'
+         '51a502491a7fa444ec24516cd0669997')
diff --git a/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch b/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch
new file mode 100644
index 0000000..4525e68
--- /dev/null
+++ b/abs/core/mythtv/stable-0.24/mythweb/mythweb.php.patch
@@ -0,0 +1,11 @@
+--- mythweb.php.orig	2011-02-01 03:33:56.000000000 +0000
++++ mythweb.php	2011-02-01 03:34:20.000000000 +0000
+@@ -30,7 +30,7 @@
+     if (Modules::getModule($Path[0])) {
+     // Add the current module directory to our search path, so modules can
+     // define includes, etc.
+-        ini_set('include_path', ini_get('include_path').':'.modules_path.'/'.$Path[0]);
++        ini_set('include_path', ini_get('include_path').':'.modules.'/'.$Path[0]);
+     // Load the module handler
+         require_once 'handler.php';
+     }
-- 
cgit v0.12


From 374f2f59e92d04addc69bd30f80bc480b208e414 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 1 Feb 2011 03:51:21 +0000
Subject: php: Fix mysql.default_socket in php.ini Ref #753

---
 abs/core/php/PKGBUILD    | 5 ++---
 abs/core/php/__changelog | 2 ++
 abs/core/php/php.ini     | 2 +-
 3 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/abs/core/php/PKGBUILD b/abs/core/php/PKGBUILD
index e36353f..28bd83f 100644
--- a/abs/core/php/PKGBUILD
+++ b/abs/core/php/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=php
 pkgname=('php' 'php-cgi' 'php-pear')
 pkgver=5.3.3
-pkgrel=6
+pkgrel=7
 _suhosinver=${pkgver}-0.9.10
 pkgdesc='A high-level scripting language'
 arch=('i686' 'x86_64')
@@ -181,8 +181,7 @@ package_php-pear() {
                 [ ! -e "$i" ] || rm -rf "$i"
         done < <(find ${pkgdir} -name '.*')
 }
-
 md5sums=('21ceeeb232813c10283a5ca1b4c87b48'
          'b66b27c43b1332400ef8982944c3b95b'
-         '8ced1a21457e3d513425617667eb8588'
+         '25bf81e701f7914a3d8472a5636640e7'
          '96ca078be6729b665be8a865535a97bf')
diff --git a/abs/core/php/__changelog b/abs/core/php/__changelog
index 5c87426..592eff9 100644
--- a/abs/core/php/__changelog
+++ b/abs/core/php/__changelog
@@ -9,3 +9,5 @@ php.ini -jm
 
 split package into "php" "php-cgi" and "php-pear" -mh
 php-pear replaces PearLog -mh
+
+php.ini:  mysql.default_socket = /var/run/mysqld/mysqld.sock  Ref #753 -mh
diff --git a/abs/core/php/php.ini b/abs/core/php/php.ini
index 5ef9d1d..50413b9 100644
--- a/abs/core/php/php.ini
+++ b/abs/core/php/php.ini
@@ -730,7 +730,7 @@ mysql.default_port =
 
 ; Default socket name for local MySQL connects.  If empty, uses the built-in
 ; MySQL defaults.
-mysql.default_socket =
+mysql.default_socket = /var/run/mysqld/mysqld.sock
 
 ; Default host for mysql_connect() (doesn't apply in safe mode).
 mysql.default_host =
-- 
cgit v0.12


From ac3fbe0fb10fcaa30d2a7cfb616bfadee79e7cc9 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 1 Feb 2011 22:29:57 +0000
Subject: screen: rebuilt pkg against elfutils. Ref #754

---
 abs/extra/community/screen/PKGBUILD | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/abs/extra/community/screen/PKGBUILD b/abs/extra/community/screen/PKGBUILD
index f97df4b..d8a60ca 100644
--- a/abs/extra/community/screen/PKGBUILD
+++ b/abs/extra/community/screen/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=screen
 pkgver=4.0.3
-pkgrel=6
+pkgrel=7
 _ptygroup=5 #the UID of our PTY/TTY group
 pkgdesc="Full-screen window manager that multiplexes a physical terminal"
 license=('GPL')
@@ -26,6 +26,11 @@ build() {
        --enable-rxvt_osc --with-pty-group=$_ptygroup \
        --mandir=/usr/share/man
   make || return 1
+}
+
+package() {
+  cd ${startdir}/src/${pkgname}-${pkgver}
+
   make DESTDIR=${startdir}/pkg install || return 1
   mkdir -p ${startdir}/pkg/etc/pam.d 
   install -m644 ${startdir}/src/screen.pam ${startdir}/pkg/etc/pam.d/screen
-- 
cgit v0.12