From d0af857767a037cde058a9bf61552861f1c3506e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 16 Jul 2015 00:59:32 +0000
Subject: mythinstall: add Plex Media Server

---
 .../MythVantage-app/mythinstall/installsettings.cpp        | 14 +++++++++++++-
 .../MythVantage-app/mythinstall/installsettings.h          |  1 +
 abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp  |  2 ++
 abs/core/mythinstall/PKGBUILD                              |  2 +-
 4 files changed, 17 insertions(+), 2 deletions(-)

diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 41b67c6..adc9430 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -1163,7 +1163,16 @@ static HostCheckBox *HostPLEXHT()
     HostCheckBox *gc = new HostCheckBox("HostPLEXHT");
     gc->setLabel(QObject::tr("Plex Home Theater"));
     gc->setValue(false);
-    gc->setHelpText(QObject::tr("Plex organizes all of your personal media, wherever you keep it, so you can enjoy it on any device."));
+    gc->setHelpText(QObject::tr("Plex Home Theater is a full-featured, powerful App that connects to the Plex Media Server and is designed to be used in the living room from the comfort of your lounge."));
+    return gc;
+};
+
+static HostCheckBox *HostPLEXMS()
+{
+    HostCheckBox *gc = new HostCheckBox("HostPLEXMS");
+    gc->setLabel(QObject::tr("Plex Media Server"));
+    gc->setValue(false);
+    gc->setHelpText(QObject::tr("Plex is a centralized home media playback system with a powerful central server - the Plex Media Server - that streams its media to many Plex player Apps."));
     return gc;
 };
 
@@ -4005,6 +4014,7 @@ void writesettings ()
     hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
     hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
     hostparm.ThisHostPLEXHT = gCoreContext->GetSetting("HostPLEXHT");
+    hostparm.ThisHostPLEXMS = gCoreContext->GetSetting("HostPLEXMS");
 
     hostparm.ThisHostfoldingathome = gCoreContext->GetSetting("Hostfoldingathome");
     hostparm.ThisHostfoldingusername = gCoreContext->GetSetting("Hostfoldingusername");
@@ -4339,6 +4349,7 @@ void writesettings ()
     myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
     myfile << "kodi=\"" + hostparm.ThisHostXBMC + "\"\n";
     myfile << "plexhometheater=\"" + hostparm.ThisHostPLEXHT + "\"\n";
+    myfile << "plexmediaserver=\"" + hostparm.ThisHostPLEXMS + "\"\n";
     myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome  + "\"\n";
     myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername  + "\"\n";
     myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize  + "\"\n";
@@ -4763,6 +4774,7 @@ MythInstallSettings::MythInstallSettings()
                 //GridShowPlugin4->addChild(HostXine());
                 GridShowPlugin4->addChild(HostHuluDesktop());
                 GridShowPlugin4->addChild(HostPLEXHT());
+                GridShowPlugin4->addChild(HostPLEXMS());
                 GridShowPlugin4->addChild(Hostwebmin());
                 GridShowPlugin4->addChild(Hostwebonlinhes());
                 GridShowPlugin4->addChild(HostXBMC());
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index cd2983b..62b2500 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -525,6 +525,7 @@ struct HostParms
     QString ThisHostwebonlinhes;
     QString ThisHostXBMC;
     QString ThisHostPLEXHT;
+    QString ThisHostPLEXMS;
     QString ThisHostHuluDesktop;
 
     QString ThisHostpluginmythgameMame;
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
index 4c243b5..95a0bd0 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
@@ -331,6 +331,7 @@ int main(int argc, char **argv)
                                                 "mythzoneminder",
                                                 "huludesktop",
                                                 "plex-home-theater",
+                                                "plex-media-server",
                                                 "kodi",
                                                 "webmin",
                                                 "web-on-linhes",
@@ -356,6 +357,7 @@ int main(int argc, char **argv)
                                             "Hostpluginmythzoneminder",
                                             "HostHuluDesktop",
                                             "HostPLEXHT",
+                                            "HostPLEXMS",
                                             "HostXBMC",
                                             "Hostwebmin",
                                             "Hostwebonlinhes",
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index 0a52a24..54e6266 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.3
-pkgrel=8
+pkgrel=10
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
-- 
cgit v0.12