From ae1bd59670b5cc296524d1d66fabdcbebca58d5b Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 21 Mar 2010 12:53:37 -0500
Subject: wxgtk: updated to 2.8.10.1

ref 508
---
 abs/extra-testing/wxgtk/ChangeLog      | 22 ++++++++++++
 abs/extra-testing/wxgtk/PKGBUILD       | 35 ++++++++++--------
 abs/extra-testing/wxgtk/gsocket.patch  | 18 ++++++++++
 abs/extra-testing/wxgtk/overflow.patch | 66 ++++++++++++++++++++++++++++++++++
 4 files changed, 127 insertions(+), 14 deletions(-)
 create mode 100644 abs/extra-testing/wxgtk/gsocket.patch
 create mode 100644 abs/extra-testing/wxgtk/overflow.patch

diff --git a/abs/extra-testing/wxgtk/ChangeLog b/abs/extra-testing/wxgtk/ChangeLog
index 03e9f96..ac2030d 100644
--- a/abs/extra-testing/wxgtk/ChangeLog
+++ b/abs/extra-testing/wxgtk/ChangeLog
@@ -1,3 +1,25 @@
+2009-10-20  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.10.1-5
+	* Added mediactrl support (close FS#15377)
+	* Added glib2 build patch
+	* Improved description
+
+2009-07-11  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.10.1-4
+	* Added security fix (close FS#15469)
+
+2009-05-21  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.10.1-1
+	* Upstream update
+
+2009-05-05  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.10-1
+	* Upstream update
+
 2009-03-06  Eric Belanger  <eric@archlinux.org>
 
 	* wxgtk 2.8.9.2-1
diff --git a/abs/extra-testing/wxgtk/PKGBUILD b/abs/extra-testing/wxgtk/PKGBUILD
index d98ac43..c4a16be 100644
--- a/abs/extra-testing/wxgtk/PKGBUILD
+++ b/abs/extra-testing/wxgtk/PKGBUILD
@@ -1,32 +1,39 @@
-# $Id: PKGBUILD 29177 2009-03-06 09:02:47Z eric $
+# $Id: PKGBUILD 63766 2010-01-18 14:31:06Z pierre $
 # Maintainer: Eric Belanger <eric@archlinux.org>
 # Original Contributor: Tom Newsom <Jeepster@gmx.co.uk>
 # New Version - Contributor: Bob Finch <w9ya@arrl.net>
 # with help from J. Santiago Hirschfeld <jsantiagoh@yahoo.com.ar> aka Angelus
 
 pkgname=wxgtk
-pkgver=2.8.9.2
-pkgrel=2
-pkgdesc="wxGTK - GTK+ implementation of wxWidgets API for GUI"
+pkgver=2.8.10.1
+pkgrel=6
+pkgdesc="GTK+ implementation of wxWidgets API for GUI"
 arch=('i686' 'x86_64')
 url="http://wxwidgets.org"
 license=('custom:wxWindows')
-depends=('gtk2>=2.12.11' 'mesa' 'libjpeg')
-#makedepends=('libgnomeprintui')
+depends=('gtk2' 'mesa' 'gstreamer0.10-base')
+makedepends=('gstreamer0.10-base-plugins' 'gconf' 'ccache')
+options=('ccache') # required to build libwx_gtk2u_mmedia
 #source=(http://downloads.sourceforge.net/wxwindows/wxGTK-${pkgver}.tar.bz2)
-source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2)
-md5sums=('e3d89746af98b9279e4ff39a57f6dc63')
-sha1sums=('a0d58d8b9606d04a35b9853da15eb7dfb08d5637')
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2 \
+        overflow.patch gsocket.patch)
+md5sums=('65d5ef166f23fe8b4c67f58df164f93e' '325dba65152bc0cfbc1400a2bf54508e'\
+         'b56113a94125e4f9a3cc2680052bdfde')
+sha1sums=('6598fbafd979a91f20100171fa23a91779f6dc62' '7c4d1d507aad0b7c25a0de55234be42ea3e3f55f'\
+         '5b0e985afd77153e8e4b9e14987d4b1a9de53acc')
 
 build() {
-  cd ${srcdir}/wxPython-src-${pkgver}
+  cd "${srcdir}/wxPython-src-${pkgver}"
+#  cd "${srcdir}/wxGTK-${pkgver}"
+  patch -p4 < ../overflow.patch || return 1
+  patch -p1 < ../gsocket.patch || return 1
   ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
-	  --enable-graphics_ctx --without-gnomeprint --disable-optimize || return 1
+    --enable-graphics_ctx  --disable-optimize --enable-mediactrl || return 1
   make || return 1
   make -C locale allmo || return 1
-  make DESTDIR=${pkgdir} install || return 1
+  make DESTDIR="${pkgdir}" install || return 1
   cd contrib/src
   make || return 1
-  make DESTDIR=${pkgdir} install || return 1
-  install -D -m644 ../../docs/licence.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+  make DESTDIR="${pkgdir}" install || return 1
+  install -D -m644 ../../docs/licence.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
 }
diff --git a/abs/extra-testing/wxgtk/gsocket.patch b/abs/extra-testing/wxgtk/gsocket.patch
new file mode 100644
index 0000000..0f1fc7b
--- /dev/null
+++ b/abs/extra-testing/wxgtk/gsocket.patch
@@ -0,0 +1,18 @@
+Index: 2.8/src/gtk/gsockgtk.cpp
+===================================================================
+--- 2.8/src/gtk/gsockgtk.cpp (revision 60599)
++++ 2.8/src/gtk/gsockgtk.cpp (working copy)
+@@ -15,8 +15,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++// newer versions of glib define its own GSocket but we unfortunately use this
++// name in our own (semi-)public header and so can't change it -- rename glib
++// one instead
++#define GSocket GlibGSocket
+ #include <gdk/gdk.h>
+ #include <glib.h>
++#undef GSocket
+
+ #include "wx/gsocket.h"
+ #include "wx/unix/gsockunx.h"
diff --git a/abs/extra-testing/wxgtk/overflow.patch b/abs/extra-testing/wxgtk/overflow.patch
new file mode 100644
index 0000000..543bdff
--- /dev/null
+++ b/abs/extra-testing/wxgtk/overflow.patch
@@ -0,0 +1,66 @@
+Index: /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagpng.cpp
+===================================================================
+--- /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagpng.cpp (revision 53479)
++++ /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagpng.cpp (revision 60875)
+@@ -569,5 +569,7 @@
+         goto error;
+ 
+-    lines = (unsigned char **)malloc( (size_t)(height * sizeof(unsigned char *)) );
++    // initialize all line pointers to NULL to ensure that they can be safely
++    // free()d if an error occurs before all of them could be allocated
++    lines = (unsigned char **)calloc(height, sizeof(unsigned char *));
+     if ( !lines )
+         goto error;
+@@ -576,9 +578,5 @@
+     {
+         if ((lines[i] = (unsigned char *)malloc( (size_t)(width * (sizeof(unsigned char) * 4)))) == NULL)
+-        {
+-            for ( unsigned int n = 0; n < i; n++ )
+-                free( lines[n] );
+             goto error;
+-        }
+     }
+ 
+Index: /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp
+===================================================================
+--- /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp (revision 48694)
++++ /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp (revision 60876)
+@@ -262,5 +262,4 @@
+ 
+     uint32 w, h;
+-    uint32 npixels;
+     uint32 *raster;
+ 
+@@ -276,7 +275,18 @@
+                             samplesInfo[0] == EXTRASAMPLE_UNASSALPHA));
+ 
+-    npixels = w * h;
+-
+-    raster = (uint32*) _TIFFmalloc( npixels * sizeof(uint32) );
++    // guard against integer overflow during multiplication which could result
++    // in allocating a too small buffer and then overflowing it
++    const double bytesNeeded = w * h * sizeof(uint32);
++    if ( bytesNeeded >= 4294967295U /* UINT32_MAX */ )
++    {
++        if ( verbose )
++            wxLogError( _("TIFF: Image size is abnormally big.") );
++
++        TIFFClose(tif);
++
++        return false;
++    }
++
++    raster = (uint32*) _TIFFmalloc( bytesNeeded );
+ 
+     if (!raster)
+Index: /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp
+===================================================================
+--- /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp (revision 60876)
++++ /wxWidgets/branches/WX_2_8_BRANCH/src/common/imagtiff.cpp (revision 60897)
+@@ -277,5 +277,5 @@
+     // guard against integer overflow during multiplication which could result
+     // in allocating a too small buffer and then overflowing it
+-    const double bytesNeeded = w * h * sizeof(uint32);
++    const double bytesNeeded = (double)w * (double)h * sizeof(uint32);
+     if ( bytesNeeded >= 4294967295U /* UINT32_MAX */ )
+     {
-- 
cgit v0.12