From 7fe52fda6fdd65ddc683f860fee93488fea06a55 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Nov 2022 18:13:47 -0500
Subject: python-timeout-decorator: initial inclusion

---
 linhes/python-timeout-decorator/PKGBUILD | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 linhes/python-timeout-decorator/PKGBUILD

diff --git a/linhes/python-timeout-decorator/PKGBUILD b/linhes/python-timeout-decorator/PKGBUILD
new file mode 100644
index 0000000..16d9f89
--- /dev/null
+++ b/linhes/python-timeout-decorator/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: robertfoster
+
+_name=timeout-decorator
+pkgname=python-${_name}
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Timeout decorator for Python"
+arch=('i686' 'x86_64' 'armv6')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://github.com/pnpnpn/timeout-decorator"
+license=('MIT')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/t/${_name}/${_name}-$pkgver.tar.gz")
+
+build() {
+  cd "$srcdir/${pkgname#python-}-$pkgver"
+
+  python setup.py build
+}
+
+package() {
+  cd "$srcdir/${pkgname#python-}-$pkgver"
+
+  python setup.py install \
+    --root="$pkgdir" \
+    --optimize=1
+}
+
+md5sums=('8545649e70b3ca43bcff11f08a996c3e')
-- 
cgit v0.12