From b0aa31e7f719efa8c818d0a9c56b35444b27c794 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 9 Nov 2010 01:21:21 +0000
Subject: mythtv: fixed menus?

---
 abs/core/mythtv/stable-0.24/PKGBUILD               | 14 +++++------
 .../mythtv/stable-0.24/menu-xml/mainmenu.xml.patch | 18 +++++++-------
 abs/core/mythtv/stable-0.24/smolt_jump.patch       | 28 ++++------------------
 3 files changed, 21 insertions(+), 39 deletions(-)

diff --git a/abs/core/mythtv/stable-0.24/PKGBUILD b/abs/core/mythtv/stable-0.24/PKGBUILD
index a00c1b6..002c6c1 100755
--- a/abs/core/mythtv/stable-0.24/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/PKGBUILD
@@ -6,7 +6,7 @@
 
 pkgname=mythtv
 pkgver=0.24
-pkgrel=1
+pkgrel=2
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org/"
@@ -24,7 +24,7 @@ groups=('pvr')
 #MAKEFLAGS="-j6"
 install='mythtv.install'
 patchs=()
-#patchs=('smolt_jump.patch')
+patchs=('smolt_jump.patch')
 optdepends=('xmltv: to download tv listings')
 #replaces=('mythtv-contrib')
 #conflicts=('mythtv-contrib')
@@ -62,10 +62,10 @@ build() {
         find bindings/python contrib -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
 
         # clean up from last build
-        echo " simple configure to make sure the distclean works"
-        ./configure
-        make distclean
-        echo "our configure"
+       # echo " simple configure to make sure the distclean works"
+       # ./configure
+       # make distclean
+       # echo "our configure"
 
   ARCH=${CARCH/_/-}
   ./configure --prefix=/usr --cpu=${ARCH} \
@@ -80,7 +80,6 @@ build() {
               --enable-opengl-vsync \
               --with-bindings=perl,python --python=python2 || return 1
 
-#  qmake mythtv.pro || return 1
   make all || return 1
 }
 
@@ -114,6 +113,7 @@ package() {
 }
 md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
          '2babd4b8e146a7538d18dcd55695b0be'
+         'a837de9ccc201994320071e48952b17d'
          'f735805a80b0d1180dee01f9df1b7004'
          'f407d6af23e74a49540755420f84fa58'
          '5469d9921b726db750b991c87d226158')
diff --git a/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch b/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
index 2ea90d7..0491803 100644
--- a/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
+++ b/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
@@ -1,5 +1,5 @@
---- themes/defaultmenu/mainmenu.xml.orig	2010-11-06 00:39:35.000000000 +0000
-+++ themes/defaultmenu/mainmenu.xml	2010-11-06 00:41:27.000000000 +0000
+--- themes/defaultmenu/mainmenu.xml.orig	2010-11-08 22:30:08.000000000 +0000
++++ themes/defaultmenu/mainmenu.xml	2010-11-08 22:35:51.000000000 +0000
 @@ -2,6 +2,13 @@
  <mythmenu name="MAIN">
  
@@ -14,11 +14,10 @@
          <type>MENU_MEDIA_LIBRARY</type>
          <text>Media Library</text>
          <action>MENU library.xml</action>
-@@ -30,18 +37,4 @@
-         <depends>mythmusic mythvideo mytharchive mythburn</depends>
+@@ -31,17 +38,10 @@
      </button>
  
--    <button>
+     <button>
 -        <type>TV_WATCH_TV</type>
 -        <text>Watch TV</text>
 -        <description>Watch live television</description>
@@ -26,10 +25,13 @@
 -    </button>
 -
 -    <button>
--        <type>MENU_UTILITIES_SETUP</type>
+         <type>MENU_UTILITIES_SETUP</type>
 -        <text>Utilities / Setup</text>
 -        <description>Configure MythTV and plugins</description>
 -        <action>MENU util_menu.xml</action>
--    </button>
--
++        <text>Service Menu</text>
++        <description>Configure your system</description>
++        <action>MENU linhes.xml</action>
+     </button>
+ 
  </mythmenu>
diff --git a/abs/core/mythtv/stable-0.24/smolt_jump.patch b/abs/core/mythtv/stable-0.24/smolt_jump.patch
index 0fc452a..76f884c 100644
--- a/abs/core/mythtv/stable-0.24/smolt_jump.patch
+++ b/abs/core/mythtv/stable-0.24/smolt_jump.patch
@@ -1,30 +1,10 @@
-Index: programs/mythfrontend/networkcontrol.cpp
-===================================================================
---- programs/mythfrontend/networkcontrol.cpp	(revision 19291)
-+++ programs/mythfrontend/networkcontrol.cpp	(working copy)
-@@ -83,6 +83,7 @@
+--- programs/mythfrontend/networkcontrol.cpp.orig	2010-11-08 23:07:04.000000000 +0000
++++ programs/mythfrontend/networkcontrol.cpp	2010-11-08 23:08:06.000000000 +0000
+@@ -88,6 +88,7 @@
      jumpMap["zoneminderliveview"]    = "ZoneMinder Live View";
      jumpMap["zoneminderevents"]      = "ZoneMinder Events";
      jumpMap["snapshot"]              = "ScreenShot";
 +    jumpMap["mythsmolt"]             = "MythSmolt";
  
-     // These jump point names match the (lowercased) locations from gContext
      jumpMap["channelrecpriority"]    = "Channel Recording Priorities";
-@@ -191,7 +192,7 @@
-     pthread_create(&command_thread, NULL, CommandThread, this);
- 
-     gContext->addListener(this);
--    
-+
-     connect(this, SIGNAL(newConnection()), this, SLOT(newConnection()));
- }
- 
-@@ -307,7 +308,7 @@
-         cs = new QTextStream(s);
-         cs->setCodec("UTF-8");
-     }
--    
-+
-     if (client)
-     {
-         closedOldConn = true;
+     jumpMap["viewscheduled"]         = "Manage Recordings / Fix Conflicts";
-- 
cgit v0.12