From f8b2cc5b6a69d47f762d36e8beb3f3cdeffb512a Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 16 Jul 2017 15:43:33 +0000
Subject: python-setuptools-scm: initial inclusion. dep of flexget

---
 .../python_modules/python-setuptools-scm/PKGBUILD  | 68 ++++++++++++++++++++++
 .../python-setuptools-scm/__changelog              |  2 +
 2 files changed, 70 insertions(+)
 create mode 100644 abs/core/python_modules/python-setuptools-scm/PKGBUILD
 create mode 100644 abs/core/python_modules/python-setuptools-scm/__changelog

diff --git a/abs/core/python_modules/python-setuptools-scm/PKGBUILD b/abs/core/python_modules/python-setuptools-scm/PKGBUILD
new file mode 100644
index 0000000..c874b8b
--- /dev/null
+++ b/abs/core/python_modules/python-setuptools-scm/PKGBUILD
@@ -0,0 +1,68 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgbase=python-setuptools-scm
+pkgname=(python2-setuptools-scm)
+pkgver=1.15.6
+pkgrel=1
+pkgdesc="Handles managing your python package versions in scm metadata."
+arch=('any')
+url="https://github.com/pypa/setuptools_scm"
+license=('MIT')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest' 'mercurial' 'git' 'python2-pip')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/pypa/setuptools_scm/archive/v$pkgver.tar.gz")
+sha512sums=('c97669232a492e19bdb073c48f9e792ee029ee2af2191da65461436e2a66a3adf5ad490f0a1429c33a5574d4afeb0d54afedfe78f581fff890ecfc787d08ef5a')
+
+prepare() {
+  cp -a setuptools_scm-$pkgver{,-py2}
+
+  export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+}
+
+build() {
+#  cd "$srcdir"/setuptools_scm-$pkgver
+#  python setup.py build
+#  python setup.py egg_info
+
+  cd "$srcdir"/setuptools_scm-$pkgver-py2
+  python2 setup.py build
+  python2 setup.py egg_info
+}
+
+check() {
+  # Hack entry points by installing it
+
+#  cd "$srcdir"/setuptools_scm-$pkgver
+#  python setup.py install --root="$PWD/tmp_install" --optimize=1
+#  SETUPTOOLS_SCM_PRETEND_VERSION= PYTHONPATH="$PWD/tmp_install/usr/lib/python3.6/site-packages:$PYTHONPATH" py.test
+
+  cd "$srcdir"/setuptools_scm-$pkgver-py2
+  python2 setup.py install --root="$PWD/tmp_install" --optimize=1
+  SETUPTOOLS_SCM_PRETEND_VERSION= PYTHONPATH="$PWD/tmp_install/usr/lib/python2.7/site-packages:$PYTHONPATH" py.test2
+}
+
+package_python-setuptools-scm() {
+  depends=('python-setuptools')
+  provides=('python-setuptools_scm')
+  conflicts=('python-setuptools_scm')
+  replaces=('python-setuptools_scm')
+
+  cd "$srcdir"/setuptools_scm-$pkgver
+  python setup.py install --root "$pkgdir"
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-setuptools-scm() {
+  depends=('python2-setuptools')
+  provides=('python2-setuptools_scm')
+  conflicts=('python2-setuptools_scm')
+  replaces=('python2-setuptools_scm')
+
+  cd "$srcdir"/setuptools_scm-$pkgver-py2
+  python2 setup.py install --root "$pkgdir"
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/abs/core/python_modules/python-setuptools-scm/__changelog b/abs/core/python_modules/python-setuptools-scm/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-setuptools-scm/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+
-- 
cgit v0.12