From db68aaa902f3d435d7e931834b6bebe670140b41 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 6 Apr 2016 21:04:08 +0000
Subject: LinHES-system: add_storage.py: reconstruct_sg only chown and chmod
 for the new dir not the whole mount

---
 abs/core/LinHES-system/PKGBUILD       | 4 ++--
 abs/core/LinHES-system/add_storage.py | 7 ++++---
 2 files changed, 6 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 0f38617..4aa1d94 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.4
-pkgrel=3
+pkgrel=4
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -100,7 +100,7 @@ md5sums=('c03d5e54f00e404c561c7dc69fff9168'
          'bc69a520add58ede9b060c73e67ace13'
          '74e17d6f7453c52d56fecaed5c3f6ad5'
          '47e093e8cfe4b5b96602358e1f540832'
-         'b5a73816813b8a9ca17338ce02e580ae'
+         'e270f46a1737a52e8f6b915830ef65f7'
          '8ed2474fa52775769255cfb0dba00a1a'
          '7753c7ce3f0db5944b7372f5d19bb374'
          '2c005d95312018bef80092136f80f254'
diff --git a/abs/core/LinHES-system/add_storage.py b/abs/core/LinHES-system/add_storage.py
index d97c96e..260421f 100755
--- a/abs/core/LinHES-system/add_storage.py
+++ b/abs/core/LinHES-system/add_storage.py
@@ -779,16 +779,17 @@ def reconstruct_storagegroups():
             print "    Creating directory structure:"
             print "       %s" %mount_point
             for y in FS_LIST:
-                print "          %s" %y
                 new_dir="%s/%s" %(mount_point,y)
                 try:
                     os.stat(new_dir)
+                    print "          %s - exists" %y
                 except:
                     os.makedirs(new_dir)
-                    cmd="chown -R mythtv:mythtv /%s" %mount_point
+                    cmd="chown -R mythtv:mythtv /%s" %new_dir
                     runcmd(cmd)
-                    cmd="chmod -R 775 /%s" %mount_point
+                    cmd="chmod -R 775 /%s" %new_dir
                     runcmd(cmd)
+                    print "          %s - created" %y
 
             print "    Adding storage groups to DB"
             if mmount is True:
-- 
cgit v0.12