From 852b4b881b2b940f3cf96c70842913b8b53b89a3 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 11 Nov 2010 02:06:33 +0000
Subject: lighttpd: update to 1.4.28

---
 abs/core/lighttpd/PKGBUILD    | 46 +++++++++++++++++++++----------------------
 abs/core/lighttpd/__changelog |  2 ++
 2 files changed, 24 insertions(+), 24 deletions(-)

diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index ed6d01e..e85681b 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -2,8 +2,8 @@
 # Maintainer: Pierre Schmitz <pierre@archlinux.de>
 
 pkgname=lighttpd
-pkgver=1.4.26
-pkgrel=16
+pkgver=1.4.28
+pkgrel=1
 pkgdesc='A secure, fast, compliant and very flexible web-server'
 license=('custom')
 arch=('i686' 'x86_64')
@@ -14,19 +14,14 @@ optdepends=('libxml2: mod_webdav' \
             'e2fsprogs: mod_webdav' \
             'libmysqlclient: mod_mysql_vhost' \
             'sqlite3: mod_webdav' \
-            'gdbm: mod_trigger_b4_dl' \
-            )
+            'gdbm: mod_trigger_b4_dl')
 backup=(etc/lighttpd/lighttpd.conf etc/logrotate.d/lighttpd etc/lighttpd/auth-inc.conf etc/lighttpd/conf.include etc/lighttpd/html.include)
 options=('!libtool' 'emptydirs')
 source=("http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${pkgver}.tar.bz2" \
-        'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf' \
-        'openssl-0.9.8m.patch')
+        'lighttpd.rc.d' 'lighttpd.logrotate.d' 'lighttpd.conf' 'auth-inc.conf')
 #install='lighttpd.install'
 build() {
-	cd $srcdir/$pkgname-$pkgver
-
-        # fixed in 1.4.27
-        patch -p2 -i ${srcdir}/openssl-0.9.8m.patch || return 1
+	cd ${srcdir}/${pkgname}-${pkgver}
 
 	./configure --prefix=/usr \
 		--libexecdir=/usr/lib/lighttpd/modules \
@@ -47,15 +42,19 @@ build() {
 		--with-memcache \
 		--with-lua || return 1
 	make || return 1
-	make DESTDIR=$pkgdir install || return 1
+}
+
+package() {
+        cd ${srcdir}/${pkgname}-${pkgver}
+	make DESTDIR=${pkgdir} install || return 1
 
-	install -D -m755 ../lighttpd.rc.d $pkgdir/etc/rc.d/lighttpd
-	install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
-	install -d -m755 -o http -g http $pkgdir/var/run/lighttpd/
-	install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
+	install -D -m755 ../lighttpd.rc.d ${pkgdir}/etc/rc.d/lighttpd
+	install -D -m644 ../lighttpd.logrotate.d ${pkgdir}/etc/logrotate.d/lighttpd
+	install -d -m755 -o http -g http ${pkgdir}/var/run/lighttpd/
+	install -d -m755 -o http -g http ${pkgdir}/var/log/lighttpd/
 
-	install -D -m644 ../lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
-	install -D -m644 ../auth-inc.conf $pkgdir/etc/lighttpd/auth-inc.conf
+	install -D -m644 ../lighttpd.conf ${pkgdir}/etc/lighttpd/lighttpd.conf
+	install -D -m644 ../auth-inc.conf ${pkgdir}/etc/lighttpd/auth-inc.conf
 
 	# set sane defaults
 	sed -e 's|/srv/www/htdocs/|/srv/http/|' \
@@ -70,15 +69,14 @@ build() {
             -e 's|#ssi.extension              = ( ".shtml" )|ssi.extension              = ( ".shtml" )|' \
 	    -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
 
-        /bin/touch $pkgdir/etc/lighttpd/{conf,html}.include || return 1
-        /bin/echo 'include "/etc/lighttpd/conf.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
-        /bin/echo 'include "/etc/lighttpd/html.include"' >> $pkgdir/etc/lighttpd/lighttpd.conf || return 1
+        /bin/touch ${pkgdir}/etc/lighttpd/{conf,html}.include || return 1
+        /bin/echo 'include "/etc/lighttpd/conf.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+        /bin/echo 'include "/etc/lighttpd/html.include"' >> ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
 
-	install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+	install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
 }
-md5sums=('a682c8efce47a2f4263a247ba0813c9b'
+md5sums=('586eb535d31ac299652495b058dd87c4'
          'bd690eee0d9e51857448770a151023b0'
          '857e174643fd7761a2f0d8431a679f6c'
          '11fbec7ff7ca1b0d5575445681e8f60e'
-         'c6e361131000ceec085f40b310ef4a2c'
-         '84c884b8dadd724afe2bc6529e9d4485')
+         'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index 0fe6415..71151d9 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -12,3 +12,5 @@ bummped to version 13 to test redmine #690
 
 # by mihanson
 Added etc/lighttpd/conf.include and etc/lighttpd/html.include to backup array
+
+upgrade to 1.4.28
-- 
cgit v0.12