From 82e0075da281324532b01233e480cd16760c8fcf Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 25 Jan 2012 20:17:03 -0600
Subject: reverts a mishap commit  to udev

---
 abs/core/udev/81-CD_DVD_symlinks.rules | 23 +++++++++++++++++++
 abs/core/udev/81-LinHES.rules          | 42 ----------------------------------
 abs/core/udev/81-OSS_Emulation.rules   |  6 +++++
 abs/core/udev/81-dvicoIR.rules         | 18 +++++++++++++++
 abs/core/udev/PKGBUILD                 | 18 +++++++++++----
 abs/core/udev/__changelog              | 14 ++++++++++++
 abs/core/udev/changelog                |  7 ------
 7 files changed, 74 insertions(+), 54 deletions(-)
 create mode 100644 abs/core/udev/81-CD_DVD_symlinks.rules
 delete mode 100644 abs/core/udev/81-LinHES.rules
 create mode 100644 abs/core/udev/81-OSS_Emulation.rules
 create mode 100644 abs/core/udev/81-dvicoIR.rules
 create mode 100644 abs/core/udev/__changelog
 delete mode 100644 abs/core/udev/changelog

diff --git a/abs/core/udev/81-CD_DVD_symlinks.rules b/abs/core/udev/81-CD_DVD_symlinks.rules
new file mode 100644
index 0000000..6d278ac
--- /dev/null
+++ b/abs/core/udev/81-CD_DVD_symlinks.rules
@@ -0,0 +1,23 @@
+# Udev rules for creating CD/DVD symlinks
+# do not edit this file, it will be overwritten on update
+
+
+#####################################
+###### CD/DVD symlinks - begin
+#####################################
+ACTION=="add|change", SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", IMPORT="cdrom_id --export $tempnode"
+ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*", IMPORT="cdrom_id --export $tempnode"
+ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="scd[a-z]", IMPORT="cdrom_id --export $tempnode"
+ENV{ID_CDROM}=="?*", SYMLINK+="cd/cdrom-%b"
+ENV{ID_CDROM_CD_RW}=="?*", SYMLINK+="cd/cdrw-%b"
+ENV{ID_CDROM_DVD}=="?*", SYMLINK+="cd/dvd-%b"
+ENV{ID_CDROM_DVD_R}=="?*", SYMLINK+="cd/dvdrw-%b"
+ACTION=="add|change", SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTR{removable}=="1", ATTRS{media}=="cdrom*", RUN+="cdsymlinks.sh"
+ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*", ATTRS{type}=="5", RUN+="cdsymlinks.sh"
+ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sg[0-9]*", ATTRS{type}=="5", RUN+="cdsymlinks.sh"
+ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="hd[a-z]", RUN+="cdsymlinks.sh"
+ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="sr[0-9]*", RUN+="cdsymlinks.sh"
+ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="sg[0-9]*", RUN+="cdsymlinks.sh"
+#####################################
+###### CD/DVD symlinks - end
+#####################################
diff --git a/abs/core/udev/81-LinHES.rules b/abs/core/udev/81-LinHES.rules
deleted file mode 100644
index 112c46d..0000000
--- a/abs/core/udev/81-LinHES.rules
+++ /dev/null
@@ -1,42 +0,0 @@
-# Udev rules for LinHES
-# do not edit this file, it will be overwritten on update
-#
-# There are a number of modifiers that are allowed to be used in some
-# of the different fields. They provide the following subsitutions:
-#
-# %n the "kernel number" of the device.
-#    For example, 'sda3' has a "kernel number" of '3'
-# %k the kernel name for the device.
-# %M the kernel major number for the device
-# %m the kernel minor number for the device
-# %b the bus id for the device
-# %c the string returned by the PROGRAM
-# %s{filename} the content of a sysfs attribute.
-# %% the '%' char itself.
-#
-# There are a number of modifiers that are allowed to be used in some of the
-# fields.  See the udev man page for a full description of them.
-
-# OSS Emulation SOUND addon modules
-SUBSYSTEM=="sound", RUN+="/sbin/modprobe snd-pcm-oss"
-SUBSYSTEM=="sound", RUN+="/sbin/modprobe snd-seq-oss"
-
-#####################################
-###### CD/DVD symlinks - begin
-#####################################
-ACTION=="add|change", SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", IMPORT="cdrom_id --export $tempnode"
-ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*", IMPORT="cdrom_id --export $tempnode"
-ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="scd[a-z]", IMPORT="cdrom_id --export $tempnode"
-ENV{ID_CDROM}=="?*", SYMLINK+="cd/cdrom-%b"
-ENV{ID_CDROM_CD_RW}=="?*", SYMLINK+="cd/cdrw-%b"
-ENV{ID_CDROM_DVD}=="?*", SYMLINK+="cd/dvd-%b"
-ENV{ID_CDROM_DVD_R}=="?*", SYMLINK+="cd/dvdrw-%b"
-ACTION=="add|change", SUBSYSTEMS=="ide", KERNEL=="hd[a-z]", ATTR{removable}=="1", ATTRS{media}=="cdrom*", RUN+="cdsymlinks.sh"
-ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sr[0-9]*", ATTRS{type}=="5", RUN+="cdsymlinks.sh"
-ACTION=="add|change", SUBSYSTEMS=="scsi", KERNEL=="sg[0-9]*", ATTRS{type}=="5", RUN+="cdsymlinks.sh"
-ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="hd[a-z]", RUN+="cdsymlinks.sh"
-ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="sr[0-9]*", RUN+="cdsymlinks.sh"
-ACTION=="remove", SUBSYSTEMS=="block", KERNEL=="sg[0-9]*", RUN+="cdsymlinks.sh"
-#####################################
-###### CD/DVD symlinks - end
-#####################################
diff --git a/abs/core/udev/81-OSS_Emulation.rules b/abs/core/udev/81-OSS_Emulation.rules
new file mode 100644
index 0000000..373537e
--- /dev/null
+++ b/abs/core/udev/81-OSS_Emulation.rules
@@ -0,0 +1,6 @@
+# Udev rules for OSS Emulation
+# do not edit this file, it will be overwritten on update
+
+# OSS Emulation SOUND addon modules
+SUBSYSTEM=="sound", RUN+="/sbin/modprobe snd-pcm-oss"
+SUBSYSTEM=="sound", RUN+="/sbin/modprobe snd-seq-oss"
diff --git a/abs/core/udev/81-dvicoIR.rules b/abs/core/udev/81-dvicoIR.rules
new file mode 100644
index 0000000..dcaf081
--- /dev/null
+++ b/abs/core/udev/81-dvicoIR.rules
@@ -0,0 +1,18 @@
+# Udev rules for Dvico remotes
+# do not edit this file, it will be overwritten on update
+
+# This rule is for the Dvico Dual Digital 4 Rev 2. It has 2 IR modules 
+# identified, only the first of which is connected to the receiver.
+# The KERNELS=="*-1" part of this rule makes sure that the first 
+# device is the one that gets the symlink.
+KERNEL=="event*", \
+    KERNELS=="*-1", \
+    ATTRS{manufacturer}=="Dvico", \
+    ATTRS{idVendor}=="0fe9", \
+    ATTRS{idProduct}=="db98", \
+    SYMLINK="input/irremote"
+
+# This rule is for the older style USB DVICO remote dongles.
+SUBSYSTEMS=="usb", KERNEL=="hiddev*", \
+    ATTRS{product}=="DVICO USB HID Remocon V1.00", \
+    SYMLINK+="usb/dvicoIR"
diff --git a/abs/core/udev/PKGBUILD b/abs/core/udev/PKGBUILD
index 996bf6a..4208c7b 100644
--- a/abs/core/udev/PKGBUILD
+++ b/abs/core/udev/PKGBUILD
@@ -7,7 +7,7 @@
 pkgbase="udev"
 pkgname=('udev' 'udev-compat')
 pkgver=171
-pkgrel=4
+pkgrel=5
 arch=(i686 x86_64)
 url="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
 license=('GPL')
@@ -17,7 +17,9 @@ options=(!makeflags !libtool)
 makedepends=('glibc' 'coreutils' 'util-linux' 'pciutils' 'libusb-compat' 'glib2' 'kernel26' 'gperf' 'libxslt' 'gobject-introspection')
 source=(http://www.kernel.org/pub/linux/utils/kernel/hotplug/$pkgbase-$pkgver.tar.bz2
         81-arch.rules
-	81-LinHES.rules
+	81-OSS_Emulation.rules
+	81-dvicoIR.rules
+	81-CD_DVD_symlinks.rules
 	static-audio-nodes-group.patch
 	static-nodes-permissions.patch
         cdsymlinks.sh)
@@ -47,8 +49,12 @@ package_udev() {
   make DESTDIR=${pkgdir} install
   # Install our rule for permissions and symlinks
   install -D -m644 $srcdir/81-arch.rules $pkgdir/lib/udev/rules.d/81-arch.rules
-  # Install LinHES rules
-  install -D -m644 $srcdir/81-LinHES.rules $pkgdir/lib/udev/rules.d/81-LinHES.rules
+  # Install OSS Emulation rules
+  install -D -m644 $srcdir/81-OSS_Emulation.rules $pkgdir/lib/udev/rules.d/81-OSS_Emulation.rules
+  # Install dvicoIR rules
+  install -D -m644 $srcdir/81-dvicoIR.rules $pkgdir/lib/udev/rules.d/81-dvicoIR.rules
+  # Install CD/DVD symlink rules
+  install -D -m644 $srcdir/81-CD_DVD_symlinks.rules $pkgdir/lib/udev/rules.d/81-CD_DVD_symlinks.rules
   # install cdsymlinks.sh
   install -D -m755 $srcdir/cdsymlinks.sh $pkgdir/lib/udev/cdsymlinks.sh
 
@@ -103,7 +109,9 @@ package_udev-compat() {
 }
 md5sums=('bdf4617284be2ecac11767437417e209'
          '6ee44e3feb8e0f037947e7d4ca273f12'
-         'd931178ca56f98f21f733fe535684ef8'
+         '18170020347b181b155ff5a1a8a904b4'
+         '3a920447b11744ecb1b57f0de683db93'
+         '48845542d8250d6f2eddf07944f78014'
          '4f625aea95a5597afd8cdf189421f193'
          'f9e50b8dfcd2215f5423ff9bc04ecf68'
          '2e808ee78d237c478b57af2a68d43769')
diff --git a/abs/core/udev/__changelog b/abs/core/udev/__changelog
new file mode 100644
index 0000000..1881493
--- /dev/null
+++ b/abs/core/udev/__changelog
@@ -0,0 +1,14 @@
+7/10/11 Britney Fransen
+- Added changelog
+- Added 81-LinHES.rules
+- Added 81-LinHES.rules to PKGBUILD
+
+8/9/11 Britney Fransen
+- Add cdsymlinks.sh to PKGBUILD
+
+1/24/2012
+- Renamed changelog to __changelog
+- Added 81-dvicoIR.rules
+- Moved OSS Emulation rules from 81-LinHES.rules to 81-OSS_Emulation.rules
+- Moved CD/DVD rules from 81-LinHES.rules to 81-CD_DVD_symlinks.rules
+- Removed 81-LinHES.rules
diff --git a/abs/core/udev/changelog b/abs/core/udev/changelog
deleted file mode 100644
index 3112650..0000000
--- a/abs/core/udev/changelog
+++ /dev/null
@@ -1,7 +0,0 @@
-7/10/11 Britney Fransen
-- Added changelog
-- Added 81-LinHES.rules
-- Added 81-LinHES.rules to PKGBUILD
-
-8/9/11 Britney Fransen
-- Add cdsymlinks.sh to PKGBUILD
-- 
cgit v0.12