From 6ce9edd775629b6d76408e69629f0058c7014a4a Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 28 Oct 2012 09:48:42 -0500
Subject: LinHES-session: remove .configure even for FE only machines

---
 abs/core/LinHES-system/LinHES-session | 14 +++++++++++++-
 abs/core/LinHES-system/PKGBUILD       |  2 +-
 2 files changed, 14 insertions(+), 2 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index 0c61c6f..2bb27b3 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -1,4 +1,5 @@
 #!/bin/bash
+MYTH_RUN_STATUS="1"
 . /etc/profile
 . /etc/systemconfig
 
@@ -246,7 +247,13 @@ function first_configure_default(){
         msg "Guide data is being loaded. \n Until this completes\n some shows will appear as unknown \n in the program guide."
         rm ~/.configure
         fi
+    else
+        if [  -f ~/.configure ]
+        then
+            rm -f  ~/.configure
+        fi
     fi
+
 }
 
 
@@ -275,6 +282,11 @@ function first_configure_mv(){
          msg "Guide data is being loaded. \nUntil this completes \nsome shows will appear as "unknown" \nin the program guide."
          rm -f ~/.configure
         fi
+    else
+        if [  -f ~/.configure ]
+        then
+            rm  -f ~/.configure
+        fi
     fi
 
 }
@@ -313,7 +325,7 @@ function run_wmctrl(){
     do
         for name in "MythTV Frontend" "MythTV Setup" "mythwelcome"
         do
-            xwininfo -name "$name"
+            xwininfo -name "$name" >/dev/null
             rc=$?
             if [ $rc = 0 ]
             then
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index f1fe894..2606cf0 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -76,7 +76,7 @@ build() {
 
 
 }
-md5sums=('5bd4938cf41b63787aa4cdfd76423e09'
+md5sums=('07ed5c1c4cd6cac2d1307e6c3b71372b'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
-- 
cgit v0.12