From bbc308c7b5c3a2328898b7c484217d6d0df50309 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 19 Dec 2014 17:26:55 +0000
Subject: mupen64plus: update to 2.0

---
 abs/extra/mupen64plus/PKGBUILD           | 33 ++++++++++++++++++++++++++++++++
 abs/not_built/extra/mupen64plus/PKGBUILD | 33 --------------------------------
 2 files changed, 33 insertions(+), 33 deletions(-)
 create mode 100644 abs/extra/mupen64plus/PKGBUILD
 delete mode 100644 abs/not_built/extra/mupen64plus/PKGBUILD

diff --git a/abs/extra/mupen64plus/PKGBUILD b/abs/extra/mupen64plus/PKGBUILD
new file mode 100644
index 0000000..2ab8b1f
--- /dev/null
+++ b/abs/extra/mupen64plus/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus
+pkgver=2.0
+pkgrel=4
+pkgdesc='Nintendo64 Emulator'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mupen64plus/'
+license=('GPL')
+depends=('glu' 'libsamplerate' 'libpng' 'sdl' 'freetype2' 'boost-libs')
+makedepends=('mesa' 'boost')
+source=("http://mupen64plus.googlecode.com/files/mupen64plus-bundle-src-${pkgver}.tar.gz")
+md5sums=('f855b4233faa9616b780c364fc4a9a9a')
+
+build() {
+  cd mupen64plus-bundle-src-${pkgver}
+
+  sh m64p_build.sh
+}
+
+package() {
+  cd mupen64plus-bundle-src-$pkgver
+  
+  # set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
+  ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man' LDCONFIG='true'
+}
+
+# vim: ts=2:sw=2:et
diff --git a/abs/not_built/extra/mupen64plus/PKGBUILD b/abs/not_built/extra/mupen64plus/PKGBUILD
deleted file mode 100644
index c7835c0..0000000
--- a/abs/not_built/extra/mupen64plus/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 78487 2012-10-19 16:17:59Z jelle $
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: Laurent Carlier <lordheavym@gmail.com>
-# Contributor: Allan McRae <allan@archlinux.org>
-# Contributor: Zephyr
-
-pkgname=mupen64plus
-pkgver=1.99.5
-pkgrel=3
-pkgdesc='Nintendo64 Emulator'
-arch=('i686' 'x86_64')
-url='http://code.google.com/p/mupen64plus/'
-license=('GPL')
-depends=('glu' 'libgl' 'libsamplerate' 'libpng' 'sdl' 'freetype2')
-makedepends=('mesa')
-source=("http://mupen64plus.googlecode.com/files/mupen64plus-bundle-src-${pkgver}.tar.gz")
-md5sums=('93772a6d6fc6a63353462deae8a6db71')
-
-build() {
-  cd mupen64plus-bundle-src-${pkgver}
-
-  sh m64p_build.sh
-}
-
-package() {
-  cd mupen64plus-bundle-src-$pkgver
-  
-  # set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
-  ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man/man6' LDCONFIG='true'
-}
-
-# vim: ts=2:sw=2:et
-- 
cgit v0.12