From 8bcf600c40a55beb37de0d7e4d781eb54466dec4 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 27 Feb 2010 12:50:32 -0800
Subject: linhes-scripts:updated upgrade_to_0.22.sh so only a standalone or mbe
 starts the backend to upgrade the schema.

---
 abs/core-testing/linhes-scripts/PKGBUILD           |  2 +-
 abs/core-testing/linhes-scripts/upgrade_to_0.22.sh | 30 ++++++++++++----------
 2 files changed, 17 insertions(+), 15 deletions(-)

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index b9a0495..2424064 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=46
+pkgrel=47
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/core-testing/linhes-scripts/upgrade_to_0.22.sh b/abs/core-testing/linhes-scripts/upgrade_to_0.22.sh
index 01c066d..bedb509 100644
--- a/abs/core-testing/linhes-scripts/upgrade_to_0.22.sh
+++ b/abs/core-testing/linhes-scripts/upgrade_to_0.22.sh
@@ -54,26 +54,28 @@ pacman -Su --noconfirm &>/dev/null
 echo "Restoring Online Streams listings."
 cp /usr/share/mythtv/is.xml.021 /usr/share/mythtv/is.xml
 clear
-echo "Starting the backend.  This will automatically update the schema."
-sv start mythbackend &>/dev/null
-echo "I'll launch an xterm so you watch output backend log."
-echo "Once the schema updates are complete, switch back to this xterm."
-echo -e "\033[1mWhen you see \"Upgrading to MythTV schema version 1244\"\033[0m"
-echo "You can switch back to this xterm."
-echo -e "\033[1mNote:After pressing <ENTER>, I'll be asleep for 30 secs...\033[0m"
-echo -e "\033[1mThis will give the schema time to upgrade.\033[0m"
-pause 'Press <ENTER> to continue...'
-xterm -fn *18* -e tail -f /var/log/mythtv/mythbackend.log &
-#Sleeping for 30 seconds to give the schema time to upgrade....
-sleep 30
-read -p "Press <ENTER> to continue once the schema upgrade is complete."
+if grep -E "Master|Stand" /etc/systemconfig &>/dev/null
+	then
+	echo "Starting the backend.  This will automatically update the schema."
+	sv start mythbackend &>/dev/null
+	echo "I'll launch an xterm so you watch output backend log."
+	echo "Once the schema updates are complete, switch back to this xterm."
+	echo -e "\033[1mWhen you see \"Upgrading to MythTV schema version 1244\"\033[0m"
+	echo "You can switch back to this xterm."
+	echo -e "\033[1mNote:After pressing <ENTER>, I'll be asleep for 30 secs...\033[0m"
+	echo -e "\033[1mThis will give the schema time to upgrade.\033[0m"
+	pause 'Press <ENTER> to continue...'
+	xterm -fn *18* -e tail -f /var/log/mythtv/mythbackend.log &
+	#Sleeping for 30 seconds to give the schema time to upgrade....
+	sleep 30
+	read -p "Press <ENTER> to continue once the schema upgrade is complete."
+fi
 echo -e "\033[1mNow, the frontend will launch to update the schema for any plugins.\033[0m"
 echo -e "\033[1mOnce the this is done, please exit the frontend.\033[0m"
 pause 'Press <ENTER> to continue...'
 xterm -e mythfrontend
 echo "Performing LinHES specific schema updates."
 /usr/LH/bin/update_schema_021_to_022.sh
-cat /etc/LinHES-release > /etc/os_myth_release
 echo "All done!"
 echo -e "\033[5mThanks for choosing LinHES!\033[0m"
 pause "Press <ENTER> to reboot."
-- 
cgit v0.12